Subject: question about IBIS versions

From: Kim Helliwell <[email-masked]>
Date: Tue, 31 Oct 2000 14:43:57 -0800

I have a situation where an IBIS model that was made with s2ibis2, and
is therefore ostensibly a Version 2.1 model, may need a model selector
keyword.

The question is: is changing the version to 3.x and adding the model selector
sufficient, or are there actual changes in the syntax of stuff that's common
between 2.1 and 3.x?

Or are there any other pitfalls in what I'm attempting here?

-- 
Kim Helliwell
Senior CAE Engineer
Acuson Corporation
Phone: 650 694 5030  FAX: 650 943 7260

---

From: Bob Ross <[email-masked]>
Date: Tue, 31 Oct 2000 15:19:41 -0800

Kim:

In general, the Version of IBIS needs to be brought up to
the level of the highest version keyword or sub-parameter
within the file.  This will allow it to pass ibischk3 at
the proper version level (which could be 1.1, 2.1 or 3.2).
In your case, just changing the Version number to 3.2 should
be sufficient when adding [Model Selector].

Because of the upward compatibility goal, no other changes
are necessary.

Bob Ross
Mentor Graphics