Subject: IBIS BIRD62.2 Comments and Questions

From: Bob Ross <[email-masked]>
Date: Thu, 10 Feb 2000 15:32:00 -0800

To All:

Here are some BIRD62.2 comments and questions.  These
comments still suggest preserving the technical content
of BIRD62.2

Bob Ross
Mentor Graphics

1.  General:  JEDEC provideds some specific parameters for
component specification.  There are a lot of interacting
sensitivities and tolerances.  How should designers use them
in real designs, and what should EDA tools do with them
for two situations?  Below is one approach.  Is there a
more simple way of using these parameters?

Reference Supply reference: 

  Vinh_ac, Vinh_dc, Vinl_dc, Vinl_ac referenced to these Vth
  calculations for typ, min, and max column corner analysis:

  Typ:   1 test:   Vth

  Min:   2 tests:  Vth_min scaled to MIN voltage reference
                   Vth_max scaled to MIN voltage reference

  Max    2 tests:  Vth_min scaled to MAX voltage reference
                   Vth_max scaled to MAX voltage reference 

External Supply reference: 

  Vinh_ac, Vinh_dc, Vinl_dc, Vinl_ac referenced to these Vth
  calculations for typ, min, and max column corner analysis:

  Typ:   1 test:   Vth

  Min:   2 tests:  Vth_min scaled to MIN external reference
                   Vth_max scaled to MAX external voltage reference

  Max    2 tests:  Vth_min scaled to MIN external reference
                   Vth_max scaled to MAX external reference 

The remaining questions address some details.

2.  Does JEDEC expect these parameters to be defined
at the die or at the pin?  Are they insensitive to 
ground and power bounce effects if Vref is tied to
VDDQ?

3. Input_Ref_Supply.  If a supply is given, then the
syntax should support all four available references

  Power_clamp_ref
  Gnd_clamp_ref
  Pullup_ref
  Pulldown_ref
  Ext_ref

These are more explicit references.  The [Pin Mapping]
keyword already sets the precedence that the explicit
power rails should be named.  VOLTAGE_RANGE can be
ambiguous and should not be used since Pullup_ref
and/or Power_clamp_ref functionally can override
voltage range if all/either are given.

For input structures, normally the power clamp
reference might be used, not the pullup reference.
The pullup reference might not be defined.

3.  Generally I do not like mixing differential and
single-ended specifications because it might be
possible to have the external reference at 0 V and
also some devices can be configured as single-ended
or differential.

4.  The [External Reference] keyword discription should
have some additional text clarifying that the min and
max columns DO NOT correspond to the [Model] min and
max columns for the I-V and V-T tables.  The entries
in these columns are the min and max values of the
external reference by magnitude.

5. Cosmetic:  These would be my preferences for 
notation "consistency" throughout IBIS:

Change Input_Ref_Supply to Input_ref_supply or to another
name such as Reference_supply

Change Ext to Ext_ref and use mixed case names suggested
above

  Power_clamp_ref
  Gnd_clamp_ref
  Pullup_ref
  Pulldown_ref

to be consistent with other "selections" in IBIS such as
Open_drain, 3-state, Bus_hold, etc.

The Vth_min and Vth_max notation of min and
max may be confusing since the usage of min and
max is different.  It is really used as a plus
and minus delta value for TYPICAL conditions from
the Vth value under TYPICAL conditions.  Delta
values consistent with delta entries for Vinh_ac
could be considered, although that would change
the Vth(min/max) formula.  Or,the actual values
could still be used, but the name changed to
Vth_upper, Vth_lower.  There are just suggestions
for consideration.

---

From: "D. C. Sessions" <[email-masked]>
Date: Fri, 18 Feb 2000 14:44:40 -0700

> ground and power bounce effects if Vref is tied to

JEDEC, like IBIS, is focused on observable-at-the-pin
parameters.  The threshold guardbands provide room
for the manufacturer to include noise margins.

Someday, this is likely to change from sheer necessity.

-- 
D. C. Sessions
[email-masked]