Subject: Re[2]: Connector spec swathing

From: [email-masked]
Date: Wed, 14 Jun 2000 11:27:43 -0500

So then, the recommendation would be to have the IBIS Connector Model
Specification _explicitly_ state how each simulator will implement the expansion
from the keywords and parameters already given in the specification.

If the recommendation is acceptable (it is for me)...  Would it be acceptable by
the simulator companies?  If not.. is there a different option?

In the discussion of this topic in the subcommittee, I got the impression that
the expansion method of matrices was somewhat seen as a proprietary technology. 
As such, I wanted to build in enough keywords and usage rules that would allow
me to assign values that would _lessen_ the likelihood of incorrect simulator
implementation  (assuming of course that I correctly defined the model, swath
size, and related keywords...)

I will take this up at our next IBIS Connector Model subcommittee
teleconference.

_gus: 630-527-4617

____________________Reply Separator____________________
Subject:    Re: Connector spec swathing
Author: chris <[email-masked]>
Date:       6/14/00 9:13 AM

Mike,

Thanks for your illustration of my point.  Clearly we have
exactly the same concern.

Gus,

Yes, including the larger matrix that is supposed to be expandable
to a full banded matrix would be useful, but it should also include
instructions on just how that smaller matrix is supposed to be used
to get the full banded matrix.

Thanks,

Chris
<SNIP>

---

From: "Matthew Flora" <[email-masked]>
Date: Wed, 14 Jun 2000 10:37:19 -0700

Gus,

(IMHO) I think this is another case of the users and the spec writers having
different perspectives.

The users assume that whomever wrote the spec must have had some idea in mind
on how the swath would be converted to a full matrix, otherwise the spec
hasn't been well thought out.  (Meaning that if the spec writer doesn't know
how to do it, what makes them think anyone does?)  The users go on to think
that as long as the spec writer has this underlying scheme, why not publish
the scheme to reduce misunderstandings.

The spec writer, on the other hand, is trying not to restrict the
implementation to what they had in mind since someone else might have an
equally clever, yet completely different way of doing it.

This came up before on discussions of some of the BIRDS for specifying changes
in delay values based upon slope and over shoot of input voltages.  Bob Ross
ended up saying that he would probably implement the scheme differently than
the spec writer, but would like to know what the spec writer had in mind if
for no other reason than to prove that it could be done.

Keep up the good work,
Matthew Flora

----- Original Message -----
From: <[email-masked]>
To: "chris" <[email-masked]>
Cc: "Mike LaBonte" <[email-masked]>; "IBIS Mailing list"
<[email-masked]>
Sent: Wednesday, June 14, 2000 9:27 AM
Subject: Re[2]: Connector spec swathing

---

From: Christopher Reid <[email-masked]>
Date: Wed, 14 Jun 2000 13:11:31 -0700

Gus,

I don't consider any of this proprietary.  I think its more important
that its unambiguous so there is confidence that the intention of the
connector vendors is followed when using the models.  Every simulator
should use the same method.

Thanks,

Chris

---

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 14 Jun 2000 13:53:51 -0700

Hi Chris,

I am having great difficultly understanding why
all the simulators should be forced to use the same method.

This is an approximate approach in the first place.  If one
simulator wants to use a method that runs 100,000 times faster
than another with a 1% accuracy reduction than it should
be able to do that.

I feel the data must be unambiguous.  The method should be
open to the simulator experts.  I do think it reasonable to
provide one example method either as a description or as
code implemented in the IBIS parser.  Perhaps a full matrix
extraction would make the most sense but I can hardly imagine
most simulators wanting to simulate a series of 10 matrices
each 1000 by 1000 just to get 2 coupled signals simulated.

I do not feel all simulators should use the same method.  I
feel most simulators may even want to use different methods
depending on the simulation needs.

> > to get the full banded matrix.

---------------------------------------------------------
Have a great day....
Kellee Crisafulli
HyperLynx, a division of Pads Software Inc.
SI,EMC,X-talk and IBIS tools
E-mail: <mailto:[email-masked]>
web:    <http://www.hyperlynx.com>
---------------------------------------------------------

---

From: Christopher Reid <[email-masked]>
Date: Wed, 14 Jun 2000 14:01:37 -0700

Kellee,

Your point is well taken.  For example, the user may be given
an option of choosing a time step.  For larger time steps
different approximations can be made.

What I would like to see is an unambiguous definition of what
is expected (a prescription of how to use these models.)  Each
vendor can then explain approximations that may be made that
deviate from this expected use in one way or another.

Thanks for the input.  I'm modifying my position to agree
with yours better.

Chris

---

From: Ian Dodd <[email-masked]>
Date: Wed, 14 Jun 2000 17:20:34 -0400

All,
	If there is no recommendation of how to create a 
simulation model from the connector "data sheet" how does
the connector company do basic validation after they have
created a model. 

	Doing speed/accuracy tradeoffs is good, but I think
we need some way to create a golden simulation so the
results can be compared back to measurement.

Ian

---

From: Al Davis <[email-masked]>
Date: Wed, 14 Jun 2000 14:11:21 -0700

Regarding the comments ...
"The spec and parser should generate a full matrix ....."

Matt and Bob hit it.  The spec should show the clearest
method of doing it, to show what it really means.  The
parser should be an example of it, that should work, and be
designed for readability rather than efficiency.

Then, the simulator maker should be able to do it any way
that works and is interchangeable with the original,
hopefully coming up with something better.

In this case, a full matrix is a very inefficient way to do
it.  I would not want to be restricted to such
inefficiency.  However, if the full matrix method is given,
I can use it to validate my "superior" method.  Also, the
"superior" method will probably be less clear to someone
who just wants to know what the spec means.

---

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 14 Jun 2000 15:24:12 -0700

Hi Chris, all,

Seems like we are getting consensus that allowing
any method is OK but we need an example method
for clarity and something that can be used
for validation.  The "golden parser"
seems a logical place to do this.

Let's "make it so"  (Picard, Startrek)

best wishes..
Kellee

---

From: fred <[email-masked]>
Date: Thu, 15 Jun 2000 01:33:07 -0700

I know the connector specification committee has spent much time and effort in
comming up with the specification.  However the current swat matrix approach
seems overly complicated and technically less than desirable.  Why not give the

full matrix and let the simulation SI tool decide which part of the matrix to
choose
for simulation based on what pin and coupling is desired. We (simulation
vendors)
only need the data. We can decide how and when to use what.  What we need is
the committee to do is identify the connector pins to the matrix diagonal
entrys. If
the connector is very large in terms of number of pins then whether one gets a
full
or sparse matrix will depend on the field solver capabilities. This is not
intended to
be critical of the committee which has worked long and hard to come up with a
spec
in the first place while hence keeping everybody happy.

Best Regards,