Subject: Re[2]: Connector spec swathing

From: [email-masked]
Date: Thu, 15 Jun 2000 06:37:10 -0500

Fred,

I am sure that if you have this question, so do others... as such I have
prepared a fairly lengthy reply.

The "basic" answer to the question is...

Find a FIELD simulator that can generate a 100 pin connector model from a
connector with a general current path length of around 2.5cm.

Make sure it is a true 3D simulator.

OK... now find one that can do such using less than 8GB of RAM and 4 xxxx GHz.
processors
  -  This is pretty much what one might call a high end PC/Workstation.  Maybe
even not "typical" hardware.

OK...  Using what has been found above...  have the problem solve in the FIELD
simulator in less than a week.  (BTW, a week is solve time, it does not include
reports, empirical confirmation, or support documentation)

OK...  now put that full matrix model that is generated into a circuit
simulator....  Setup the rest of the problem....  go away for the weekend...
comeback Monday....  still not done...  Comeback Wednesday...  Ooopps  found out
that a termination resistor was misplaced... restart the simulation.

The point is...  connector companies would be perfectly happy with smaller
models...

But from what I have been told my customers which are the same as many SI
simulators NEED to be able to model 50, 100, 200, 500, 1000, 5000 pins... (Yes,
these are all real connector sizes today).

As a work around for this problem.... we suggest the preverbal "critical net
analysis". Which will still take 8 hours to solve using something in the order
of a 40 pin connector model.

Also,  I as a connector manufacture make parts with different circuit sizes...
sometime from 10 to 1000 in 10 pin increments...  OK... there we have 100
models...  Lets say we just go up to 100 pins...  that is 10 models... at 3 days
AVERAGE per model (smaller models take less time)...  that means one month of
FIELD SIMULATION time...  and we STILL  can not support any thing over 100 pins.

 Not to mention that connector companies have about 40,000 different product
lines.. lets say conservatively that only 1% of the 40,000 require models... 
That's 400.... a conservative estimate would be that there are 10 circuit sizes
for each of those 400 connectors...  as such 4,000 different models.  OF EACH
Type.  There are three basic types Single Line models, MultiLine Models, and
Cascaded Models...  then there are TWO VERSIONS of each type... distributed and
lumped...  grand total 24,000 SPECIFIC models.

But wait,  Now model makers and simulators also have to database and revision
control the models.

Point being...  an auto swath will give end uses access to more models with more
pin options than they ever had before (to answer the customers requests). And
GREATLY reduce the redundancies such that the 24,000 models above can be done in
1 model per connector family.. or 400 files.

_gus: 630-527-4617

____________________Reply Separator____________________
Subject:    Re: Connector spec swathing
Author: fred <[email-masked]>
Date:       6/15/00 1:33 AM

I know the connector specification committee has spent much time and effort in
comming up with the specification.  However the current swat matrix approach
seems overly complicated and technically less than desirable.  Why not give the

full matrix and let the simulation SI tool decide which part of the matrix to
choose
for simulation based on what pin and coupling is desired. We (simulation
vendors)
only need the data. We can decide how and when to use what.  What we need is
the committee to do is identify the connector pins to the matrix diagonal
entrys. If
the connector is very large in terms of number of pins then whether one gets a
full
or sparse matrix will depend on the field solver capabilities. This is not
intended to
be critical of the committee which has worked long and hard to come up with a
spec
in the first place while hence keeping everybody happy.

Best Regards,

Kellee Crisafulli wrote:

> Hi Chris,<SNIP>

---

From: [email-masked]
Date: Thu, 15 Jun 2000 11:56:05 -0500

For what it is worth...

I have been specifically trying to NOT do empirical confirmations for the ICM
specification.  Why?

*  Accuracy will very based on simulation algorithm.  Different algorithms may
produce different results.  All simulators may not use the same algorithm.  As
such, confirmation to an empirical test will effectively qualify a simulator...
not necessarily the model.

We have well over 10,000 hours spent on methodologies and procedures for
analytical to empirical transmission line model confirmations in SPICE to VNA to
TDR to LCR to crosstalk to ...etc...  I can not afford to do the same
confirmation with each simulator on the market.

*  Empirical test need fixturing.  "Golden fixturing" for correlation level work
requires large amounts of design time... and extreme control over the
manufacturing.  This relates to large amounts of time and dollars required for
PCB design and build.

*  Empirical test needs a test procedure for BOTH the simulation and the
empirical test.  Developing crosstalk, impedance, TDR, inductance, capacitance,
ground bounce, jitter, etc... takes some time.  And just try to get more than
one person to agree on methodologies.  

As such, what I am proposing instead....

**  Generate "Golden Matrices" from a couple of different geometries.

** Berkeley SPICE models can be generated from a "Golden matrix" (or matrices). 
Let's call these golden models.

** These models can be run in Berkeley SPICE using Berkeley source and
termination components.  The Berkeley algorithms are well known/understood.

** Specific circuit configurations can be setup.  Let's call these "Golden Test
Simulations".

**  From the "Golden Tests"... "Golden Waveforms" can be generated.

In this scenario....  we are building "baseline information".

Now... the same "Golden Matrices" used to generate the SPICE models can be
DIRECTLY installed into an ICM.

Now each individual simulator company, end user, other...  can use the "Golden
Matrx" and setup the same "Golden Test Simulations"  and get results for a given
simulator.

These results can be compared to the "Golden Waveforms" as a GENERAL
confirmation.

In the proposed scenario, fixturing and test methodology is not part of the
picture....   This, in my mind, will create an adequate confirmation that is
straight forward and timely in it's implementation.

_gus: 630-527-4617

____________________Reply Separator____________________
Subject:    Re: Connector spec swathing
Author: Ian Dodd <[email-masked]>
Date:       6/14/00 5:20 PM

All,
        If there is no recommendation of how to create a 
simulation model from the connector "data sheet" how does
the connector company do basic validation after they have
created a model. 

        Doing speed/accuracy tradeoffs is good, but I think
we need some way to create a golden simulation so the
results can be compared back to measurement.

Ian

Kellee Crisafulli wrote:
> Hi Chris,
> <SNIP>

---

From: [email-masked]
Date: Thu, 15 Jun 2000 11:56:05 -0500

For what it is worth...

_gus: 630-527-4617

All,

Ian

---

From: "zanella, fabrizio" <[email-masked]>
Date: Fri, 16 Jun 2000 08:18:33 -0400

I agree with Mikhail.  I actually push the connector vendors for smaller
matrices, for 30X30 connector matrices cause very long run times in HSPICE,
even using Ultra 60 Sparcs with 500MB of RAM.  It's very unreasonable to
expect larger than 30X30 connector LRC matrices.
Regards,
Fabrizio Zanella
Hardware Engineering
EMC Corporation
508-435-2075, x14645
FAX: 508-497-8027
[email-masked]

		-----Original Message-----
		From:	Mikhail Khusid
[mailto:[email-masked]]
		Sent:	Thursday, June 15, 2000 2:29 PM
		To:	Chris Rokusek
		Cc:	IBIS Mailing list
		Subject:	RE: Re[2]: Connector spec swathing

		Chris,

		Whether a connector company can make a full matrix model of
a connector
		depends more on the connector than the tools.  In fact, if a
connector is
		complicated enough to warrant several L and C sections, and
if a connector
		has many pins, providing a full matrix model can be very
unpractical.

		As a representative of the connector company where a 570 pin
connector
		is considered a small one, I can assure you that it's
impossible for me
		to generate dozens of 570x570 matrices.  Furthermore, I
doubt that any
		simulator will be able to solve a problem with full matrices
of that size.
		Doing a swath method allows me to generate reasonable size
matrices,
		up to 30x30, which should respresent sufficient couplings
inside
		the connector, and thus is an effective way to simulate the
connector
		behavior in reasonable time.

		Lastly, I agree with Kellee that a standard should probably
include
		a description of a "golden" way to generate a full matrix
model out of a swath,
		however, I would welcome simulator companies attempts to
avoid using
		this method for every connector.

		Michael Khusid
		Teradyne Connection Systems
		http://www.teradyne.com

		"Chris Rokusek" <[email-masked]> on 06/15/2000
12:27:55 PM

		To:   "IBIS Mailing list" <[email-masked]>
		cc:    (bcc: Mikhail Khusid/NNH/Teradyne)
		Subject:  RE: Re[2]: Connector spec swathing

		Gus,

		Given that some companies actually do possess the tools to
create Full
		Matrix connectors (& packages) accurately and efficiently
and given that
		simulators MUST come up with algorithms to reduce this full
matrix (perhaps
		efficiently with an accuracy tradeoff), simulator companies
are just trying
		to avoid extra work in having to write two algorithms that
do very similar
		things--one to expand the swath to arbitrary pins and one to
reduce the full
		matrix to arbitrary pins.  Many of us prefer to solve the
most
		general/accurate problem first (Full Matrix).

		I don't think we're saying "don't use the swath", I think
all we're saying
		is provide us with a recommended algorithm (and perhaps
build it into the
		parser) for expanding the swath into a full matrix so that
each simulator
		can potentially get the same answer for the most general
case.  It seems
		like that would keep everybody happy.

		Chris Rokusek
		Innoveda

		> -----Original Message-----
		> From: [email-masked] [mailto:[email-masked]]
		> Sent: Thursday, June 15, 2000 4:37 AM
		> To: fred
		> Cc: Kellee Crisafulli; IBIS Mailing list
		> Subject: Re[2]: Connector spec swathing
		>
		>
		> Fred,
		>
		> OK... now find one that can do such using less than 8GB of
RAM
		> and 4 xxxx GHz.
		> OK...  Using what has been found above...  have the
problem solve
		> in the FIELD
		> simulator in less than a week.  (BTW, a week is solve
time, it
		> does not include
		> simulator....  Setup the rest of the problem....  go away
for the
		> weekend...
		> comeback Monday....  still not done...  Comeback
Wednesday...
		> Ooopps  found out
		> simulators NEED to be able to model 50, 100, 200, 500,
1000, 5000
		> pins... (Yes,
		> As a work around for this problem.... we suggest the
preverbal
		> "critical net
		> analysis". Which will still take 8 hours to solve using
something
		> in the order
		> Also,  I as a connector manufacture make parts with
different
		> circuit sizes...
		> models...  Lets say we just go up to 100 pins...  that is
10
		> models... at 3 days
		> AVERAGE per model (smaller models take less time)...  that
means
		> one month of
		> FIELD SIMULATION time...  and we STILL  can not support
any thing
		> over 100 pins.
		> That's 400.... a conservative estimate would be that there
are 10
		> circuit sizes
		> for each of those 400 connectors...  as such 4,000
different
		> models.  OF EACH
		> Type.  There are three basic types Single Line models,
MultiLine
		> Models, and
		> Cascaded Models...  then there are TWO VERSIONS of each
type...
		> distributed and
		> But wait,  Now model makers and simulators also have to
database
		> and revision
		> control the models.
		>
		> Point being...  an auto swath will give end uses access to
more
		> models with more
		> pin options than they ever had before (to answer the
customers
		> requests). And
		> GREATLY reduce the redundancies such that the 24,000
models above
		> can be done in
		> I know the connector specification committee has spent
much time
		> and effort in
		> comming up with the specification.  However the current
swat
		> matrix approach
		> seems overly complicated and technically less than
desirable.
		> Why not give the
		>
		> full matrix and let the simulation SI tool decide which
part of
		> the matrix to
		> only need the data. We can decide how and when to use
what.  What
		> we need is
		> the connector is very large in terms of number of pins
then
		> whether one gets a
		> be critical of the committee which has worked long and
hard to
		> come up with a