Subject: Bus Clamp vs Dynamic Clamp

From: "Chris Rokusek" <[email-masked]>
Date: Wed, 8 Mar 2000 14:52:43 -0800

Hi Ibis-gurus,

I've got a question:

I'm wondering what the differences are between:

  1) "Static Mode" of a Dynamic Clamp Sub-model

        vs.

  2) Bus Hold Sub-Model.

If there are no differences, is there any reason we really need the
redundancy and extra confusing verbage defining what Static Mode is?

Chris

---

From: Bob Ross <[email-masked]>
Date: Fri, 10 Mar 2000 12:44:06 -0800

Chris:

Briefly, the Bus Hold submodel always
always operates in the triggered mode
and optionally with an Off_delay.  So
it does not have a Static mode.

Bob Ross
Mentor Graphics

---

From: "Chris Rokusek" <[email-masked]>
Date: Fri, 10 Mar 2000 14:10:09 -0800

Let me rephrase:

If a Static Mode Dynamic Clamp submodel can be described as a Bus Hold
model, why do we need a static mode?

Think about this:

	There are two submodel types.

	Their are multiple modes for each type.

	The submodel itself is a type (in so much as its not a model).

	The submodel type can only be used under certain conditions of the parent
Model.

That's a lot of IF's just to effectively add a node to a circuit.

Customers keep calling asking me to interpret the IBIS Spec.  Therefore, I
conclude the spec must be difficult to understand.

The more TYPE's, RULE's, IF's, and MODE's there are in this spec, the more
difficult it becomes to comprehend and maintain.  Hey look that makes an
acronym:  TRIM!

Of course its MY FAULT just as much as anyone else's for allowing some of
these BIRDS to contain redundancies.  I'm hoping that we become more careful
as to what we are adding to the spec and perhaps we can even reduce and
simplify at some point.

Thanks for reading!

Chris Rokusek
Viewlogic Systems

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, March 10, 2000 12:44 PM
> To: Chris Rokusek
> Cc: Ibis@Eda. Org
> Subject: Re: Bus Clamp vs Dynamic Clamp
>
>
> Chris:
>