Subject: Problems noted with posted v3.2.6 parser -- requires BUG filing?

From: "Mirmak, Michael" <[email-masked]>
Date: Fri, 5 Jan 2001 17:26:30 -0800

The most recent edition of the parser (v.3.2.6, DOS32) seems to have a
problem 
with models which lack a [Pullup] keyword.  It flags models which 
have a Model_type of I/O_open_drain, which would not require [Pullup].

I've enclosed an IBIS model below to demonstrate the warning.  Is this 
warning intentional?  Should this problem be filed as BUG53?

Thanks!

- Michael Mirmak, Intel Corp.

|***********************************************************************
|
[IBIS Ver]       3.2
[File Name]      bug53.ibs
[File Rev]       0.0
[Date]           05-January-2001
[Source]         File created from specification
[Notes]          Using the IBISCHK3 v3.2.6 parser, the following file
                 will generate a single warning regarding the lack of
                 a [Pullup] section.  This warning does not appear in
                 the v.3.2.5 parser's output.  
|
[Disclaimer]
    (C) Copyright 2001 Intel Corp.
    All rights reserved
    This model is for demonstration purposes only,
|
[Component]      GENERIC_IBIS
[Manufacturer]   Intel Corp.
|
[Package]
|                typ        min        max
R_pkg            6.0mO      5.0mO      7.0mO
L_pkg            5.0nH      2.0nH      8.0nH
C_pkg            1.0pF      0.5pF      1.5pF
|
|
[Pin]     signal_name      model_name    R_pin    L_pin    C_pin
    1     TestSignal1       TestModel1
|
|************************************************************************
|
[Model]          TestModel1
Model_type       I/O_open_drain
Polarity         Non-Inverting
Vinl = 800mV
Vinh = 2.0V
|
Cref = 10.0pF
Vref = 0.0
Vmeas = 0.4
C_comp                    5.00pF            4.00pF            6.00pF
|
|
[Temperature Range]       27.00             100.00            0.00
[Voltage Range]           5.0V             4.75V              5.25V
|
[Pulldown]
| voltage     I(typ)              I(min)              I(max)
|
  -5.0000      -40.0m          -34.00m           -45.00m
  -4.0000      -39.0m          -33.00m           -43.00m
   0.0000       0.0m             0.00m             0.00m
   5.0000       40.0m            34.0m            45.00m 
  10.0000       45.0m            40.0m            49.00m
|
|
[GND Clamp]
| voltage     I(typ)              I(min)              I(max)
|
  -5.0000    -3900.0mA         -3800.00mA           -4000.00m
  -0.7000      -80.0m            -75.00m              -85.00m
  -0.6000      -22.0m            -20.00m              -25.00m
  -0.5000       -2.4m             -2.00m               -2.90m
  -0.4000        0.0A              0.0A                 0.00A 
   5.0000        0.0A              0.0A                 0.00A
|
[Power Clamp]
| voltage     I(typ)              I(min)              I(max)
|
  -5.0000     4450.00m            NA                   NA
  -0.7000       95.0m             NA                   NA
  -0.6000       23.0m             NA                   NA
  -0.5000        2.4m             NA                   NA
  -0.4000        0.0m             NA                   NA
   0.0000        0.0m             NA                   NA
|
[Ramp]
|variable        typ              min                  max
dV/dt_r          2.20/1.06n       1.92/1.28n           2.49/650p
dV/dt_f          2.46/1.21n       2.21/1.54n           2.70/770p
R_load = 300ohms
|
|
|************************************************************************
[End]
|
| The new v3.2.6 parser gives the following spurious output:
|
|IBISCHK3 V3.2.6
|
|Checking bug53.ibs for IBIS 3.2 Compatibility...
|
|WARNING - [Model] TestModel1 has no description of the buffer's high state
|         DC drive characteristics (no [Pullup] table).  This warning
|         can be silenced by changing the Model_type or by adding a
|         [Pullup] table.
|
|Errors  : 0
|Warnings: 1
|
|File Passed
|
|
|

---

From: Bob Ross <[email-masked]>
Date: Mon, 08 Jan 2001 15:58:32 -0800

Michael:

It appears that BUG34 may have been implemented incorrectly.
Thank you for reporting this.

This will be filed as BUG53.  As we check ibischk3.2.6,
we might issue ibischk3.2.7 to correct any problems found.

Bob Ross
Mentor Graphics