Subject: Re: Model name question

From: Syed Huq <[email-masked]>
Date: Thu, 12 Jul 2001 17:21:48 -0700 (PDT)

Arpad,

To avoid this problem(which can occur in a simulator), we append the Component 
name to each of the buffer name. That makes the buffer name 'unique'. The user 
can truncate the name to meet the IBIS requirement.

Syed

> From: "Muranyi, Arpad" <[email-masked]>
> To: "[email-masked]'" <[email-masked]>
> Subject: Model name question
> Date: Thu, 12 Jul 2001 14:56:11 -0700
> MIME-Version: 1.0
> 
> All,
> 
> I would like to find out whether there is a need to include the
> component name as part of the buffer names for the [Model]
> keyword in an IBIS file.  The reasoning goes like this:
> 
> If there are two different IBIS files with buffer names inside
> them which are the same (while the electrical characteristics
> of the models are different) and these two models are used in
> the same simulation, could the tool lose track of which one is
> which?
> 
> Do tools make these names unique for simulations to prevent
> this from happening so that me as a model maker wouldn't have
> to worry about this?
> 
> Thanks,
> 
> Arpad
> =================================================================
>

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Fri, 13 Jul 2001 09:27:29 -0700

Thank you all for your responses so far.

However, I feel that my real question was not answered
very clearly.  I would like to get a feel for how many
tools actually do have a problem with the situation
outlined in my original message, and how many tools can
handle it gracefully because of their way of dealing with
these names.  Could the tool vendors respond to this, if no
other way at least privately to me?

Thanks,

Arpad
==========================================================

-----Original Message-----
From: Scott McMorrow [mailto:[email-masked]]
Sent: Thursday, July 12, 2001 5:34 PM
To: Matthew Flora
Cc: [email-masked]
Subject: Re: Model name question

Matthew,

I believe you misunderstood me.
Let me quote myself:

> We need not specify the exact format of the naming convention,
> but we do need to clarify that a model should be identified by
> component_name and model_name, since model_names are
> not unique.

I do not suggest any particular naming and/or scoping convention
for IBIS models.  I do suggest that it be required that some sort
of convention is used and defined by each vendor, so that
name space and revision problems are eliminated.  I suggest that
IBIS specifications require that models be tracked in a way that
naming conficts cannot occur and revision control can be facilitated.

You have just suggested a further clarification to the model naming
problem (i.e. manufacturer).  I believe the following will uniquely
identify an IBIS model in most all cases:
(manufacturer, component_name, model_name, revision)

My experience is that what is not specified is what breaks designs.
I would much rather err on the specification side after 22  years of
design work.  I've used way too many components and software which
use assumptions which are ill-defined, are unpublished to protect the
guility, or are in opposition to common sense.

It's time to dispel the assumption that component designers and
software vendors will do the right thing.

regards,

scott

Matthew Flora wrote:

> Scott, Arpad,
>
> May I suggest that you are headed toward a slippery slope.  One common
name
> conflict with models that the tuples mentioned do not eliminate is second
> source parts from multiple manufacturers.  They might have started with
the
> same model and tweaked it for their process.  If you try to come up with a
> scheme where a single name includes every possible identifying mark, then
> you'll end up with a ridiculously long name.
>
> I suggest leaving it to the tools to keep track of which model they are
> dealing with.  It ain't difficult.  Software has had to do this for a long
> time.  It's not new.  It's not rocket science.
>
> Cheers,
> Matthew Flora
>
> ----- Original Message -----
> From: "Scott McMorrow" <[email-masked]>
> To: "Muranyi, Arpad" <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, July 12, 2001 3:28 PM
> Subject: Re: Model name question
>
> > Arpad,
> >
> > I believe many simulator vendors already identify models
> > internally by the following tuple:
> >
> > (component_name, model_name)
> >
> > I would recommend formalizing this in future IBIS specifications.
> > We need not specify the exact format of the naming convention,
> > but we do need to clarify that a model should be identified by
> > component_name and model_name, since model_names are
> > not unique.
> >
> > If we were all real sticklers, we would require tools to identify
> > a model by the following tuple:
> >
> > (component_name, model_name, revision)
> >
> > Many a time I have been bit by multiple revisions of models laying
> > around ... especially with automatic path searches of model directories,
> > where the last model loaded is the one that is used.
> >
> > regards,
> >
> > scott
> >
> >
> > "Muranyi, Arpad" wrote:
> >
> > > All,
> > >
> > --
> > Scott McMorrow
> > Principal Engineer
> > SiQual, Signal Quality Engineering
> > 18735 SW Boones Ferry Road
> > Tualatin, OR  97062-3090
> > (503) 885-1231
> > http://www.siqual.com
> >
> >

--
Scott McMorrow
Principal Engineer
SiQual, Signal Quality Engineering
18735 SW Boones Ferry Road
Tualatin, OR  97062-3090
(503) 885-1231
http://www.siqual.com