Subject: RE: Case sensitivity?

From: "Beal, Weston" <[email-masked]>
Date: Wed, 18 Jul 2001 14:32:31 -0700

Todd,

This is a small problem of semantics.  Keywords are case-INsensitive, but keywords are also enclosed in square brackets, [].  These words you cited are not in square brackets so they are considered subparameters instead of keywords.  Now the rules change.  Isn't this fun? :)

Later,
Weston

-----Original Message-----
From: Todd Westerhoff [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 12:42 PM
To: [email-masked]
Subject: Case sensitivity?

Hi all,

I'm using IBISCHK V3.2.5 and have noticed that the handling of the keywords

Si_location
Timing_location

seems to be case sensitive, although the IBIS Spec says that keywords are
supposed to be case-insensitive.  Anyone else seen the same thing?

Todd.

Todd Westerhoff
SI Engineer
Hammerhead Networks
5 Federal Street
Billerica, MA  01821
[email-masked]
ph: 978-671-5084

---

From: "Todd Westerhoff" <[email-masked]>
Date: Wed, 18 Jul 2001 18:51:18 -0400

Euruka! You are absolutely right.

You know that this brings up my favorite comment, right?  Which, for the
uninitiated, can be found at:

http://www.cafepress.com/kumar_right

Thanks for the feedback.

Todd ;-)

Todd Westerhoff
SI Engineer
Hammerhead Networks
5 Federal Street
Billerica, MA  01821
[email-masked]
ph: 978-671-5084

-----Original Message-----
From: Beal, Weston [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 5:33 PM
To: [email-masked]'
Subject: RE: Case sensitivity?

Todd,

This is a small problem of semantics.  Keywords are case-INsensitive, but
keywords are also enclosed in square brackets, [].  These words you cited
are not in square brackets so they are considered subparameters instead of
keywords.  Now the rules change.  Isn't this fun? :)

Later,
Weston

-----Original Message-----
From: Todd Westerhoff [mailto:[email-masked]]
Sent: Wednesday, July 18, 2001 12:42 PM
To: [email-masked]
Subject: Case sensitivity?

Hi all,

Si_location
Timing_location

Todd.

Todd Westerhoff
SI Engineer
Hammerhead Networks
5 Federal Street
Billerica, MA  01821
[email-masked]
ph: 978-671-5084

---

From: Al Davis <[email-masked]>
Date: Wed, 18 Jul 2001 16:15:51 -0700

Of course, sometimes you need to be careful.

[Model] is not case sensitive, but Model_type is.

Well ....

Clearly, [Model] and [mOdEl] are equivalent.  They are keywords in 
traditional IBIS.

Clearly, Model_type and Model_tYpE are not.  They are subparameters 
in traditional IBIS.

What about Model_type and mOdEl_type ?