Subject: RE: Model name question

From: "Muranyi, Arpad" <[email-masked]>
Date: Fri, 13 Jul 2001 08:43:52 -0700

Many of the responses kind of did that already, but
here I go anyway:  Will a simulation tool get confused
if there are identical model names in two different
IBIS files used in the same simulation?
 
Arpad
======================================================

-----Original Message-----
From: Abdulrahman Rafiq [mailto:[email-masked]]
Sent: Thursday, July 12, 2001 4:07 PM
To: Muranyi, Arpad
Cc: [email-masked]'
Subject: Re: Model name question

Arpad, 

Do you mind trying to rephrase your question ? 

"Muranyi, Arpad" wrote: 

All, 

I would like to find out whether there is a need to include the 
component name as part of the buffer names for the [Model] 
keyword in an IBIS file.  The reasoning goes like this: 

If there are two different IBIS files with buffer names inside 
them which are the same (while the electrical characteristics 
of the models are different) and these two models are used in 
the same simulation, could the tool lose track of which one is 
which? 

Do tools make these names unique for simulations to prevent 
this from happening so that me as a model maker wouldn't have 
to worry about this? 

Thanks, 

Arpad 
=================================================================

-- 

-------------------------------------------------------------------------

--------------------------------------          -             -          |

| Abdulrahman A. Rafiq (AKA Abbey)   |         ---           ---         | 

| Hardware Engineer                  |       -------        ------       |

| ISBU, Cisco Systems, Inc.          |     -----------    ----------     |

--------------------------------------   ------------------------------  | 

-------------------------------------------------------------------------

---

From: "Todd Westerhoff" <[email-masked]>
Date: Fri, 13 Jul 2001 14:17:35 -0400

No, it won't get confused at all.  But one of the models will be wrong,
unless the toolset has done something to render the component/buffer name
associations unique.  Like prepending the component name to the buffer name,
as in Mike LaBonte's reply.

By default, SPECCTRAQuest uses the prepend method, for what it's worth.

Todd.

Todd Westerhoff
SI Engineer
Hammerhead Networks
5 Federal Street
Billerica, MA  01821
[email-masked]
ph: 978-671-5084

  -----Original Message-----
  From: Muranyi, Arpad [mailto:[email-masked]]
  Sent: Friday, July 13, 2001 11:44 AM
  To: [email-masked]'
  Cc: [email-masked]'
  Subject: RE: Model name question

  Arpad

  -----Original Message-----
  From: Abdulrahman Rafiq [mailto:[email-masked]]
  Sent: Thursday, July 12, 2001 4:07 PM
  To: Muranyi, Arpad
  Cc: [email-masked]'
  Subject: Re: Model name question

  Arpad,

  "Muranyi, Arpad" wrote:

    All,

    Thanks,

    Arpad

---

From: "Jon Powell" <[email-masked]>
Date: Fri, 13 Jul 2001 18:22:58 -0700

You know,
The real issue is usually:
Does the model and part names match up to the users part names in the
schematic capture and layout programs.
You get that right and you will just naturally be changing the names in the
IBIS models.

jon

  -----Original Message-----
  From: Todd Westerhoff [mailto:[email-masked]]
  Sent: Friday, July 13, 2001 11:18 AM
  To: Muranyi, Arpad; [email-masked]
  Cc: [email-masked]
  Subject: RE: Model name question

  Todd.

  Todd Westerhoff
  SI Engineer
  Hammerhead Networks
  5 Federal Street
  Billerica, MA  01821
  [email-masked]
  ph: 978-671-5084

    -----Original Message-----
    From: Muranyi, Arpad [mailto:[email-masked]]
    Sent: Friday, July 13, 2001 11:44 AM
    To: [email-masked]'
    Cc: [email-masked]'
    Subject: RE: Model name question

    Arpad

    -----Original Message-----
    From: Abdulrahman Rafiq [mailto:[email-masked]]
    Sent: Thursday, July 12, 2001 4:07 PM
    To: Muranyi, Arpad
    Cc: [email-masked]'
    Subject: Re: Model name question

    Arpad,

    "Muranyi, Arpad" wrote:

      All,

      Thanks,

      Arpad

---

From: "Todd Westerhoff" <[email-masked]>
Date: Mon, 16 Jul 2001 10:18:01 -0400

You're right of course, in that getting the right model to associate with
the right part is usually the bigegst problem.

But ...

I think the original question assumed that the "schematic to packaged part"
associations had been made correctly, but that two different devices were
using buffer models with the same name, that weren't necessarily the same
buffer types.

You know, the same problems we had in 1997.

Todd.

Todd Westerhoff
SI Engineer
Hammerhead Networks
5 Federal Street
Billerica, MA  01821
[email-masked]
ph: 978-671-5084
  -----Original Message-----
  From: Jon Powell [mailto:[email-masked]]
  Sent: Friday, July 13, 2001 9:23 PM
  To: 'Todd Westerhoff'; [email-masked]
  Subject: RE: Model name question

  You know,
  The real issue is usually:
  Does the model and part names match up to the users part names in the
schematic capture and layout programs.
  You get that right and you will just naturally be changing the names in
the IBIS models.

  jon

    -----Original Message-----
    From: Todd Westerhoff [mailto:[email-masked]]
    Sent: Friday, July 13, 2001 11:18 AM
    To: Muranyi, Arpad; [email-masked]
    Cc: [email-masked]
    Subject: RE: Model name question

    Todd.

    Todd Westerhoff
    SI Engineer
    Hammerhead Networks
    5 Federal Street
    Billerica, MA  01821
    [email-masked]
    ph: 978-671-5084

      -----Original Message-----
      From: Muranyi, Arpad [mailto:[email-masked]]
      Sent: Friday, July 13, 2001 11:44 AM
      To: [email-masked]'
      Cc: [email-masked]'
      Subject: RE: Model name question

      Arpad

      -----Original Message-----
      From: Abdulrahman Rafiq [mailto:[email-masked]]
      Sent: Thursday, July 12, 2001 4:07 PM
      To: Muranyi, Arpad
      Cc: [email-masked]'
      Subject: Re: Model name question

      Arpad,

      "Muranyi, Arpad" wrote:

        All,

        Thanks,

        Arpad