Subject: RE: IBIS 3.2 model error

From: Andrew Holmes <[email-masked]>
Date: Tue, 12 Jun 2001 11:02:41 -0700

I am getting the following error on an IBIS 3.2 LVDS input model when I
run a check. The error is:

<excerpt><excerpt><excerpt><excerpt><excerpt><excerpt><excerpt><excerpt><excerpt><bold><fontfamily><param>Courier</param><bigger>checking
lvdsiflv33c.ibs for IBIS 3.2 Compatibility...

ERROR - Component 'lvdsiflv33c': [Series Pin Mapping] Pin2 '2': model
type cannot be Series or Series_switch.

Errors  : 1

File Failed

</bigger></fontfamily></bold></excerpt></excerpt></excerpt></excerpt></excerpt></excerpt></excerpt></excerpt></excerpt>

Not sure how I should interpret this. The Series model defined looks
correct and so does the Series Pin Mapping as defined by the 3.2 spec. 

Any feedback would be appreciated.

Thanks,

Andy

Andy Holmes

Tality (formerly Cadence Design Systems)

6950 Hollister Avenue, Suite 200

Santa Barbara, CA  93117

PH# 805-571-1206

FAX 805-571-1300

[email-masked]

---

From: "Lance Wang" <[email-masked]>
Date: Tue, 12 Jun 2001 15:10:50 -0400

Hi, Andrew, 
I met the same problem before. This is because,  in the [Series Pin Mapping] section. You have the model name called series_switch or series. It is not a good idea to use them as a model name. But it is legal! You can live with it in Cadence tools.

Try to rename it and see what happens.

I  think this is bug of IBIS GOLDEN PARSER. At least it didn't tell you which problem you met.

-Lance

Liqun Wang (Lance)
Cadence Design Systems, Inc.
PSD High Speed Development
PH:978-446-6685
FAX:978-446-6363

  ----- Original Message ----- 
  From: Andrew Holmes 
  To: [email-masked] 
  Sent: Tuesday, June 12, 2001 2:02 PM
  Subject: RE: IBIS 3.2 model error

  I am getting the following error on an IBIS 3.2 LVDS input model when I run a check. The error is:

                    checking lvdsiflv33c.ibs for IBIS 3.2 Compatibility...

                    ERROR - Component 'lvdsiflv33c': [Series Pin Mapping] Pin2 '2': model type cannot be Series or Series_switch.

                    Errors : 1

                    File Failed

  Not sure how I should interpret this. The Series model defined looks correct and so does the Series Pin Mapping as defined by the 3.2 spec. 

  Thanks,

  Andy
  Andy Holmes

---

From: Bob Ross <[email-masked]>
Date: Tue, 12 Jun 2001 13:26:42 -0700

Andy:

There was a bug in ibischk3 Version 3.2.6 and below regarding
not allowing the series or series switch elements to be 
attached to I/O buffers (a late specification change).
This is documented as bug40 under

  http://www.eda.org/pub/ibis/bugs/ibischk/

Try ibischk3 Version 3.2.7 found under

  http://www.eda.org/pub/ibis/ibischk3/

Bob Ross
Mentor Graphics

> Andrew Holmes wrote:
> Not sure how I should interpret this. The Series model defined looks correct
> and so does the Series Pin Mapping as defined by the 3.2 spec.
>