Subject: Re: Bird #5, 80 columns

From: [email-masked] (Christopher E. Reid)
Date: Fri, 10 Dec 93 12:14:41 -0500

Eric,

Your suggested addtion of a section:
-----------------------------------------------------
Well, we could add a new section to the file, 

[Pin_Mapping]	gnd		pwr
1		GNDBUS1		PWRBUS1
2		GNDBUS2		PWRBUS2
...
11		GNDBUS1		NA
12		GNDBUS1		NA
13		GNDBUS1		NA
...
31		NA		PWRBUS1
32		NA		PWRBUS1
33		NA		PWRBUS1

This would come after the [Pin] section, and would be TOTALLY OPTIONAL
and NOT REQUIRED.
---------------------------------------------------------------
does maintain the 80-character limit without complicating the
parser, but it also requires a duplication of the pin-map, which
is also undesirable.

Chris

---

From: Will Hobbs <[email-masked]>
Date: Fri, 10 Dec 93 12:26:24 PST

As I stated before, I feel human readability is important for several reasons.  
One thing I didn't mention is how easy it is for a mistake to go unnoticed if 
it's off beyond the right side of the screen.  At first blush, I like Chris's 
suggestion.  The files are already fairly long so a little longer won't be too 
bad, ASCII text is cheap, and this proposal maintains readability.

Will

Eric,

[Pin_Mapping]	gnd		pwr
1		GNDBUS1		PWRBUS1
2		GNDBUS2		PWRBUS2
...
11		GNDBUS1		NA
12		GNDBUS1		NA
13		GNDBUS1		NA
...
31		NA		PWRBUS1
32		NA		PWRBUS1
33		NA		PWRBUS1

Chris