Subject: more on SCOPE

From: [email-masked] (Jon Powell)
Date: Thu, 29 Sep 94 09:24:59 PDT

OK,

how about this. If indeed the Pin Model names have lexical scope
in an ibs file. How do we (humans) refer to them?

example:

I have a problem with this on Pin Model it is called OUTPUT. how
can I fix it?

1) the .ibs file name is unique so I can say ibs_file_name.OUTPUT

2) the .ibs file name is unique for any given company so I
   can say INTEL.ibs_file_name.OUTPUT

3) other ideas.

jonp

---

From: Arpad Muranyi <[email-masked]>
Date: Thu, 29 Sep 94 12:11:04 PST

Text item: 

Jon,

I am not sure what you mean by "fix it".

As a human, I would just call it: model OUTPUT of IBIS_FILE_NAME copmonent.  
This is the same as your first option.  However, if you think there might be 
more companies with the same component name (second sourcing), you might add the
company name to it as in your second option.  Then I would say: model OUTPUT of 
COMPANY's IBIS_FILE_NAME component.

Of course, I would say it this way only as a human...  I am not sure how those 
Godly people would say it who gathered earlier this year I believe in Oregon...

Arpad

OK,

example:

     
     
3) other ideas.
     
jonp

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: more on SCOPE
To: [email-masked]
From: [email-masked] (Jon Powell)
Date: Thu, 29 Sep 94 09:24:59 PDT