Subject: Re: General questions

From: [email-masked] ( Bob Ross)
Date: Wed, 14 Dec 94 11:44 PST

Syed:

See Below for some comments.

Bob Ross,
Interconnectix, Inc.

> Hello IBISgurus:

> I have been talking about IBIS to different groups at National and
> some questions regarding IBIS's capability came up.

> Can IBIS model an output stage with 'gradual turn-on' feature ?
> For example, products like LV TTL have gradual turn-on ckts on the
> output stage so if an Octal were to switch, GND bounce would be reduced. 
> I would like to know if anyone has modeled this using IBIS.

YES, THE [RISING WAVEFORM] AND [FALLING WAVEFORM] KEYWORDS IN VERSION 2.1
HANDLE GRADUAL TURN-ON.

> The other question is, some product line(ex. GTL) have a feedback path
> from output to input. Is there any limitations with IBIS modeling this
> type of structure.

THE IBIS ARCHITECTURE DOES NOT HANDLE FEEDBACK FROM OUTPUT TO INPUT.  THIS
WAS DISCUSSED LAST YEAR AT THE IBIS SUMMIT AND MAY AGAIN BE A TOPIC TO
DISCUSS FOR POSSIBLE INCLUSION IN IBIS VERSION 3.0

> My feeling is, 'gradual turn-on' or 'feedback' are very device specific
> features and IBIS simply sees the I/O structure and all else is a black 
> box within the device.

> I would be curious if anyone is modeling LV TTL or GTL type of devices.

> Comments...questions..

> Regards,
> Syed.
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Syed B. Huq 
> Applications Engineer/Data Transmission Products
> National Semiconductor 
> Tel:(408)721-4874; Fax:(408)721-4785
> Internet:[email-masked]
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Will Hobbs <[email-masked]>
Date: Wed, 14 Dec 94 17:58:18 PST

Text item: 

Syed,

I can't reply in any more detail than what Jon has already stated, or I'd have 
to shoot the reflector.  But Jon is right on.  It was due to controlled rise 
time concerns that we introduced this feature into 2.0, and have found it to 
work quite well, though developing an underlying model that consumes the data is
a challenge, as the EDA vendors reading this no doubt know.

Will

Syed,

I believe that the waveform mechanism can handle many forms of the 
"gradual turn on" and
the "feed back" drivers. In fact, I believe that is what INTEL wanted 
to use these
waveforms for in the first place (so called Rise Time Controlled drivers).

The feed back issue is harder since it depends on the speed of the 
feedback mechanism and that
speed is NOT defined (as yet) in the IBIS format.

jonp

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: General questions
Cc: [email-masked]
To: [email-masked]
From: [email-masked] (Jon Powell)
Date: Wed, 14 Dec 94 12:57:12 PST