Subject: Re: Nonmonotonic Pulldown I-V curves

From: Barry Katz <[email-masked]>
Date: Wed, 20 Apr 94 13:25:29 EDT

Sorry if this message gets posted twice.

After further review of Jon's report and some addition experimentation
on my part I think I may have identified a problem with the presented
results.

In my experiments, I found that the bulk currents were on the order of
picoAmps and that the difference on the order of femptoAmps. This
leads me to believe that the currents shown in Figure 5 of the report
are in fact the parasitic diode currents not the transistor Bulk
currents. This may just be a terminology issue.

However, something does appears to be inconsistent because even if we
were talking about diode currents the difference in these diode
currents should still be zero. This is based on the fact the the
transistor bulk currents are effectively zero and the current through
the diode is voltage dependent. Therefore, since both the "on" and
"off" cases have the same sweep, the difference between the currents
for these cases will be zero. This is regardless of your definition of
i_bulk.

Comments anyone?

Jon, can you put the spice decks corresponding to your report on the
reflector? 

Barry-

My test structure is shown below.

                 i_drain                   ---------
             <---                          |       |
          ---------------------------------|Ammeter| SWEEP
          |                  |             |       |
          |                  |  |i_clamp   ---------
          |                  |  |              |
 i_g   ----    i_bulk       --- V              |
 --> | |     <---            ^                 |
   --| | |--------          / \                |
   | | |         |          ---                |
  / \  ----      |           |                 |
 ( + )    | |    |           |                 |
 ( - )    | |i_s |           |                 |
  \ /     | V    |           |                 |
   |      |      |           |                 |
  ---    ---    ---         ---               ---
   -      -      -           -                 -

I think Jon's test structure was as follows

                                i_drain    ---------
                               <---        |       |
          ---------------------------------|Ammeter| SWEEP
          |                  |             |       |
          |                  |  |i_clamp   ---------
          |                  |  |              |
 i_g   ----                 --- V              |
 --> | |                     ^                 |
   --| | |--------          / \                |
   | | |         |          ---                |
  / \  ----      |           |                 |
 ( + )    | |    ------------|                 |
 ( - )    | |i_s          -------  |           |
  \ /     | V            |Ammeter| | i_bulk    |
   |      |               -------  V           |
  ---    ---                 |                ---
   -      -                 ---                -
                             -

---

From: Barry Katz <[email-masked]>
Date: Wed, 20 Apr 94 14:47:19 EDT

Jon,

It is my understanding that you were attempting to separate the bulk
diode currents from the pulldown I-V curves.

Therfore, I'm assuming that the one CMOS transistor in the report must
have the parasitic diodes internal to its model. Is this correct? This
would explain the huge (Amp range) bulk currents.

If it is, then isn't the test circuit I have drawn representative of
what you were modeling in the report(ignoring the parasitic diode from
source to bulk since it is shorted). My Id is the same as your Id etc.

I guess my question still is, given that you agree with everything I
have said above, how can the bulk currents between the "on" and "off"
cases be different?

I'm assuming that Ib = i_parasitic_diode and the diode current is a
function of the sweep voltage.

                                    Id         ---------
                                  <---         |       |
          -------------------------------------|Ammeter| SWEEP
          |                  |                 |       |
          |                  |  |i_parasitic   ---------
          |                  |  |   diode         |
       ----                 --- V                 |
     | |                     ^                    |
   --| | |--------          / \                   |
   | | |         |          ---                   |
  / \  ----      |           |                    |
 ( + )    | |    ------------|                    |
 ( - )    | |Is           -------  |              |
  \ /     | V            |Ammeter| | Ib           |
   |      |               -------  V              |
  ---    ---                 |                   ---
   -      -                 ---                   -
                             -

Barry Katz-

---

From: Arpad Muranyi <[email-masked]>
Date: Wed, 20 Apr 94 13:42:01 PST

They are different, because the ON transistor adds a parallel (resistive) path 
with its channel to the calmping diode.

Arpad

Jon,

                                    Id         ---------
                                  <---         |       |

Barry Katz-