Subject: BIRD30 Prog. Buffers Comment

From: [email-masked] ( Bob Ross)
Date: Wed, 6 Sep 95 09:53 PDT

To Arpad, Malan, Stephen and IBIS Team:

I would prefer to avoid the "Default" syntax associated with the [Model 
Selector] keyword.

Here is the example of what is currently proposed:

[Model selector]        Progbuffer1
                ABCD0123456789ABCDE0
                ABCD0123456789ABCDE1
Default         ABCD0123456789ABCDE2
                ABCD0123456789ABCDE3
                ABCD0123456789ABCDE4
|
[Model selector]        Progbuffer2
                ABCD0123456789ABCDE0
Default         ABCD0123456789ABCDE3
                ABCD0123456789ABCDE4
                ABCD0123456789ABCDE5
                ABCD0123456789ABCDE6

I would prefer that the first model encountered is the default:

[Model selector]        Progbuffer1
                ABCD0123456789ABCDE2    | the default
                ABCD0123456789ABCDE0
                ABCD0123456789ABCDE1
                ABCD0123456789ABCDE3
                ABCD0123456789ABCDE4
|
[Model selector]        Progbuffer2
                ABCD0123456789ABCDE3     | the default
                ABCD0123456789ABCDE0
                ABCD0123456789ABCDE4
                ABCD0123456789ABCDE5
                ABCD0123456789ABCDE6

Comments could provide a description of the buffers if they are no clear
from the name.  An alternative is to have another column required column
for describing such buffers, similar to "signal_name in the [Pin] keyword:

[Model selector]             Progbuffer1
|   model name               description
    ABCD0123456789ABCDE2     SS3.3              | the default
    ABCD0123456789ABCDE0     WS3.3
    ABCD0123456789ABCDE1     WF3.3
    ABCD0123456789ABCDE3     SF3.3
    ABCD0123456789ABCDE4     SF3.3_OD
|
[Model selector]             Progbuffer2
|   model name               description
    ABCD0123456789ABCDE3     SF3.3              | the default
    ABCD0123456789ABCDE0     WS3.3
    ABCD0123456789ABCDE4     SF3.3_OD
    ABCD0123456789ABCDE5     SF5.0
    ABCD0123456789ABCDE6     SF5.0

The description would not be standardized since there are many ways to
differentiate models.  The simulator could display the description and
could optionally base a selection mechanism on the description.  This
syntax would then have two columns for each model for consistency.

Bob Ross,
Interconnectix, Inc.

---

From: [email-masked] (Jon Powell)
Date: Wed, 6 Sep 95 11:21:33 PDT

How does one control the selection of the various buffer types?

It seems that it would be important to provide a mechanism that allows
simple programmable selection of output types. If this is not provided then
the user will be forced to create a unique IBIS file that has the actual model
mapping that was decided. Even if you "leave this up to the tool vendors" the
user will still have to, effectively, create their own pin map file.

regards,
jon