Subject: Re[2]: EGG Half Dozen

From: Arpad Muranyi <[email-masked]>
Date: Wed, 20 Sep 95 11:08:00 PDT

Text item: 

Since noone responded to this EMAIL I sent quite a while ago, I suspect that it 
might have gotten lost, so I am resending it again.  Is this automated detection
method acceptable, or are there cases when it would fail?

Arpad
================================================================================
Jon,

I have an idea that might do the thing without an extra keyword.  (I didn't
spend much time on this, though, so I am not sure if this is fool proof).

The I-V curves of bipolar pulldown structures usually cross the voltage axis
above 0 volt, in other words, zero current is at approximately 0.15 V on those
I-V curves.  On the other hand, the I-V curves of CMOS pulldowns would go
through the origin, since the channel behaves more like a voltage controlled
resistor (i.e. no voltage, no current).  If the I-V curve in an IBIS file is
accurate enough to detect this difference, I think you can just look for the
voltage at zero current, and if it is not zero, you could assume a bipolar
device.

Do you think this will work?

Arpad
===============================================================================
More Argument on EGG Half Dozen.

Hopefully by now people have the hardcopy in hand and can look at
the two IV curve groups. If we have no argument on how they look
(at least, in general appearance) then my problem is this:

As the "control" voltage changes on the CMOS gate only the IV curve
strength changes. The zero millamp point stays constant (at ~VCC) this
makes sense as all we are doing is making the CMOS gate more resistive.

The TTL gate, however, changes its zero milliamp point, it being a totem
pole arrangement and all.

The point is, at risetime/2, what is the proper thevinin equivalent for the
driver? You have to know if it is CMOS or TTL. If there is a fool proof way
to determine this form the IV curve alone, they we are done, else I would
like a new (optional?) KEYWORD.

regards,
jon

(I hope I got this HALF-DOZEN joke out before bob or will).

(If you still need hardcopy, let me know. Won't it be nice when I can just
post HTML to a WWW EGG discussion page?).

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: EGG Half Dozen
To: [email-masked]
From: [email-masked] (Jon Powell)
Date: Thu, 10 Aug 95 10:09:52 PDT
10 Aug 95 10
:39:38 -0700
Received: from aurora.intel.com by relay.jf.intel.com with smtp
     (Smail3.1.28.1 #2) id m0sgbZz-000twZC; Thu, 10 Aug 95 10:39 PDT

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: Re: EGG Half Dozen
To: [email-masked], [email-masked]
From: Arpad Muranyi <[email-masked]>
Date: Thu, 17 Aug 95 16:46:00 PDT
:58:49 -0700
Received: from hermes.intel.com by relay.jf.intel.com with smtp
     (Smail3.1.28.1 #2) id m0sjEpo-000twvC; Thu, 17 Aug 95 16:58 PDT

---

From: [email-masked] (C. Kumar)
Date: Wed, 20 Sep 95 14:43:08 -0400

I do not see we need to add anything special in IBIS to detect whether is curve is TTL or CMOS. The VT curves in 2.1 provides the mechanism to specify a non ideal transient behavior
= Kumar
Cadence design System
> Received: by f14.qdt.com (4.1/SMI-4.1)
>      id AA10842; Thu, 10 Aug 95 10:09:50 PDT
> Message-Id: <[email-masked]>
> Received: from f14.qdt.com by hal.qdt.com (4.1/SMI-4.1)
>      id AA27974; Thu, 10 Aug 95 10:09:52 PDT
> Received: from hal.qdt.com by qdt.com (4.1/SMI-4.1)
>      id AA00557; Thu, 10 Aug 95 10:09:52 PDT
> Received: from qdt.UUCP by uucp4.UU.NET with UUCP/RMAIL
>         ; Thu, 10 Aug 1995 13:36:18 -0400
> Received: from uucp4.UU.NET by relay3.UU.NET with SMTP
>      id QQzcfe02475; Thu, 10 Aug 1995 13:36:26 -0400
> Received: from relay3.UU.NET by vhdl.vhdl.org (4.1/SMI-4.1/BARRNet)
>      id AA04774; Thu, 10 Aug 95 10:43:05 PDT
> Received: from vhdl.vhdl.org by aurora.intel.com (5.65/10.0i); Thu,
> 10 Aug 95 10
> :39:38 -0700
> Message-Id: <Thu, 17 Aug 95 16:56:34 [email-masked]>
> Received: by ccm.hf.intel.com (ccmgate 3.2 #2) Thu, 17 Aug 95 16:56:39 PDT
> Received: from ccm.hf.intel.com by relay.jf.intel.com
>      (Smail3.1.28.1 #2) id m0sjEnf-000txAC; Thu, 17 Aug 95 16:56 PDT
> Received: from relay.jf.intel.com by ormail.intel.com with smtp
>      (Smail3.1.28.1 #7) id m0sjEng-000UgMC; Thu, 17 Aug 95 16:56 PDT
> Received: from ormail.intel.com by vhdl.vhdl.org (4.1/SMI-4.1/BARRNet)
>      id AA04272; Thu, 17 Aug 95 17:03:27 PDT
> Received: from vhdl.vhdl.org by hermes.intel.com (5.65/10.0i); Thu, 17 Aug 95 16
> :58:49 -0700