Subject: Fwd: Re: Re[4]: Non-Monotonic Drivers

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:08:12 EDT

-- [ From: Ron Christopher * EMC.Ver #2.10P ] --

Forwarding to the reflector.

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Wednesday, 23-Aug-95 09:11 PM
> 
> From: Jon Powell               \ Internet:   
> ([email-masked])
> To:   Ron Christopher          \ PRODIGY:     (EGJJ77A)
> 
> Subject: Re: Re[4]: Non-Monotonic Drivers
> 
> Arpad tongue in cheek comments aside, the point with non-monotonic
> waveforms that I have been stressing is that non-monotonicity implies
> negative resistance, this implies feedback, this implies time delay.
It
> also implies a possible capacitive charge pumping effect. We need to
know
> that delay. We need to know how it effects the IV curve. Ignoring
this
> effect will not help. If we don't put the delay into IBIS then the
> simulator companies can make assumptions but cannot guarantee that
those
> assumptions will be right. 
> 
> If anyone does not agree with this bit about a delay, then speak up
and
> lets have a discussion. If you don't understand it, give me a call
and
> lets discuss it that way.
> 805 988 8250
> 
> 
> by the way, Are we having this discussion between the four of us on
> purpose, or did you guys do the same thing I did and just hit
"reply"?
> cheers,
> jon

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:09:07 EDT

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Tuesday, 22-Aug-95 09:32 PM
> 
> From: Arpad Muranyi            \ Internet:   
> ([email-masked])
> Subject: Re: Non-Monotonic Drivers
> 
> Text item: 
> 
> John,
> 
> Thanks for the graphical response to my question.  This is the kind
of
> response  I really wanted to get.  I have a question, though.  Is
this I-V
> curve a  function of the voltage on the output pin, or time.  I mean,
is
> "translating  between two Vgs curves" done with a feedback circuit by
> monitoring the output  voltage, or is it a function of time as slew
rate
> controlled devices usually do  it?
> 
> If the answer is time, IBIS can definitely do it, but if it is
voltage (as
> in  feedback), IBIS would not be able to help you at this time. 
However,
> the open  forum committee did consider this issue in meetings before,
and
> I don't think  that it would be impossible to incorporate features
that
> can model it.
> Arpad
=======================================================================
==
> =====
> Arpad,
> 
> The drivers Ron refers to have the following IV curve shape...
> 
>      Ids                *   *
>                     *          *
>                   *               *
>                  *                   *
>                 *                      ****************
>                *
>               *
>              *
>             *                                   Vds
> 
> 
> Instead of the normal transistor curve shape like...
> 
>      Ids                *   ***********************
>                     *
>                   *
>                  *
>                 *
>                *
>               *
>              *
>             *                                   Vds
> 
> 
> The top curve comes about because we are manipulating the gate
voltage to
> control di/dt noise in the maximum Vds region of the large output
device.
> Essentially we are translating between two Vgs curves for the output
> transistor. Hence the non-monotonicity is real and not noise related.
> Clamp diodes would add another bend in the curve and create 3 current
> values for 1 voltage value.
> 
> The simulation tools we looked at would "correct" the data by making
the
> top curve look like the bottom. We saw some extreme differences in
> benchmark nets after this manipulation from the full transistor
> simulation. Since there is no standard on how to "correct" the above
> curve, we would not know how various simulation vendors would treat
the
> model.
> 
> The above and the time schedule of IBIS 2.1 and CMOS 4 makes
supporting
> the IBIS modeling strategy unattractive for our CMOS 4 products.
> 
> Thanks,
> John Brennan
> 
>
***********************************************************************
> John Brennan                           Internal: jbrennan@btv
> IBM Microelectronics                   Internet:
[email-masked]
> G77V/862-1                             Tel: 802-769-6982 (Tie-Line:
446)
> Burlington, VT                         Fax: 802-769-5882 (Tie-Line:
446)
***********************************************************************
> 
> Text item: External Message Header
> 
> The following mail header is for administrative use
> and may be ignored unless there are problems.
> 
> ***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.
> 
> From: "John Brennan" <[email-masked]>
> Date: Tue, 22 Aug 1995 13:34:03 -0400
> Subject: Non-Monotonic Drivers
> To: [email-masked], [email-masked], [email-masked]
> Message-Id: <[email-masked]>
> Received: by btv.ibm.com (AIX 3.2/UCB 5.64/fs4.03)
>           id AA33207; Tue, 22 Aug 1995 13:34:05 -0400
> Received: from eeyore.btv.ibm.com by btv.ibm.com (AIX 3.2/UCB
5.64/1.9)
>           id <[email-masked]>; Tue, 22 Aug 1995 13:34:10 -0400
> Received: by BTV (XAGENTA 4.0) id 3245; Tue, 22 Aug 1995 13:35:23 -
0400
> Received: from BTV by VNET.IBM.COM (IBM VM SMTP V2R3) with BSMTP id
7677;
>    Tue, 22 Aug 95 13:38:48 EDT
> Received: from vnet.ibm.com by aurora.intel.com (5.65/10.0i); Tue, 22
Aug
> 95 10:
> 38:52 -0700
> Received: from aurora.intel.com by fmmail.fm.intel.com with smtp
>      (Smail3.1.28.1 #2) id m0skxGs-000aoAC; Tue, 22 Aug 95 10:37 PDT
> 
> 
> 

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:08:00 EDT

Forwarding following to the reflector with permission.

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Tuesday, 22-Aug-95 01:38 PM
> 
> From: John Brennan             \ Internet:    ([email-masked])
voltage to
device.
the
the
supporting
[email-masked]
446)
446)
> 
> ------- Forwarded Message
> 
> Date:    Tue, 22 Aug 1995 10:48:35 -0400
> From:    [email-masked] (MR RONALD J CHRISTOPHER)
> To:      [email-masked]
> Subject: Fwd: Re:
> 
> - -- [ From: Ron Christopher * EMC.Ver #2.10P ] --
> 
> John,
> 
> This is the one that needs a technical answer on the IBIS forum.
> 
> Thanks
> Ron Christopher
> - ------- FORWARD, Original message follows -------
> 
> > Date: Thursday, 17-Aug-95 01:32 PM
> >
> > Subject: Re:
> > Ron,
> > There are many aspects to non-monotonic data.  For example, some
> > non-monotonic  data could be caused by noise, others by the
behavior
> of
> > the device.  The former case can be solved by filtering, but the
> latter
> > case is more complicated.  In  order to tell you what IBIS can or
> cannot
> > do, I would like to have a little more description on those devices
> that
> > you are referring to.  Can you tell me how  they are non-monotonic?
> >
> > Arpad Muranyi
> > Intel Corporation
> >
>
> > ======
> > I am working as an independent with CFI, EDAC, and Sematech on a 10
> year
> > roadmap for electronic CAD standards.  Our work is described on the
> WWW at
> > http://www.cfi.org/roadmap/roadMap-eii-report.html.
> >
> > Our 10 year roadmap should show how we are going to do delay above
> the
> > chip.  I thought we would be able to state IBIS, but it doesn't
> handle the
> > basic CMOS IV .5um IBM ASIC drivers.  Bob Ward says Version 2.x
does
> not
> > handle all the TI drivers either.  Can we establish some steps in
the
> IBIS
> > group to correct this which we could refer to in our roadmap?
> >
> > To: [email-masked], [email-masked]
> > Message-Id: <[email-masked]>
> > X-Mailer: PRODIGY Services Company Internet mailer [PIM 3.2-342.56]
> > >From: [email-masked] (MR RONALD J CHRISTOPHER)
> > Date: Thu, 17 Aug 1995 10:18:59 EDT
> > Received: from mail.prodigy.com (mail.prodigy.com [199.4.137.13])
by
> > inetgate.pr
> > odigy.com (8.6.10/8.6.9) with SMTP id KAA22884; Thu, 17 Aug 1995 10:
> 20:31
> > -0400
> > Received: from inetgate.prodigy.com by vhdl.vhdl.org (4.1/SMI-
> 4.1/BARRNet)
> >      id AA18685; Thu, 17 Aug 95 09:02:30 PDT
> > Received: from vhdl.vhdl.org by hermes.intel.com (5.65/10.0i); Thu,
> 17 Aug
> > 95 09
> > :02:08 -0700
> > Received: from hermes.intel.com by relay.jf.intel.com with smtp
> >      (Smail3.1.28.1 #2) id m0sj7OV-000twpC; Thu, 17 Aug 95 09:02
PDT
======================================================================
> > This e-mail is from the "[email-masked]" mailing list. Please
> contact
> > us at "[email-masked]" for any changes, additions,
> deletions
> > or adjustments that you might need. Thank you very much.
> >
>
======================================================================
> >
> >
> >
> 
> - ------- FORWARD, End of original message -------
> 
> 
> 
> 
> 
> ------- End of Forwarded Message
> 
> 
> 

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:08:55 EDT

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Wednesday, 23-Aug-95 09:34 AM
> 
> Each point on the curve is what you would get if you put a battery DC
> voltage at the output of the driver and measured the current through
the
> pad with all other operating conditions constant. The curves were
> generated with multiple DC analysis using ASX(the IBM SPICE program).
I do
> not think IBIS can handle this today. Specifically, simulation
programs
> will try to alter the DC curves, and there is nothing that tells them
how
> to do this(I believe the correct thing to do would be to not alter
the
> curve).
> John
[email-masked]
446)
446)
> 
> ------------------ Referenced E-Mail ----------------------------
> 
> Date:    Tue, 22 Aug 1995 15:47:55 PST
> To:      [email-masked], [email-masked], [email-masked]
> cc:      [email-masked]
> From:    Arpad Muranyi <[email-masked]>
> Message-Id: <[email-masked]>
> 
> Text item:
> 
> John,
> 
of
> response I really wanted to get.  I have a question, though.  Is this
I-V
is
rate
voltage (as
However,
> the open forum committee did consider this issue in meetings before,
and I
> don't think that it would be impossible to incorporate features that
can
> model it.
voltage to
device.
the
the
supporting
[email-masked]
446)
446)
5.64/1.9)
0400
7677;
Aug
> 95 10
> :

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:08:38 EDT

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Wednesday, 23-Aug-95 03:43 PM
> 
> Subject: Re[2]: Non-Monotonic Drivers
> 
> Text item: 
> 
> John,
> 
> Thanks again for your reply.  I have mixed feelings about what to say
now.
> 
> 1)  This kind of a behavior is most likely caused by a feedback
circuit in
> the  buffer.  It is true, IBIS currently does not have provisions to
> describe buffers with feedback.  However, we had discussions on this
> subject in the open forum  meetings before, and we could pick it up
again
> if there is a real need for  modeling such buffers in IBIS.
> 
> 2)  On the other hand, I am not sure if IBIS is to blame for the
situation
> that  you described, that simulators alter the curve this and that
way.  I
> imagined  how I would use this data in my HSPICE behavioral (=IBIS)
> models.  I am using  piecewise linear (PWL) sources for the I-V
curves. 
> If I make the voltage values the independent variable, and current
the
> dependent variable, it will work no  problem, because each voltage
value
> is assigned only one current value.  (It  doesn't matter whether the
> current values are repeated).  If I turned it around, however, to
have
> current values as the independent variable and voltage the  dependent
one,
> it would not work, because the simulator would have to pick  between
two
> or more voltages for one current value.  What I am trying to say 
here is
> that this kind of a curve should work, as far as IBIS is concerned 
(as  it
> does in my HSPICE behavioral models).  It depends on what the
simulator
> tool  does with it.
> ====
the
I do
programs
how
the
[email-masked]
446)
446)
> of response
> I really wanted to get.  I have a question, though.  Is this I-V
curve a
> function of the voltage on the output pin, or time.  I mean, is
> "translating
> between two Vgs curves" done with a feedback circuit by monitoring
the
> output
> voltage, or is it a function of time as slew rate controlled devices
> usually do
> it?
> 
voltage (as
However,
and I
can
voltage to
device.
the
the
supporting
[email-masked]
446)
446)
5.64/1.9)
0400
7677;
> Received: from vnet.ibm.com by aurora.intel.com (5.65/10.0i); Tue,
> 22 Aug 95 10
> :
> 38:52 -0700
> Date: Wed, 23 Aug 1995 09:01:18 -0400
> In-Reply-To: Your message of Tue, 22 Aug 1995 15:47:55 PST.
>              <[email-masked]>
> Cc: [email-masked], [email-masked], [email-masked],
>         [email-masked]
> To: Arpad Muranyi <[email-masked]>
> Message-Id: <[email-masked]>
>           id AA12722; Wed, 23 Aug 1995 09:01:19 -0400
5.64/1.9)
>           id <[email-masked]>; Wed, 23 Aug 1995 09:01:20 -0400
> Received: by BTV (XAGENTA 4.0) id 3602; Wed, 23 Aug 1995 09:36:15 -
0400
> Received: from BTV by VNET.IBM.COM (IBM VM SMTP V2R3) with BSMTP id
2183;
>    Wed, 23 Aug 95 09:36:24 EDT
> Received: from vnet.ibm.com by hermes.intel.com (5.65/10.0i); Wed, 23
Aug
> 95 06:
> 40:31 -0700
> Received: from hermes.intel.com by fmmail.fm.intel.com with smtp
>      (Smail3.1.28.1 #2) id m0slG1j-000algC; Wed, 23 Aug 95 06:39 PDT
> 
> 
> 

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:08:16 EDT

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Wednesday, 23-Aug-95 07:26 PM
> 
> Subject: Re[4]: Non-Monotonic Drivers
> 
> Text item: 
> 
> John,
> 
> I see your point in suggesting a spec on how to handle the I-V
curves. 
> However, I am afraid that this will never happen.  We had similar, or
even
> more important issues surface up in previous Open Forum meetings, yet
> these discussions ended  with the conclusion that the software tool
vendor
> should not be told how to do  things.  That is their specialty, and
that
> is how they differentiate on the  market.  Each one of them knows
> everything better than the other, so they  wouldn't listen anyway. :-)
> 
> You, the user must decide which tool suits your needs the best.
> 
> Arpad
>
> =====
> Arpad,
> 
> I agree 100% with your point #2. In fact non-monoticity was a non-
issue
> with our ASX simulator because we knew ahead of time that these
waveforms
> were non-standard. Our ASX analysis did not match up that well
because the
> Vout vs. Time waveforms were not symmetric about the center voltage,
the
> shape of the waveform assumed by the vendor tool was different from
> actual. IBIS has addressed this in ver 2.1.
> 
> Thus we analyzed the VI cureves and did what you said in #2. The
problem
> is ofcourse that the standard does not tell one writing a simulation
> program how to handle these IV curves. Current programs that I looked
at
> changed the data to be monotonic, I beleive so they could calculate
> impedances. I would imagine different programs would do different
things.
> I suspect you have seen other non-monotonic drivers that are non-
monotonic
> for other reasons that may need to be treated different yet. A
challenge
> would be to write the spec to handle all of the known cases.
> 
> We are not getting sufficient demand for CMOS 4 IBIS models to
justify any
> lengthy studies on how to model these drivers.
> 
> John
> 
>
[email-masked]
446)
446)
> Date:    Wed, 23 Aug 1995 10:46:08 PST
> cc:      [email-masked], [email-masked], [email-masked],
> Message-Id: <[email-masked]>
> 
> Text item: 
> 
> John,
> 
now.
circuit in
> the
> buffer.  It is true, IBIS currently does not have provisions to
describe
> buffer
> s
> with feedback.  However, we had discussions on this subject in the
open
> forum
> meetings before, and we could pick it up again if there is a real
need for
> modeling such buffers in IBIS.
> 
situation
> that
> you described, that simulators alter the curve this and that way.  I
> imagined
> how I would use this data in my HSPICE behavioral (=IBIS) models.  I
am
> using
> piecewise linear (PWL) sources for the I-V curves.  If I make the
> voltage value
> s
> the independent variable, and current the dependent variable, it will
work
> no
> problem, because each voltage value is assigned only one current
value. 
> (It
> doesn't matter whether the current values are repeated).  If I turned
> it around
> ,
> however, to have current values as the independent variable and
voltage
> the dependent one, it would not work, because the simulator would
have to
> pick between two or more voltages for one current value.  What I am
trying
> to say here is that this kind of a curve should work, as far as IBIS
is
> concerned (as it does in my HSPICE behavioral models).  It depends on
what
> the simulator tool does with it.
> 
> Arpad
>
the
I do
programs
how
the
[email-masked]
446)
446)
curve a
the
voltage (as
However,
and I
can
voltage to
device.
the
the
supporting
[email-masked]
446)
446)
>           id AA33207; Tue, 22 Aug 1995 13:34:05 -0400 Received: from
> eeyore.btv.ibm.com by btv.ibm.com (AIX 3.2/UCB 5.64/1.9)
0400
7677;
Aug
>           id AA12722; Wed, 23 Aug 1995 09:01:19 -0400 Received: from
> eeyore.btv.ibm.com by btv.ibm.com (AIX 3.2/UCB 5.64/1.9)
0400
2183;
Aug
> 95 06
> Date: Wed, 23 Aug 1995 16:22:17 -0400
> In-Reply-To: Your message of Wed, 23 Aug 1995 10:46:08 PST.
>              <[email-masked]>
> Subject: Re: Re[2]: Non-Monotonic Drivers
> Message-Id: <[email-masked]>
>           id AA27032; Wed, 23 Aug 1995 16:22:19 -0400 Received: from
> eeyore.btv.ibm.com by btv.ibm.com (AIX 3.2/UCB 5.64/1.9)
>           id <[email-masked]>; Wed, 23 Aug 1995 16:23:16 -0400
> Received: by BTV (XAGENTA 4.0) id 3950; Wed, 23 Aug 1995 16:29:18 -
0400
> Received: from BTV by VNET.IBM.COM (IBM VM SMTP V2R3) with BSMTP id
1866;
>    Wed, 23 Aug 95 16:29:25 EDT
Aug
> 95 13:
> 29:31 -0700
>      (Smail3.1.28.1 #2) id m0slMPX-000altC; Wed, 23 Aug 95 13:28 PDT
> 
> 
> 

------- FORWARD, End of original message -------

---

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Thu, 31 Aug 1995 11:07:32 EDT

Ron Christopher
------- FORWARD, Original message follows -------

> Date: Thursday, 24-Aug-95 11:31 AM
> 
> From: Will Hobbs               \ Internet:   
> ([email-masked])
> Subject: Re[6]: Non-Monotonic Drivers
> 
> Text item: 
> 
> John,
> 
> Thet V/T curves with reference load in IBIS 2.1 address the problem
of
> simulator accuracy by providing actual expected results under known
> conditions.  Multiple  such curve/load pairs can be included in the
model
> file and can be used by the  end customer to check the simulator's
> handling of the data.
> 
> Will
> 
> Arpad,
> 
> Yes, and that is exactly what we did... CMOS 4 SI tool was IBM ANDAP  
(we
> already had the models done). Since we are ASIC library suppliers, 
we
> actually let our customers decide which tool where practical.
> 
> Ofcourse we could as a silicon vendor just put the IBIS data out
there 
> and give the user enough rope to hang themselves(user beware), or put
the
> burden on the Simulation vendor to handle. Sounds like that's  what
they
> are asking for by keeping it out of the spec. Generating  IBIS data
is
> easy, making sure it simulates right is another story.
> 
> Thanks,
> John
> 
>
[email-masked] 
446) 
446) 
> Date:    Wed, 23 Aug 1995 14:54:11 PST
> Message-Id: <[email-masked]>
> 
> Text item: 
> 
> John,
> 
curves. 
> However
> ,
> I am afraid that this will never happen.  We had similar, or even
more
> importan
> t
> issues surface up in previous Open Forum meetings, yet these
discussions
> ended
> with the conclusion that the software tool vendor should not be told
how
> to do
> things.  That is their specialty, and that is how they differentiate
on
> the
> market.  Each one of them knows everything better than the other, so
they
> wouldn't listen anyway. :-)
> 
issue
waveforms
because the
the
problem
at
things.
monotonic
challenge
justify any
[email-masked]
446)
446)
now.
circuit in
describe
open
need for
situation
am
work
value. 
voltage
have to
trying
is
what
the
I do
programs
how
the
[email-masked]
446)
446)
curve a
the
voltage (as
However,
and I
can
voltage to
device.
the
the
supporting
[email-masked]
446)
446)
0400
7677;
Aug
0400
2183;
Aug
0400
1866;
Aug
> 95 13
> Date: Thu, 24 Aug 1995 09:47:13 -0400
> In-Reply-To: Your message of Wed, 23 Aug 1995 14:54:11 PST.
>              <[email-masked]>
> Message-Id: <[email-masked]>
>           id AA19141; Thu, 24 Aug 1995 09:47:14 -0400 Received: from
>           id <[email-masked]>; Thu, 24 Aug 1995 09:47:16 -0400
> Received: by BTV (XAGENTA 4.0) id 4274; Thu, 24 Aug 1995 09:47:23 -
0400
> Received: from BTV by VNET.IBM.COM (IBM VM SMTP V2R3) with BSMTP id
2142;
>    Thu, 24 Aug 95 09:47:29 EDT
> Received: from vnet.ibm.com by hermes.intel.com (5.65/10.0i); Thu, 24
Aug
> 95 06:
> 49:32 -0700
> Received: from hermes.intel.com by ichips.intel.com (5.64+/10.0i);
Thu, 24
> Aug 9
> 5 06:49:41 -0700
> Received: from ichips.intel.com by relay.jf.intel.com with smtp
>      (Smail3.1.28.1 #2) id m0slcfA-000twiC; Thu, 24 Aug 95 06:49 PDT
> 
> 
> 

------- FORWARD, End of original message -------

---

From: Arpad Muranyi <[email-masked]>
Date: Thu, 31 Aug 95 16:06:00 PDT

Text item: 

Dileep,

I tend to agree.  I am just curious which tool you are referring to.
Would you be able to disclose that info to us?

Arpad
==========================================================================

My understanding of the non-monotonic behavior
being discussed here is as follows. An I-V table is
specified, where I is the dependent variable
and V is the independent variable. V values
are strictly monotonically increasing. The
corresponding I values are non-monotonic i.e.,
for a certain range of V, I decreases as V
increases; but the I values are unique i.e.,
for each V value, there is only one I value.

I do not see why such a table cannot be used.

As far as the Golden Parser is concerned, it
will issue a warning, but it will not prevent
the user from specifying such data.

As far as the simulators are concerned, the
simulator I work on, will be able to use that
data without any problems. I think that some
other simulators give "error" messages or
"correct" such a data because they assume that
such a device does not exist and therefore, the
user may have made a mistake in specifying that
information. If they know that the specification
is intentional, then they may be able to use that
data with very minor modifications to the simulator.

Of course, it is possible to connect such a device
in some topologies where the circuit will be
unstable or may have multiple stable points.
Then, the simulations will have problems.
But if the device is connected so that the
circuit has a well defined behavior, then
it will be possible to simulate the circuit.
This will be the case for most of the
signal integrity applications.

Dileep Divekar
------------------------------------------------------------
Dileep Divekar
Contec CAE, Ltd.
2188 Bering Drive
San Jose, CA 95131

Phone - (408)-434-6767 x 126
Fax   - (408)-434-6884
Email - [email-masked]
------------------------------------------------------------

Content-Length: 1728
Cc: [email-masked], [email-masked], [email-masked]
Subject: Non-Monotonic Drivers
To: [email-masked]
From: [email-masked] (Dileep Divekar)
Date: Thu, 31 Aug 1995 14:22:07 +0800
4.1/BARRNet)
     id AA08072; Thu, 31 Aug 95 15:28:04 PDT
Received: from vhdl.vhdl.org by hermes.intel.com (5.65/10.0i); Thu, 31 Aug 95 15
:23:16 -0700
Received: from hermes.intel.com by relay.jf.intel.com with smtp
     (Smail3.1.28.1 #2) id m0soI14-000tx7C; Thu, 31 Aug 95 15:23 PDT