Subject: Non-Monotonic Drivers

From: [email-masked] (Dileep Divekar)
Date: Thu, 31 Aug 1995 14:22:07 +0800

My understanding of the non-monotonic behavior
being discussed here is as follows. An I-V table is
specified, where I is the dependent variable
and V is the independent variable. V values
are strictly monotonically increasing. The
corresponding I values are non-monotonic i.e.,
for a certain range of V, I decreases as V
increases; but the I values are unique i.e.,
for each V value, there is only one I value.

I do not see why such a table cannot be used.

As far as the Golden Parser is concerned, it
will issue a warning, but it will not prevent
the user from specifying such data.

As far as the simulators are concerned, the
simulator I work on, will be able to use that
data without any problems. I think that some
other simulators give "error" messages or
"correct" such a data because they assume that
such a device does not exist and therefore, the
user may have made a mistake in specifying that
information. If they know that the specification
is intentional, then they may be able to use that
data with very minor modifications to the simulator.

Of course, it is possible to connect such a device
in some topologies where the circuit will be
unstable or may have multiple stable points.
Then, the simulations will have problems.
But if the device is connected so that the
circuit has a well defined behavior, then
it will be possible to simulate the circuit.
This will be the case for most of the
signal integrity applications.

Dileep Divekar
------------------------------------------------------------
Dileep Divekar
Contec CAE, Ltd.
2188 Bering Drive
San Jose, CA 95131

Phone - (408)-434-6767 x 126
Fax   - (408)-434-6884
Email - [email-masked]
------------------------------------------------------------

---

From: [email-masked] (Jon Powell)
Date: Thu, 31 Aug 95 16:57:18 PDT

>>data with very minor modifications to the simulator.

I disagree with this accessment. Unless the feedback speed
of the path is known an accurate guess cannot be made as to
how to simulate the device. Of course, if the feedback path just
doesn't matter then it doesn't so much matter what you guess.
I would like us to explore a mechanism for behaviorally defining
this feedback path/speed.

At the very outside, I have seen two different devices that had
non-monotonic IV curves that looked approximately the same at DC.
One had a feedback path that was 20ns (it was only used for changing
the long term DC operating point of the device) and another had a feedback
path that was "instantaneous". It is my claim that these two devices would
have different simulations even though they would have identical IBIS models.

that is all.

jon