Subject: IBIS model submission procedure (revised)

From: [email-masked]
Date: Mon, 09 Jan 95 10:20:35 EST

PROCEDURE FOR SUBMITTING A MODEL TO
                        THE IBIS MODEL LIBRARY

                               January 6, 1994

                                Michael Steer
                            IBIS Model Librarian
             Department of Electrical and Computer Engineering
                    North Carolina State University
                    Raleigh, NC 27695-7911
                    phone: +1-919-515-5191
                    fax:   +1-919-515-3027
                    email: [email-masked]   (preferred means of communication)

Vendors and others are encouraged to submit IBIS models to the IBIS model
library.  The IBIS librarian maintains the IBIS models stored on vhdl.org
in the directory /pub/ibis/models .

  1.  Before submission models must be readable by the Golden
      Parser with out errors or warning messages being generated.

  2.  A submission should consist of the following:

      a.  A readme file ( named README.TXT ) including the following
 
          Name of Person Submitting:   XXXXXXXXXXXX
          Address:     XXXXXXXXXXXXXXXXXXXXXXXXXXXX
          Affiliation: XXXXXXXXXXXXXXXXXXXXXXXXXXXX
          E-Mail:      XXXXXXXXXXXXXXX
          Telephone Number: XXXXXXXXXXXXXXXXXXXXXXX
          Fax Number:       XXXXXXXXXXXXXXXXXXXXXXX
          Suggested Directory Structure XXXXXXXXXXX
            Structure for models

      b.  A Model Transfer Agreement Use the sample below) must be signed
          and mailed to the IBIS librarian < [email-masked] >.  The model
          transfer agreement must be MAILED to 
                    Dr. Michael Steer
                    Attn: IBIS
                    Department of Electrical and Computer Engineering
                    North Carolina State University
                    Raleigh, NC 27696-7911
          The above address is good for the post-office, Federal Express,
          Airborne, UPS etc. even though there is no street address.

          The model check-in procedure will not be finalized until
          this agreement has been received by the IBIS librarian.

      c.  All files should be in a single file before emailing to the IBIS
          librarian. Use one of the following four methods:

          1. [ gnu tar AND ( uuencode OR mmencode ) ]
          2. [ tar AND compressed AND ( uuencode OR mmencode ) ]
          3. [ zip AND ( uuencoded OR mmencode'd ) ]
          4. [ zip ] 
             Note that zip'ing alone may result in problems due to non-ascii 
             characters.  You can obtain suitable programs for DOS as follows:

          ftp oak.oakland.edu
          login as anonymous
          binary                              // to put in binary transfer mode
          cd /pub/msdos/zip
          get pkz204g.exe                     // the zip archive create/extract 
                                                 program.  Run this program to
                                                 generate the required utilities
          cd /pub/msdos/compress
	  get comp430d.zip                    // Unix-compatible 16bit 
                                                 compress/uncompress utility
          cd /pub/msdos/decode
	  get qux01_91.zip                    // UUencode/UUdecode
   
          quit                                // finish up
 
      Expect an acknowledgement within two days.

  3.  When models are received:
         a. The following will be added to each IBIS file if not already
            present:

         [Disclaimer] IBIS Open Forum disclaims all warranties. See
         DISCLAIM.TXT in vhdl.org:/pub/IBIS/models for the full disclaimer.

         b. The IBIS models will be checked with the Golden Parser and if
            they parse successfully they will be accepted.

  4.   The IBIS models will be treated as confidential until they are
       publically released.  When new models are added an announcement will
       be made.

==============================================================================
   
                 IBIS Model Transfer Agreement

The under-signed submitter has submitted the following models to
the IBIS library (list model filenames)

------------------------------------------------------------------------------

------------------------------------------------------------------------------

------------------------------------------------------------------------------

The submitter authorizes inclusion of the submitted models in the model
library.

The model files will be provided as is except for the addition of the
following statement to each file:

        [Disclaimer] IBIS Open Forum disclaims all warranties. See
        DISCLAIM.TXT in vhdl.org:/pub/IBIS/models for the full disclaimer.

If the models were written as a work made for hire in the course of
employment, the Work is owned by the company/employer which must sign this
agreement in the space provided below.

Submitter's Signature and Date  _______________________________

Typed or Printed Name and Title _______________________________

Institution or Company          _____________________________________________

Authorization (if required)     _______________________________

Typed or Printed Name and Title _______________________________

Please Check
___________

                         ___
  Submitter's Own Work   |  |
                         |__|
                         ___
  Work done for Hire     |  |
                         |__|

---

From: [email-masked] (Syed Huq)
Date: Mon, 9 Jan 95 15:27:29 PST

Mike,

Got a question on 'c' below. 

All files should be in a single file....Can you clarify this. Does this
mean the 'README.TXT' and the 'modelfile.ibs' in one file.

Regards,
Syed.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Syed B. Huq 
Applications Engineer/Data Transmission Products
National Semiconductor 
Tel:(408)721-4874; Fax:(408)721-4785
Internet:[email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~