Subject: bird 28 comments

From: Stephen Peters <[email-masked]>
Date: Wed, 19 Jul 1995 16:23:55 -0700

Hello Jon, and others:

     While I think that almost all realistic packages do have intersperced
ground I  have to agree with Jon -- there can be a situation of signal, GND,
signal coupling and thus the restriction becomes unworkable.  (There is also
Jon's original example of no grounds and the leads couple to there nearest
neighboor.  Even if this is unlikely the spec should handle this case.)
I guess my question now is what simulation tools will do if actual section
lenghts are included.  The scenario as I see it is:

 1.  The field solver assumes a bunch of parallel wires of infinite length,
     and reports coupling 'per unit length'.

 2.  The coupling per unit length, and the actual length of each section
     is entered into the package file.

 3.  Now, can existing simulation tools handle the actual, unequal lengths?
     For example, if one is stimulating a section of sig2, and it couples 
     to sig1 and sig3, would a simulation tool assume that all three sections
     are of equal length (perhaps use the average length).  Does a tool have to 
     include the extra length of the longer sections as an uncoupled bit of L/C?

    This is the question I think we need to discuss Friday.  Anyway, thanks for
your comments.

          Regards,
          Stephen Peters
          Intel Corp.

---

From: [email-masked] (Jon Powell)
Date: Wed, 19 Jul 95 16:59:12 PDT

Let me tell you what I think I would do.

For any group of lines that couple you need an "ACTIVE" line, that is, the one that
is going to be stimulated. This is usually the line in the middle of a group since outside lines
would, per se, couple to more lines surrounding them if they were ACTIVE. Now you build your simulation
net list. I would do something like:

P1 ===========================
A  ========================
P2 ====================

  |-------------------|---|--|

(A is active net and P1 and P2 are passive nets. Pretend they are at 45% angle as in Stephens drawing)

Net A would couple to P2 and P1 using a 3 config coupling for the length of P2. Net A would couple to net
P1 with a 2 config coupling from the end of P2 to the end of A. Net P1 would have an additional, "self only"
coupling for the rest of its length. Ideally, IBIS would supply this data, baring that, perhaps things could
be hacked. Of course, if we know how people are going to hack things we should just give the right data
to begin with.

jon