Subject: Experience with S2IBIS

From: Hsin-Huei Lin <[email-masked]>
Date: Thu, 13 Jul 1995 17:18:36 -0500

Hi,
	I would like to speak to anyone who has experience using s2ibis
to create IBIS data for ASIC design, please call me at (612)-574-4641.
 Thank you.

Hsin-Huei Lin
Medtronic, Inc.

---

From: Fred Vance <[email-masked]>
Date: Thu, 13 Jul 95 16:12:12 -0700

Hsin-Huei,

I have not used S2IBIS, but I have created IBIS models from SPICE models for use  
with ASIC designs. The models I created were for use as behavioral HSPICE models.  
This sounds circular (SPICE to IBIS to HSPICE), but IBIS SPICE models work a lot  
better than transistor-level SPICE in some of my applications.

I have also converted SPICE models to XTK models using XTK's SPI2XTK utility. I  
have even converted IBIS models to SPICE models so that I could then convert them  
to XTK models.

Something that is not always clear to new users of IBIS models is that IBIS models  
are independent of the tools that you use. If you are planning to use IBIS models  
with SPICE or Quad Design's XTK tool set and I can be of help to you, let me know.

Fred Vance, Engineer
FirePower Systems, Inc. (We make computers.)
Menlo Park, CA

---

From: Fred Vance <[email-masked]>
Date: Wed, 19 Jul 95 11:51:52 -0700

Kellee,

In response to your question:
>
>  I saw the posting you made to Hsin-Huei and was a little curious about
>your statement that IBIS is independent of the tools.  Are you aware
>that several tools directly support IBIS?
>
Yes. What I meant about IBIS being independent of tools is that IBIS models  
can be used by more than one tool. I was trying to make the point that an  
IBIS model is not a tool, but information for use with a tool.

Ironically, I caused a minor uproar in the past by stating (incorectly) that  
IBIS was not a model. At that time, I was trying to say that an IBIS model  
alone can not be used for simulation, but requires a simulation tool. 

I suppose that one could argue that since it is possible to use IBIS data in  
a Bergeron Plot that tools are not necessary for simulations with an IBIS  
model. I for one, want my tools.

I have tried in the past to make a distinction between IBIS, the  
specification and IBIS, the information or model. Now, I think I will have  
to make the further delineation, IBIS tools and IBIS compatible simulators.

You also wrote:

>  There are many tools out that directly support IBIS models.  For example
>both of our HyperLynx tools LineSim and BoardSim read and and use IBIS
>models without conversion.

I might have unintentionally given the impression that Quad Design doesn't  
have an IBIS tool. They do, it's called IBIS2XTK. (While I'm at it, I  
refered to Quad's tool SPI2MOD incorrectly as SPI2XTK.)

Also, Syed Huq told me that Meta-Software has a utility to convert an IBIS  
model to an HSPICE behavioral model.

I may have both of these utilities and haven't tried them yet. The reason? I  
did most of my library building in 1994 when these tools weren't available  
(or only under an NDA). Since then, new models that I received have been  
SPICE models.

I would like to be a strong advocate of IBIS. I believe it is great for  
everyone.

Regards,
Fred