Subject: bidirec-3state model

From: Stephen Peters <[email-masked]>
Date: Fri, 28 Jul 1995 13:52:44 -0700

Hello Syed:

     The a bi-directional pin is, by it's nature and function, assumed 
to be tri-stateable.  The model type to use is 'I/O'.

      Regards,
      Stephen Peters
      Intel Corp.

------

Hi,

How do I define the model type for a bi-directional 3-state pin.

I could use I/O but there is no defination for a I/O pin that can
be tri-statable.

Any suggestions..

Regards,
Syed
National Semiconductor

---

From: Arpad Muranyi <[email-masked]>
Date: Fri, 28 Jul 95 14:03:00 PDT

Text item: 

Syed,

As far as I understand, I/O is what you need to use.

Input means there is only a receiver on that pin.

Output means that there is only a driver on that pin, which is constantly 
driving either high or low.

I/O means that there is a receiver and a driver on that pin, which only makes 
sense if the driver can be disabled or 3-stated so that the receiver can receive
signals from other chips on the bus and not just from its own driver.

3-state means that there is only a driver on that pin, but because the device is
used on a bus, where other devices are also driving, it must be able to float 
also, even though it never "receives" signals.

What you are asking: "bi-directional 3-state" does not make sense to me in the  
above context.  Am I missing something, or is my answer what you needed to know?

Arpad Muranyi
Intel Corporation
------------------------------------------------------------------------------- 
Hi,

Any suggestions..

Regards,
Syed
National Semiconductor

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: bidirec-3state model
To: [email-masked]
From: [email-masked] (Syed Huq)
Date: Fri, 28 Jul 95 13:09:20 PDT
:12:10 -0700
Received: from hermes.intel.com by relay.jf.intel.com with smtp
     (Smail3.1.28.1 #2) id m0sbvlT-000twhC; Fri, 28 Jul 95 13:12 PDT

---

From: [email-masked] (Syed Huq)
Date: Mon, 31 Jul 95 08:57:16 PDT

Arpad/Stephen,

Thanks for your responses. An I/O type should work for my model.

This device is a bi-directional transceiver and both ports can 
be disabled from the bus.

Regards,
Syed
National Semiconductor