Subject: SOS (reply to Dileep)

From: Lynn Warriner <[email-masked]>
Date: Thu, 02 Mar 95 11:00:56 -0600

I agree with Kellee.  Specifically for the PowerPC chips the output transistors
have their own power and gnd pins.  Even the logic that drives the final devices
are independant of the output devices.  

The one problems that I see with IBIS modeling of SOS is accounting for the power
and gnd parasitics properly, including mutual inductances.  Also, information about
when the devices switch is important.  For example, by setting a few hundred pico
second skew on the switching of drivers on one PowerPC chip lead to a reduction of
the ground bounce voltage by a factor of two.  

To make this all meaningful -- The present IBIS models do not contain sufficent
package information and driver switching skews to provide an accurate model. 
However, it can certainly be used as a bounding case.

Regards,
Lynn Warriner

------- Forwarded Message

Received: from erebus.ibmoto.com (erebus.ibmoto.com [129.38.203.1]) by
styx.ibmoto.com (8.6.10/8.6.9) with ESMTP id VAA13967 for
<[email-masked]>; Wed, 1 Mar 1995 21:14:02 -0600
From: [email-masked]
Received: from vhdl.vhdl.org (VHDL.VHDL.ORG [198.31.14.3]) by
erebus.ibmoto.com (8.6.9/8.6.9) with SMTP id VAA16540 for
<[email-masked]>; Wed, 1 Mar 1995 21:14:54 -0600
Received: from washington.nwlink.com (nwlink.com) by vhdl.vhdl.org
(4.1/SMI-4.1/BARRNet)
	id AA03942; Wed, 1 Mar 95 19:15:07 PST
Date: Wed, 1 Mar 1995 19:09:04 -0800
To: [email-masked]
Subject: SOS (reply to Dileep)

Hi Dileep,

My assumptions are:
 1) Steady state currents can be ignored since they don't contribute
    significantly to ground bounce.

 2) Internal buffer currents driving low pF gate loads can be ignored
    relative to the much large output transistor, package, and external
    loading.

 3) Internal logic switching noise can be negelected.

 4) I have done hundreds of SOS measurements with PLD's and FPGA's.  The
    output buffer switching with all other internal logic held constant
    always seemed to generate the majority of the SOS energy.  I admit I
    don't have any data about chips like the new advanced microprocessors.
    Although I did do some SOS tests on a 68000 about 10 years ago and the
    buffer loading was again the major contributor.

  5)Cross over region currents are small.  That is the current that flows
    when both devices in a totem pole or CMOS output is smaller than the
    current resulting from the output switching the load and package 
    and parasitic capacitance of the output stage.  This is the one that I
    believe has the most room to cause error.  But it is also highly process
    dependant.

So in summary, while there are hundreds of other effects contributing to SOS
I believe the output buffer transition is at least the major contributor.

I won't be insulted if someone want's to tell me I am full of IBIS droppings.
This is just some seat of the pant's info I have used over the years.

Kellee

Have a great day...Kellee Crisafulli, HyperLynx Inc.

------- End of Forwarded Message

---

From: Will Hobbs <[email-masked]>
Date: Thu, 2 Mar 95 10:29:29 PST

Text item: 

Lynn,

all of these concerns are addressed in IBIS 2.1.

Regards,

Will Hobbs

The one problems that I see with IBIS modeling of SOS is accounting 
for the power
and gnd parasitics properly, including mutual inductances.  Also, information 
about
when the devices switch is important.  For example, by setting a few 
hundred pico
second skew on the switching of drivers on one PowerPC chip lead to 
a reduction of
the ground bounce voltage by a factor of two.

Regards,
Lynn Warriner

Hi Dileep,

My assumptions are:

Kellee

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

From: Lynn Warriner <[email-masked]>
Date: Thu, 02 Mar 95 11:00:56 -0600
Subject: SOS (reply to Dileep)
Cc: [email-masked], [email-masked]
To: [email-masked]
Message-Id: <[email-masked]>
Received: (bert@localhost) by lw.ibmoto.com (8.6.10/8.6.9) id LAA19775; Thu, 2 M
ar 1995 11:00:56 -0600
Received: from lw.ibmoto.com (lw.ibmoto.com [129.38.13.34]) by styx.ibmoto.com (
8.6.10/8.6.9) with ESMTP id LAA27012; Thu, 2 Mar 1995 11:00:57 -0600
Received: from styx.ibmoto.com by vhdl.vhdl.org (4.1/SMI-4.1/BARRNet)
     id AA12740; Thu, 2 Mar 95 09:08:15 PST
Received: from VHDL.VHDL.ORG by hermes.intel.com (5.65/10.0i); Thu, 2 Mar 95 09:
34:47 -0800
Received: from hermes.intel.com by ichips.intel.com (5.64+/10.0i); Thu, 2 Mar 95
 09:34:54 -0800
Received: from ichips.intel.com by relay.jf.intel.com with smtp
     (Smail3.1.28.1 #2) id m0rkEm8-000twrC; Thu, 2 Mar 95 09:34 PST