Subject: Re: Clarifing example for Packaging EGG

From: [email-masked] (C. Kumar)
Date: Mon, 8 May 95 10:26:56 -0400

I thank Jon for the quick response. Let me make my arguements clearer.

The arguements John put forward are precisely the ones which the spice subcircuit defintions solve in a clean and elegant fashion . A subcircuit defintion is highly flexible. It can be designed for any LEVEL of granularity. A subcircuit can represent single pins as well as any ARBITRARY grouping of pins. A package model may consists of a COLLECTON  of these subcircuits. 

Say in Jon's  example PIN 1 and 2 are uncoupled while 3 and 4 are coupled. 
Then the package subcircuits may have the form.

.subckt pin1defintion buf1 pin1
..
.ends

.subckt pin2defintion buf2 pin2
..
.ends

.subckt pin3pin4defintion buf3 buf 4 pin3 pin4
...

.ends

There is nothing in these subcircuit defintions which "demands" the 
simulation of all 28 pins.

The role of IBIS may then be to offer GUIDELINES as to the granularity and the 
number of subcircuits that should represent the package model.

> 
> Here is a counter-example that shows that SPICE-like connectivity descriptions are
> probably not sufficient.
> 
> ---+
>    |- PIN 1
>    |- PIN 2
>    |- PIN 3
>    |- PIN 4
>    |- PIN 5
>    |- PIN 6
>    |- PIN 7
>    |- PIN 8
>    |- PIN 9
>    |- PIN 10
>    |- PIN 11
>    |- PIN 12
>    |- PIN 13
>    |- PIN 14
>    |- PIN 15
>    |- PIN 16
>    |- PIN 17
>    |- PIN 18
>    |- PIN 19
>    |- PIN 20
>    |- PIN 21
>    |- PIN 22
>    |- PIN 23
>    |- PIN 24
>    |- PIN 25
>    |- PIN 26
>    |- PIN 27
>    |- PIN 28
> ---+
> 
> All adjacent pins couple significantly. All pins further that two away do not couple in any measureable manner.
> A circuit that demands the simulation of all 28 pins (and therefor all 28 nets connecting to these pins) at the
> same time is not acceptable. A mechanism that allows overlapping and redundant coupling descriptions is needed.
> I do not believe that the SPICE SUBCKT concept will handle this situation.
> 
> I think this (by the way) will be the rule, rather than the exception.
> 
> 
> jon
>

---

From: [email-masked] (Jon Powell)
Date: Mon, 8 May 95 11:26:40 PDT

kumar,

you are missing my point.

give me an example where:

 pin 1 couples to pin 99 and 2.
 pin 2 couples to pin 1 and 3.
 pin 3 couples to pin 2 and 4.
 pin 4 couples to pin 3 and 5.
 pin 5 couples to pin 5 and 6.
 ...

case a:
all 3 pin groupings couple with exactly the same 3 element matrix.

case b:
all 3 pin groupings couple with different 3 element matrices.