Subject: Ramp Def. ??

From: Stephen Peters <[email-masked]>
Date: Wed, 23 Oct 1996 18:18:45 -0700

Hello Ahmed:

   It's the 20% to 80% of the voltage swing.  Specifically
the Dt number is calculated as (for rising wavefront)....

(time at which voltage waveform crosses [.8(voltage swing) +
starting voltage])  -  (time at which voltage waveform crosses
[.2(voltage swing) + starting voltage]).

         Hope that helps.

           Regards,
           Stephen Peters
           Intel Corp.

Hello IBIS people

Is ramp rate defined as the time it takes the output to go:
(a) 20% to 80% of output final value
 or
(b) 20% to 80% of output voltage swing*

* I define voltage swing as the difference 
  between final value and initial value. 
 
For example;
Say, the output swings 1 to 5 volts.    |    5 v        ____
To calculate the ramp rate do I use     |              /
(a) 20% to 80% of 5 volts               |             /
 or                                     |            /
(b) 20% to 80% of 4 volts               |    1v ____/
 
Regards, Ahmed.
|---------------------------------------+------------------------------------|
|Ahmed Omer                             | Advanced Interconnect Systems Labs |
|E-MAIL: [email-masked]  | Semiconductor Products Sector      |
|      : [email-masked]       | M O T O R O L A, Inc.              |
|Phone:	 512-933-2247                   | 3501 Ed Bluestein Blvd  MDrop: F36 |
|Fax:	 512-933-5845                   | Austin, TX 78721                   |
|---------------------------------------+------------------------------------|

---

From: [email-masked] ( Bob Ross)
Date: Wed, 23 Oct 96 18:29 PDT

Ahmed:

Case (b).

The 20% and 80% voltage points are 1.8 V and 4.2 V.

Best Regards,
Bob Ross
Interconnectix, Inc.

> Date: Wed, 23 Oct 1996 18:17:25 -0500
> From: [email-masked] (Ahmed Omer)
> Message-Id: <[email-masked]>
> To: [email-masked]
> Subject: Ramp Def. ??
> X-Sun-Charset: US-ASCII
> Status: RO

---

From: [email-masked] (Ahmed Omer)
Date: Thu, 24 Oct 1996 09:38:40 -0500

Hello Bob and Stephen

	Thank you for your responses. Your answers are what I expected.
However, the IBIS specifications are not clear on that. In fact it defines 
ramp rate in both ways. So we should make correction on the specifications.

Regards, Ahmed.

>>>> Bob Ross wrote:

Ahmed:

Case (b).

Best Regards,
Bob Ross
Interconnectix, Inc.

>>>> Stephen Peters wrote:

Hello Ahmed:

         Hope that helps.

           Regards,
           Stephen Peters
           Intel Corp.

>>>> Ahmed Omer wrote:

Hello IBIS people

 
For example;
 
Regards, Ahmed.
|____________________________________________________________________________|

---

From: Arpad Muranyi <[email-masked]>
Date: Thu, 24 Oct 96 07:50:00 PDT

Text item: 

It is 20-80% of the swing.
Arpad Muranyi
Intel Corporation

===========================================

Hello IBIS people

For example;

Regards, Ahmed.
|Phone:      512-933-2247                   | 3501 Ed Bluestein Blvd  MDrop: F36
 |

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: Ramp Def. ??
To: [email-masked]
From: [email-masked] (Ahmed Omer)
Date: Wed, 23 Oct 1996 18:17:25 -0500
4.1/Email-2.0)
     id AA15671 for [email-masked]; Wed, 23 Oct 96 16:16:26 MST
Received: from mogate.sps.mot.com by spsgate.sps.mot.com (4.1/SMI-4.1/Email 2.1
10/25/93)
     id AA19072 for [email-masked]; Wed, 23 Oct 96 16:16:27 MST
Received: from spsgate.sps.mot.com (spsgate.sps.mot.com [192.70.231.1]) by vhdl.
vhdl.org (8.7.3/8.7.3) with SMTP id QAA06076 for <[email-masked]>; Wed, 23 Oct 19
96 16:27:12 -0700 (PDT)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by ormail.intel.com (
8.7.6/8.7.3) with ESMTP id QAA29638; Wed, 23 Oct 1996 16:20:16 -0700 (PDT)
Received: from ormail.intel.com (ormail.intel.com [134.134.248.3]) by relay.jf.i
ntel.com (8.7.4/8.7.3) with ESMTP id QAA04218; Wed, 23 Oct 1996 16:20:15 -0700 (
PDT)
Return-Path: [email-masked]

---

From: Arpad Muranyi <[email-masked]>
Date: Tue, 29 Oct 96 10:10:00 PST

Text item: 

Ahmed,

In my opinion, the IBIS spec defines the ramp rates only one way, and clearly.  
See included sections below.  Could you please point it out to me where you 
think the other definition is in the spec?

Thanks,

Arpad Muranyi
Intel Corporation

|==============================================================================
|     Keyword:  [Ramp]
|    Required:  Yes, except for inputs and terminators
| Description:  Defines the rise and fall times of a buffer.  The ramp rate
|               does not include packaging but does include the effects of the
|               C_comp parameter.
|  Sub-Params:  dV/dt_r, dV/dt_f, R_load
| Usage Rules:  The rise and fall time is defined as the time it takes the
|               output to go from 20% to 80% of its final value.
|               The ramp rate is defined as:
|
|               dV          20% to 80% voltage swing
|               -- = ----------------------------------------
|               dt   Time it takes to swing the above voltage
|
|               The ramp rate must be specified as an explicit fraction
|               and must not be reduced.  The [Ramp] values can use "NA" for
|               the min and max values only.  The R_load subparameter is
|               optional if the preferred 50 ohm load is used.  The R_load sub-
|               parameter is required if a non-standard load is used.
|==============================================================================
|
|                       NOTES ON DATA DERIVATION METHOD
|
|
| 3) Ramp Rates:
|
|    c. Due to the resistor, output swings will not make a full transition as
|       expected.  However the pertinent data can still be collected as
|       follows:
|           1)  determine the 20% to 80% voltages of the 50 ohm swing
|           2)  measure this voltage change as "dV"
|           3)  measure the amount of time required to make this swing "dt"
|

===============================================================================
Hello Bob and Stephen

Regards, Ahmed.

Ahmed:

Case (b).

Best Regards,
Bob Ross
Interconnectix, Inc.

Hello Ahmed:

         Hope that helps.

           Regards,
           Stephen Peters
           Intel Corp.

Hello IBIS people

For example;

Regards, Ahmed.

Subject: Re: Ramp Def. ??
To: [email-masked]
From: [email-masked] (Ahmed Omer)
Date: Thu, 24 Oct 1996 09:38:40 -0500
4.1/Email-2.0)
     id AA28890 for [email-masked]; Thu, 24 Oct 96 07:37:42 MST
Received: from mogate.sps.mot.com by spsgate.sps.mot.com (4.1/SMI-4.1/Email 2.1
10/25/93)
     id AA27429 for [email-masked]; Thu, 24 Oct 96 07:37:47 MST
Received: from spsgate.sps.mot.com (spsgate.sps.mot.com [192.70.231.1]) by vhdl.
vhdl.org (8.7.3/8.7.3) with SMTP id HAA29154 for <[email-masked]>; Thu, 24 Oct 19
96 07:48:37 -0700 (PDT)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by ormail.intel.com (
8.7.6/8.7.3) with ESMTP id HAA05439; Thu, 24 Oct 1996 07:45:44 -0700 (PDT)
Received: from ormail.intel.com (ormail.intel.com [134.134.248.3]) by relay.jf.i
ntel.com (8.7.4/8.7.3) with ESMTP id HAA21430; Thu, 24 Oct 1996 07:45:43 -0700 (
PDT)
Return-Path: [email-masked]

---

From: [email-masked] (Ahmed Omer)
Date: Wed, 30 Oct 1996 10:02:41 -0600

Hello Arpad,

Look at the two phrases marked with  ***<...>*** in the Usage Rules.
These are (a) and (b) in my original question.

| Usage Rules:  The rise and fall time is defined as the time it takes the
|               output to go from ***< 20% to 80% of its final value.>***
|               The ramp rate is defined as:
|
|               dV        ***< 20% to 80% voltage swing >***
|               -- = ----------------------------------------
|               dt   Time it takes to swing the above voltage
|
  
Regards, Ahmed.

---

From: Arpad Muranyi <[email-masked]>
Date: Wed, 30 Oct 96 08:52:00 PST

Text item: 

Ahmed,

I see your point.

I guess, the question is what do you think is the final value.  When we wrote 
this, we were thinking about the final value under the given test conditions, 
which was defined to be a 50 Ohm resistive load.  Therefore, the final value is 
not a rail-to-rail swing, because the resistor won't let that happen.

Consider a rising edge measurement (for a CMOS device).  Before the pullup 
begins to drive, the voltage on the output is at GND, because the load resistor 
is also connected to GND, so there is no current flowing in the loop.  So the 
starting voltage of the swing is 0 V.  When the pullup is done switching, you 
get a voltage division across the pullup and the load resistor.  This is your 
final value after the transition.  Considering the 0 V starting voltage, this 
number is also equal to the swing.

I quess, this could have been written up a little more clearly, but we are 
engineers, not lawyers.  And so far I didn't hear that any one else was confused
by this.

I hope this helps,

Arpad Muranyi
Intel Corporation
================================================================================

Hello Arpad,

Regards, Ahmed.

Subject: Re: Re[2]: Ramp Def. ??
To: [email-masked]
From: [email-masked] (Ahmed Omer)
Date: Wed, 30 Oct 1996 10:02:41 -0600
4.1/Email-2.0)
     id AA13288 for [email-masked]; Wed, 30 Oct 96 09:01:49 MST
Received: from mogate.sps.mot.com by spsgate.sps.mot.com (4.1/SMI-4.1/Email 2.1
10/25/93)
     id AA03916 for [email-masked]; Wed, 30 Oct 96 09:01:50 MST
Received: from spsgate.sps.mot.com (spsgate.sps.mot.com [192.70.231.1]) by vhdl.
vhdl.org (8.7.3/8.7.3) with SMTP id IAA12672 for <[email-masked]>; Wed, 30 Oct 19
96 08:12:39 -0800 (PST)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by mailbag.jf.intel.c
om (8.8.2/8.7.3) with ESMTP id IAA19234; Wed, 30 Oct 1996 08:11:42 -0800 (PST)
Received: from mailbag.jf.intel.com ([email-masked] [134.134.248.4])
by relay.jf.intel.com (8.7.4/8.7.3) with ESMTP id IAA12640; Wed, 30 Oct 1996 08:
09:09 -0800 (PST)
Return-Path: [email-masked]

---

From: [email-masked] (Ahmed Omer)
Date: Thu, 31 Oct 1996 09:10:01 -0600

Hello Arpad;
 
In your last note on this subject you wrote:

" I quess, this could have been written up a little more clearly, but we are 
engineers, not lawyers.  And so far I didn't hear that any one else was 
confused by this."

I do not understand! What point or points are you making with that paragraph?

Regards, Ahmed.

---

From: Arpad Muranyi <[email-masked]>
Date: Thu, 31 Oct 96 17:12:00 PST

Text item: 

Ahmed,

I meant to say that lawyers have a good ability to put things in words so that 
noone can misinterpret what they say at a later time.  (I could be wrong on that
though).

Writing a spec in a non-misinterpretable way is very difficult, and I find that 
very often what I meant to say gets interpreted differently by someone else, 
because they have a different vocabulary, background, mindframe, etc.  This is 
what might have been the case here too.

It was totally clear to me that both places were saying the same, and yet you 
thought that it meant rail-to-rail in the first place, and 20-80 % in the 
second.  However, you were the first one I heard this interpretation from...

Arpad

Hello Arpad;

Regards, Ahmed.

Subject: Re: Re[4]: Ramp Def. ??
To: [email-masked]
From: [email-masked] (Ahmed Omer)
Date: Thu, 31 Oct 1996 09:10:01 -0600
4.1/Email-2.0)
     id AA11454 for [email-masked]; Thu, 31 Oct 96 08:09:09 MST
Received: from mogate.sps.mot.com by spsgate.sps.mot.com (4.1/SMI-4.1/Email 2.1
10/25/93)
     id AA16258 for [email-masked]; Thu, 31 Oct 96 08:09:13 MST
Received: from spsgate.sps.mot.com (spsgate.sps.mot.com [192.70.231.1]) by vhdl.
vhdl.org (8.7.3/8.7.3) with SMTP id HAA09744 for <[email-masked]>; Thu, 31 Oct 19
96 07:20:34 -0800 (PST)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by mailbag.jf.intel.c
om (8.8.2/8.7.3) with ESMTP id HAA18237; Thu, 31 Oct 1996 07:21:31 -0800 (PST)
Received: from mailbag.jf.intel.com ([email-masked] [134.134.248.4])
by relay.jf.intel.com (8.7.4/8.7.3) with ESMTP id HAA12474; Thu, 31 Oct 1996 07:
18:59 -0800 (PST)
Return-Path: [email-masked]