Subject: Re: Rising Waveform Loading Effects

From: [email-masked] (Dileep Divekar)
Date: Tue, 29 Oct 1996 13:59:35 +0800

Arpad Muranyi, Intel Corporation wrote:
 
> What I mean by this is, that if the simulator is smart enough, it can take the 
> data and modify it, derive new curves, etc.  So, if you have an I-V curve and a 
> V-t curve which was generated with 50 Ohm resistive load in the model, a good 
> simulator should derive a new V-t curve that matches the different load 
> resistance in that particular simulation.  Taking this further, the simulator 
> could make V-t curves with reactive loads also.  In general, then, the simulator
> can simulate at each iteration with a different set of curves that matches any 
> loading condition, even if the "load" is another non-linear I-V curve.  The 
> point here is that the data in the IBIS model is not supposed to be a limiting 
> factor to what the simulator does with it.

This is not quite true. Simulator cannot CREATE additional information.
If V-t data is given only for one resistive load, how can the simulator
create V-t data for arbitrary loading conditions? To illustrate the point,
let us assume that the so called "load" can be described by only one
independent variable. (In real life, it is an n-dimensional problem.)
Let us assume that the dependent entity is the V-t curve. Thus, in this
hypothetical two dimension space, the ibis specification gives one data
point. From this single data point, there is no way to produce a straight
line, or at least there is no UNIQUE way. If the ibis specification were
to give two data points, then one can say that the simulator should be
smart enough to fit a straight line thru these two points and then
interpolate and extrapolate(although extrapolation is dangerous in many
situations).
[In practice, ibis specification has room to provide V-t curves for
multiple loads, but the simulator is still limited by the information
provided in the ibis model. It cannot CREATE V-t curves for the
general n-dimensional case. The simulator may be able to do this if it
makes certain assumptions, but since these assumptions are not specified
in the ibis model, the simulation results will be unpredictable (and even
unreliable).]

------------------------------------------------------------
Dileep Divekar
Applied Simulation Technology, Inc.
2188 Bering Drive
San Jose, CA 95131

Phone - (408)-434-0967 x 100
Fax   - (408)-434-1003
Email - [email-masked]
------------------------------------------------------------

---

From: Chris Rokusek <[email-masked]>
Date: Tue, 29 Oct 1996 15:36:52 -0800

Dileep,

There are a few "dimensions" of knowledge not explicity present in the
.ibs model which may be useful to a simulator:

   - Nearly all digital drivers can be catagorized into one
     of a few unique output stages groups whose behavior
     can been studied in depth.

   - Transistors are well defined devices whose behavior 
     has been studied for decades.

*** Simulator modeling algorithms are not trivial.

Given DC vi curves for high/low states and predetermined resistively
loaded waveforms as required by simulator, waveform prediction into
arbitrary loads is possible, proven and extremely reliable for
board-level analysis.

-Chris Rokusek
Quad Deisgn Technology