Subject: Rising Waveform Loading Effects

From: "Boeckmann, Ed (Edward F)" <[email-masked]>
Date: Thu, 24 Oct 1996 10:25:42 -0500

Hello to all,

I am concerned about the validity of using IBIS models for general
printed circuit board signal analysis in an environment of various types
of loads, transmission lines, vias, pads, connectors, various
terminations, etc.

According to the IBIS specification V2.1 dated Dec. 13, 1995,  for a
rising waveform (for example), there are various loads specified as
L_dut, R_dut, L_fixture, R_fixture, C_dut, and C_fixture.  In addition
data is to be taken with the effects of C_comp included.  There is
however no provision for generating curves with a transmission line load
which is more typically the case, especially for high speed circuits. in
actual circuit boards.

It is well known however, that the ramp rate and levels reached will be
affected by the loads. For example, changing  the values of R_fixture
and V_fixture on a typical buffer. (The s2ibis2 program will generate
different curves for different values of R_fixture, for example IBIS
curves for  50 ohms and 100 ohms is generated from a command file that
specified curves for 50 and 100 ohms.)

My question is this:  If in an actual simulation environment we really
have a different loading condition with transmission lines , vias, etc.,
how can we legitimately use an IBIS model that was generated with a
different lumped element loading condition ?

I hope someone can help me to understand how the IBIS models will
accurately produce the correct physical response with an arbitrary but
realistic loading condition, different from the test fixture, at least
to a level of accuracy close to that which would result from the
original transistor level spice model, say within 5%.

Ed Boeckmann,  "My comments reflect solely my own opinion!"
Intergraph Corp.
Huntsville AL 35894
tel. (205)-730-6219
fax (205)-730-6000
email [email-masked]

---

From: [email-masked] (Richard A. Schumacher)
Date: Tue, 29 Oct 1996 08:23:10 -0600

The current crop of IBIS models are a far cry from being accurate enough 
to really predict the kinds of things Jon is talking about, but many of
them are good enough to ensure that I don't drastically mis-terminate
the transmission lines on my boards.

	One almost does not need any models for that, IBIS or otherwise.
	If a simulator will not provide 200 mV and 500 psec accuracy 
	while simulating a situation complex enough to be non-intuitive
	then it's hardly worth the trouble.

Another question to think about: do Ibis models derived from Spice models
really have the kind of accuracy that Jon needs?

	I don't know. How do we know how accurate such IBIS models
	are? That uncertainty is why I'm not rushing to embrace IBIS
	as a substitute for SPICE or measurement-derived I-V curves 
	in simulation. When a vendor is willing to make direct 
	comparisions between simulations (using their own nominal 
	SPICE models, measured I-V curves and IBIS models) and 
	measurements of actual circuits, and demonstrate at least 
	200 mV/500 psec accuracy, then I'll start to have some 
	confidence. Such simulations must address realistic situations
	in multiple cases (heavy vs light loading, lumped vs 
	transmission line environments), and not merely 50 pF - 500 
	ohm test cases. Until then I'll continue to press vendors 
	for SPICE models or I-V curves, or generate my own. 

	Richard Schumacher

	I do not speak in any capacity for the Convex Division of the
	Hewlett Packard Company.

---

From: Arpad Muranyi <[email-masked]>
Date: Tue, 29 Oct 96 08:49:00 PST

Text item: 

Richard,

Believe it or not, the kinds of comparisons that you are longing for are/were 
being done by vendors (at least by Intel).  When we began to use IBIS, (or our 
IBIS-like behavioral models), the first thing we wanted to know was how accurate
they are.  If they would have not provided the accuracy, we wouldn't have gone 
out to simulation vendors to see if they are willing to sign up to a new 
standard, just to embarrass ourselves...  Also, we use these in our own 
simulations.  Do you think we would fool ourselves with a bunch of bogus data 
and spend millions of dollars in making chips based on that?

I wonder how familiar you are with the IBIS modeling technique, at all.  You say
you would rather take I-V curves or SPICE models from the vendors than IBIS 
models.  Do you realize that the IBIS models you do not want to accept contain 
the same I-V curves (and more) that you are willing to take?

Arpad Muranyi
Intel Corporation 
===============================================================================

     Richard Schumacher

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Cc: <[email-masked]>,
        <[email-masked]>,
        [email-masked], [email-masked],
        [email-masked], [email-masked],
        [email-masked],
        [email-masked],
        [email-masked]
Subject: Re: Rising Waveform Loading Effects
To: [email-masked], [email-masked]
From: [email-masked] (Richard A. Schumacher)
Date: Tue, 29 Oct 1996 08:23:10 -0600
7.3/8.7.3) with ESMTP id GAA14594; Tue, 29 Oct 1996 06:34:50 -0800 (PST)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by mailbag.jf.intel.c
om (8.7.6/8.7.3) with ESMTP id GAA13125; Tue, 29 Oct 1996 06:32:04 -0800 (PST)
Received: from mailbag.jf.intel.com ([email-masked] [134.134.248.4])
by relay.jf.intel.com (8.7.4/8.7.3) with ESMTP id GAA28416; Tue, 29 Oct 1996 06:
29:30 -0800 (PST)
Return-Path: [email-masked]

---

From: Arpad Muranyi <[email-masked]>
Date: Tue, 29 Oct 96 09:18:00 PST

Text item: 

Ed,

Your concern is well taken.  However, I would like to point out that an IBIS 
model is nothing but data.  The V-t curve in the IBIS model is not supposed to 
be the same as the simulation waveforms, unless the load is identical to the 
load that was used to generate the V-t curve.  The simulator can do anything to 
this data.

What I mean by this is, that if the simulator is smart enough, it can take the 
data and modify it, derive new curves, etc.  So, if you have an I-V curve and a 
V-t curve which was generated with 50 Ohm resistive load in the model, a good 
simulator should derive a new V-t curve that matches the different load 
resistance in that particular simulation.  Taking this further, the simulator 
could make V-t curves with reactive loads also.  In general, then, the simulator
can simulate at each iteration with a different set of curves that matches any 
loading condition, even if the "load" is another non-linear I-V curve.  The 
point here is that the data in the IBIS model is not supposed to be a limiting 
factor to what the simulator does with it.

Of course this is not the only way things can be done, I was just trying to 
illustrate the concept.

The reason resistive (and not reactive or transmission line) loads are preferred
for generating V-t curves is that with a resistive load we get only what the 
buffer does.  With other types of loads we get what the load does also.  Why 
would one want to add all that to the V-t curves when it will have to be taken 
out anyway to model just the buffer alone?

Arpad Muranyi
Intel Corporation
================================================================================

Hello to all,

Encoding: 41 TEXT
X-Mailer:  Microsoft Exchange Server Internet Mail Connector Version 4.0.994.57
Date: Thu, 24 Oct 1996 10:25:42 -0500
Subject: Rising Waveform Loading Effects
To: "[email-masked]'" <[email-masked]>
From: "Boeckmann, Ed (Edward F)" <[email-masked]>
Message-ID: <c=US%a=_%p=INTERGRAPH%l=[email-masked]
m>
Received: by hq15.pcmail.ingr.com with SMTP (Microsoft Exchange Server Internet
Mail Connector Version 4.0.994.57)
     id <[email-masked]>; Thu, 24 Oct 1996 10:26:59 -050
0
Received: from hq15.pcmail.ingr.com (hq15.pcmail.ingr.com [129.135.251.243]) by
vhdl.vhdl.org (8.7.3/8.7.3) with SMTP id IAA29698 for <[email-masked]>; Thu, 24 O
ct 1996 08:37:41 -0700 (PDT)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by ormail.intel.com (
8.7.6/8.7.3) with ESMTP id IAA14618; Thu, 24 Oct 1996 08:30:29 -0700 (PDT)
Received: from ormail.intel.com (ormail.intel.com [134.134.248.3]) by relay.jf.i
ntel.com (8.7.4/8.7.3) with ESMTP id IAA00404; Thu, 24 Oct 1996 08:30:29 -0700 (
PDT)
Return-Path: [email-masked]

---

From: [email-masked] (Ian Dodd)
Date: Tue, 29 Oct 96 16:30:16 MST

Dileep,
	I am afraid I side with Arpad, the Rising waveform curves define how the 
driver gets from one specified point on the logic low I/V curve to a 
specified point on the high I/V curve. 

	In transmission line simulation we want to know how the driver will
go from a  point on the logic low I/V curve defined by our loading to a point on
the logic high I/V curve defined by our loading. 
If the first IV points and the ones that we want to use for our loading conditions
are not too far apart, it seems reasonable to assume that
the curve between the two points we want is very similar in shape to that connecting
the two points on the Rising curve. An algorithm based on this observation should give
predictable and reliable results.

						Ian Dodd
						Veribest Inc
						[email-masked]  

----- Begin Included Message -----

---

From: [email-masked] (Dileep Divekar)

> factor to what the simulator does with it.

This is not quite true. Simulator cannot CREATE additional information.
If V-t data is given only for one resistive load, how can the simulator
create V-t data for arbitrary loading conditions? To illustrate the point,
let us assume that the so called "load" can be described by only one
independent variable. (In real life, it is an n-dimensional problem.)
Let us assume that the dependent entity is the V-t curve. Thus, in this
hypothetical two dimension space, the ibis specification gives one data
point. From this single data point, there is no way to produce a straight
line, or at least there is no UNIQUE way. If the ibis specification were
to give two data points, then one can say that the simulator should be
smart enough to fit a straight line thru these two points and then
interpolate and extrapolate(although extrapolation is dangerous in many
situations).
[In practice, ibis specification has room to provide V-t curves for
multiple loads, but the simulator is still limited by the information
provided in the ibis model. It cannot CREATE V-t curves for the
general n-dimensional case. The simulator may be able to do this if it
makes certain assumptions, but since these assumptions are not specified
in the ibis model, the simulation results will be unpredictable (and even
unreliable).]

------------------------------------------------------------
Dileep Divekar
Applied Simulation Technology, Inc.
2188 Bering Drive
San Jose, CA 95131

Phone - (408)-434-0967 x 100
Fax   - (408)-434-1003
Email - [email-masked]
------------------------------------------------------------

----- End Included Message -----

---

From: [email-masked] (Dileep Divekar)
Date: Wed, 30 Oct 1996 08:09:09 +0800

Ian,
I agree with your statement about I-V curves.
I was talking avout the V-t tables.
Dileep

---

From: [email-masked] (Dileep Divekar)
Date: Wed, 30 Oct 1996 08:30:53 +0800

Chris Rokusek, Quad Deisgn Technology wrote:
>
>There are a few "dimensions" of knowledge not explicity present in the
>.ibs model which may be useful to a simulator:

That is precisely my point. You are making certain assumptions and guesses,
which are OUTSIDE the ibis specification. In fact you are trying to guess
the information which ibis is trying to hide. What do you do if you encounter
some data which does not fit any of your guesses?

All the knowledge "dimensions" should be utilized in developing the specification,
but once the specification is developed, it should have any loose ends.

Let us assume that you have a simulator which can predict waveforms for any
arbitrary load, given ONE waveform for one RESISTIVE load. But the ibis
specification does not specify that. A model developer can specify a waveform
into a general RLC load (as shown in the example on page 19 of 2.1 specification)
and claim that they have provided a perfectly legal ibis model and now it is
up to the simulator to do the rest. What does
the simulator do in this case with the waveform with all the ringing, overshoot,
undershoot etc.? The simulator should not place restrictions in ADDITION to
the ibis specification. Therefore, if one waveform into one resistive load
is all that is required, then it should be stated explicitly. Otherwise
different people can make different assumptions and guesses. If certain things
are REQUIRED to carry out a simulation, then the ibis model should SPECIFY
those things instead of leaving them to guesswork.
------------------------------------------------------------
Dileep Divekar
Applied Simulation Technology, Inc.
2188 Bering Drive
San Jose, CA 95131

---

From: "C. Kumar" <[email-masked]>
Date: Thu, 31 Oct 1996 13:43:02 -0500

I think I get the point Dileep is trying to make. It is true that with the V-t data there is no UNIQUE solution possible. This problem will baloon when we add multi stage models.

The real issue is IBIS is ONLY data. And the data is subject to different interpolation and extrapolation schemes. In other words this data by in itself cannot guarantee that different simulators will produce the same result. Neither can it say which one is correct. The only locus is the golden waveform. In this respect IBIS data  is fundamentally different from a macro model , where you should expect the same results from different simulators. IBIS data is rather a precursor to a macro model, which we do not have any standard for.

- kumar

> From [email-masked] Tue Oct 29 17:31 EST 1996
> Received-Date: Tue, 29 Oct 1996 17:31:23 -0500
> From: [email-masked] (Dileep Divekar)
> To: [email-masked]
> Cc: [email-masked]
> X-Sun-Charset: US-ASCII
> Content-Type: text
> Content-Length: 2417
> X-Lines: 46
> 
>