Subject: [Resistance Matrix] keyword

From: haselect <[email-masked]>
Date: Sun, 7 Apr 1996 19:04:04 -0400

Hello Ibisians,

      I wonder if somebody could clarify the use of resistance matrices in
package models. Should the values entered in these matrices be in Siemens or
Ohms?

      It seems to me that the resistance matrix is really a conductance
matrix, because in the case of a banded matrix (for example) it is assumed
that values outside the bandwidth are zero - doesn't this mean zero Ohms and
so wouldn't it mean that the corresponding pins would be short circuited
togther?  Zero conductance on the other hand would imply an open circuit
which would make more sense.

     For example if we had a 2 pin package:

[Resistance Matrix]   Banded_matrix
[Bandwidth]             0
[Row]     1
1.0
[Row]     2
1.0

  My understanding of the IBIS spec' leads me to understand that the full
matrix would be:

        | 1  0 | 
        | 0  1 |

I.e. pins 1 and 2 have resistances of 1 Ohm, but there is a 0 Ohm short
circuit between them.

Have I misunderstood something here?

I'm about to model a device package where there is a degree of resistive
coupling between the pins and I need to know the correct units to use,
Siemens or Ohms?
Haruny Said
H.A.S. Electronics, Inc.
130 Bishop Allen Drive
Cambridge MA 02139
Email  [email-masked]
WWW http://www.haselect.com

Phone (617) 868 7828

---

From: Eric Bracken <[email-masked]>
Date: Mon, 08 Apr 1996 08:28:20 -0400

With regard to the units:

  It's Ohms.    

With regard to the off-diagonal entries of the R-matrix:

  [R] really represents the voltages developed along the conductors in
response to DC current flows:

        V1  =  R11 * I1 + R12 * I2
        V2  =  R12 * I2 + R22 * I2

If R12 = 0, this is just saying that 

        V1 = R11 * I1    and    V2 = R22 * I2

and so the only voltage drop you get on the wire is due to current
flowing along THAT wire, and not the other one.  This is like having
two separate wires with an ideal ground return:

              I2
             ---->   
         V2  0---[  R22  ]---0 V2 - R22*I2

         I1
        ---->
    V1  0----[  R11  ] ---0  V1 - R11*I1
        +                  +
            -                -
             0----------------0  
              ground (ideal)
                     <---------
                       I1 + I2

Note that by KCL the current flowing back along the ground line is I1
+ I2; in this ideal case, there's no voltage developed due to the
ground current.

In the case where R12 is NONzero, this is like having a ground return
with some resistance Rg associated with it:

              I2
             ---->   
         V2  0---[  R2   ]---0 V2 - R2*I2 - Rg*(I1 + I2)

         I1
        ---->
    V1  0----[  R1   ] ---0  V1 - R1*I1 - Rg*(I1 + I2)
        +                  +
            -                -
             0----[  Rg  ]----0
              ground (nonideal)
                     <---------
                       I1 + I2

Here, R12 = Rg and R11 = R1 + Rg, R22 = R2 + Rg.

I hope that this helps...

--Eric

__________________________________________________________________
     ________   ________   __   ________
    /\_______\ /\_______\ /\_\ /\_______\ J. Eric Bracken, Ph.D.
   / / ______// / ____  // / // / ______/ Ansoft Corporation
  / / /__\   / / /__\/ // / // / /        Four Station Square, Suite 660
 / / ____/  / / ___  _// / // / /___      Pittsburgh, PA 15219-1119
/ / /____\ / / / \/ / / / // / /____\     (412) 261-3200 FAX (412) 471-9427
\/_______/ \/_/  \/_/ \/_/ \/_______/     [email-masked]

 http://www.ece.cmu.edu/afs/ece/usr/bracken/.home-page.html
__________________________________________________________________