Subject: Re: BIRD 42.3

From: [email-masked] ( Bob Ross)
Date: Thu, 2 Oct 1997 17:51:31 -0700 (PDT)

DC:

I have been considering your response for quite a while.
Here are some of my comments:

(1)  You have provided an interesting demonstration
case where a two-waveform based IBIS model may be needed.

If you terminate the load to Vcc, then there will be
no difference in theory.  However, if you terminate the
output to some other voltage, you will see a difference.

(2)  It is also interesting that you pose the problem
in terms of conductance variations (which could
be implied by the IBIS architecture.)  It could
have been presented in terms of resistance
variations.  However, there would be an implied
difference.  Pulldown one, for example goes
linearly from 0 to 20 mS conductance.  If it
were expressed as resistance, it would go
non-linearly from infinite to 100 ohms to 50 ohms
resistance.

(3)  I understand that there are other real world
effects that can enter into the bounce analysis
that may not show up in the IBIS model processing.
I would still think that a delta current could
still be used for some of these effects that
are caused just by the device switching itself.

Bob Ross
Inteconnectix

Date: Fri, 05 Sep 1997 12:23:45 -0700
From: "D. C. Sessions" <[email-masked]>
Organization: VLSI Technology Inc.

To: IBIS Mailing list <[email-masked]>
Subject: BIRD 42.3

As long ago promised, here's a talking case for BIRD42.3
For simplicity, I've restricted the case to a very simple
falling-edge behavioral model.  The driver in question
is a 50-ohm switched resistor, with the following
time/conductance tables.  The pulldown driver is common,
but there are two different pullup responses:  All
listed conductances are piecewise linear.

  Time  |  Pulldown   |	 Pullup #1  |  Pullup #2  |
        | Conductance |	Conductance | Conductance |
--------+-------------+-------------+-------------+
   0 ps |     0 mS    |	   20 mS    |    20 mS    |
 500 ps |     0 mS    |	   20 mS    |    20 mS    |
1000 ps |     0 mS    |	   10 mS    |    20 mS    |
1500 ps |     0 mS    |	    0 mS    |     0 mS    |
2000 ps |    10 mS    |	    0 mS    |     0 mS    |
2500 ps |    20 mS    |	    0 mS    |     0 mS    |
3000 ps |    20 mS    |	    0 mS    |     0 mS    |

As is typical for real-world drivers, these are
break-before-make.

*IF* the load had time to settle completely to zero
current before the next edge, there would be no
difference between them; however, in real high-speed
switching even unterminated lines take too long to
settle and thus the pullup is still sourcing current
when this schedule starts. Obviously, a terminated
line is even worse; either way the turnoff of the
pullup has important consequences.

IMNSHO, this effect is far more important than the
(extremely rare) case of major crowbar current,
and any solution to this will necessarily also take
care of those few instances where crowbar current
is actually significant.

-- 
D. C. Sessions
[email-masked]

---

From: "D. C. Sessions" <[email-masked]>
Date: Fri, 03 Oct 1997 13:14:13 -0700

> non-linearly from infinite to 100 ohms to 50 ohms

In general I dislike dividing by zero; I'd much rather
deal with tens of siemens at one end of the scale than
(fictitious) millions of ohms at the other.  Also, it
turns out to be a more-nearly-realistic time-domain
process with the output device ramping up its conductivity
as its controls change state.  ("Hello, students, can
you say 'transconductance'?"  Sorry -- Friday.)

> are caused just by the device switching itself.

I've been dealing with conductivity modulation in output
devices for more than a year and don't see a clean solution
short of full SPICE simulation.  Life just isn't fair
sometimes.  Until someone smarter than me comes up with a
solution, we'll have to deal with the sort-of-linear
model that's implied by IBIS.  It's really not all that bad
in principle but there are all sorts of uglies hiding in the
details.  If we're going to get serious about doing SSO
analysis in an IBIS context the biggest obstacle isn't
crowbar current (sorry; cheap shot) it's the lack of useful
power-distribution information.  Supply connections are
extremely local, so it's not helpful to know the total
number of power and ground contacts on a part -- you have to
know which ones feed which pins and their relationship to
other supplies less near.  Once we have *that* we can make
a pretty good guess about the rail potential changes and IBIS
v/i curves do a fair job from there.