Subject: connector models

From: John V Fitzpatrick <[email-masked]>
Date: Fri, 12 Dec 1997 09:28:44 +0100

Hello,

Maybe someone could help me clear up a point? 
I've not been following recent IBIS activity 
as closely as I should...

I'm preparing an internal presentation on IBIS, and am
wondering what to say on the topic of connectors and cables.

Are the following statements reasonably truthful? 

   - Many attempts have been made to adapt IBIS to 
     the creation of connector and cable models. No
     agreed synthax has been found, due mainly to the
     complex nature of coupling. 
   - Limited connector and cable models are possible with 
     IBIS 3.0, using the expanded package model and the new
     series element.
   - There is no medium-term prospect of a better IBIS synthax
   - Most simulator companies have developed their own
     connector model synthax.

Comments?
John

-- 
John Fitzpatrick   <[email-masked]>    
Alcatel Telecom, 4 rue de Broglie, 22304 Lannion, France
Tel: +33(0)2.96.04.79.33  Fax: +33(0)2.96.04.85.09

---

From: Stephen Peters <[email-masked]>
Date: Fri, 12 Dec 1997 08:24:07 -0800

>    - Most simulator companies have developed their own

Yes, I think that is a very accurate statement of the situation.

                 Regards,
                 Stephen Peters
                 Intel Corp.

---

From: Kellee Crisafulli <[email-masked]>
Date: Fri, 12 Dec 1997 11:08:50 -0800

Hi John,

>     complex nature of coupling. 
The problem is just the lack of energy. 
We were very close to agreement at last years
Design Super Con.  The major problem I saw is that the participants
from the connector companies have not provide enough energy to
get resolution.  If one or more connector companies put in even a
small fraction of the energy that an Intel or National Semi puts into
IBIS this would have been completed long ago.

>     IBIS 3.0, using the expanded package model and the new
yes

>   - There is no medium-term prospect of a better IBIS synthax
I would agree there is no short term prospect.  Medium term is
always possible just needs energy from a few good people.
Long term is highly probable

>   - Most simulator companies have developed their own
Or they use one of the formats developed by a connector company.  However
there is alot to be desired in any format I am currently aware of.  This is
one thing that has made it so difficult to accomplish an IBIS standard for connector
modeling.  It is easy to agreement on a simple standard for connector models.  It was
difficult to get acceptance of that being good enough for a first pass.  So rather than
go forward with something basic we got nothing!

Summary:
We let those that must have everything or some special interest prevent the creation
of simple starting point.  This could have been overcome with a small push from
one or two people after last years Design Super Con.  Anyone with some energy to
provide could make the difference on this one.  It will take a few months to revive it
though.

-------------------------------------------------------------------------
Have a great day...
Kellee Crisafulli at HyperLynx
[email-masked]	http://www.hyperlynx.com
-------------------------------------------------------------------------

---

From: Fred Balistreri <[email-masked]>
Date: Fri, 12 Dec 1997 10:18:57 -0800

> Yes, I think that is a very accurate statement of the situation.
Its even a bit worse than that. Connector makers typically model the
electrical characteristics with some sort of field solver. The output
of the field solver can be in various formats. The most common is 
Spice syntax. However it may be S parameters if a full wave solution is
used. Its clear that those companys will have to be accessed and
convienced to put out the models in IBIS format......once we can agree
to some standard. We are currently still working on semiconductor
vendors. Based on that experience I don't think its going to be an
easy job. I do have faith in Bob Ross and crew though.

Best Regards,

-- 
Fred Balistreri
[email-masked]

http://www.apsimtech.com

---

From: John V Fitzpatrick <[email-masked]>
Date: Mon, 15 Dec 1997 14:35:37 +0100

All,
 
Thanks to everyone who replied to my recent message. I was hoping
against hope that my summary was too pessimistic, but it
wasn't.

I attended the Design SuperCon, and remember the heated debates
on matrix formats, definition of the where ground is, etc.
There seemed to be little shortage of energy that day!

I've been thinking a bit about how I characterise connectors for 
SI simulation. 
Basically, I just do a differential TDR measurement between two
connector pins. This gives me impedance and coupling, plus
lots of hints as to where the discontinuities are.
Then I go build a Spice model of the connector 
which gives me the same TDR result in simulation. The detail
of the model depends on the application.
 
IBIS basic models are measurement based. So I could easily 
imagine a basic connector model containing common mode and
differential TDR curves between pairs of points. Because connectors
have a lot of symmetry,2-4 sets of curves should be enough.

[Connector]
InputPinA  InputPinB  OutputPinA  OutputPinB Model  

[Model]
Model_type Connector

[Differential TDR]
Time   Vtyp   Vmax  Vmin

[Common Mode TDR]
Time   Vtyp   Vmax  Vmin

Then it would be up to the simulator to create a circuit model based 
on the TDR measurements, but that's only software :-)
 
Bonnes fetes à tous!
(Yes, the French can be politically correct too...)

John

> Summary:
> We let those that must have everything or some special 
> interest prevent the creation of simple starting point.  
> This could have been overcome with a small push from
> one or two people after last years Design Super Con.  
> Anyone with some energy to provide could make the difference 
> on this one.  It will take a few months to revive it
> though.

---

From: "Dr. Edward P. Sayre" <[email-masked]>
Date: Mon, 15 Dec 1997 13:41:21 -0500

John & others:

Do you do your measurements with connector mounted on a circuit card with
ground planes or is the connect  probed at the connection points with 50
ohm probing?  Using your differential measurement, how do you account for
signal/ground positions or ratios?

I favor mounting connectors on circuit cards to include the mounting and
footprint effects. I do not favor Maxwell matrices in IBIS unless they can
be measured and characterized.  Many Maxwell matrices include as many as
30+ crossections with no real justification on circuit element grounds for
the large number.  They often do not account for losses very well either.

Aside from that, Maxwell matrices are not theoretically what one measures
in a coupled N-port circuit measurement. 

Ed Sayre 

+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~+
|       NORTH EAST SYSTEMS ASSOCIATES, INC.       |
|      -------------------------------------      |
|     "High Performance Engineering & Design"     |
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~+
| Dr. Ed Sayre            e-mail: [email-masked] |
| NESA, Inc.              http://www.nesa.com/    |
| 636 Great Road          Tel +1.508.897-8787     |
| Stow, MA 01775 USA      Fax +1.508.897-5359     |
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~+

---

From: "Dr. Edward P. Sayre" <[email-masked]>
Date: Mon, 15 Dec 1997 13:41:21 -0500

John & others:

Ed Sayre