Subject: IBIS_CHK BUG8

From: [email-masked] ( Bob Ross)
Date: Thu, 6 Feb 97 16:21 PST

******************************************************************************
********************* IBIS GOLDEN PARSER BUG REPORT FORM *********************
******************************************************************************

INSTRUCTIONS

To report a bug in the IBIS golden parser.  Please fill out the top part
of the following form and send the complete form to [email-masked].

A list of reported bugs will be maintained on vhdl.org.

******************************************************************************

PARSER VERSION NUMBER: IBIS_CHK V2.1.11, and IBIS_CHK V1.1.a

PLATFORM (SPARC, HP700, PC, etc.):  SUN

OS AND VERSION:  SunOS 4.1.4

REPORTED BY:  Bob Ross, Interconnectix

DATE:  February 6, 1997

DESCRIPTION OF BUG:  Reserved keywords used as pin numbers generate errors

(This bug was discovered by Arthur Wong of IDT and reported December 5, 1996.)

| When pin "number" takes on the name of any of the reserved keywords
| (gnd, power, nc, na), an error is reported.

INSERT IBIS FILE DEMONSTRATING THE BUG:

|***************************************************************
|
[IBIS Ver]        2.1
| [IBIS Ver]        1.1
[File Name]       prob8.ibs
[File Rev]        0.1
[Date]            January 22, 1997
[Source]          Bob Ross, Interconnectix
[Disclaimer]      Provided for modeling purposes only.
                  Results are not guaranteed.
|
|***************************************************************
|
[Component]      TEST
[Manufacturer]   Test File
[Package]
| variable      typ             min             max
R_pkg           0.0m            NA              NA
L_pkg           0.0nH           NA              NA
C_pkg           0.0pF           NA              NA
|
|***************************************************************
|
[Pin]           signal_name     model_name      R_pin   L_pin   C_pin
nc              One_Pin         NC
gnd             One_Pin         GND
na              One_Pin         NC
power           One_Pin         POWER
|
[End]

******************************************************************************
******************** BELOW FOR ADMINISTRATION AND TRACKING *******************
******************************************************************************

BUG NUMBER: 8

SEVERITY: [FATAL, SEVERE, MODERATE, ANNOYING, ENHANCEMENT]   ANNOYING

PRIORITY: [HIGH, MEDIUM, LOW]                                LOW

STATUS: [OPEN, CLOSED, WILL NOT FIX, NOT A BUG]              OPEN

FIXED VERSION:  

FIXED DATE:

NOTES ON BUG FIX:

******************************************************************************
******************************************************************************

---

From: Kellee Crisafulli <[email-masked]>
Date: Fri, 07 Feb 1997 10:40:35 -0800

Hi all,

  It is not obvious that to me that this is really a bug.  It seems that
this user has the usage of
Pin and signal_name reversed.  Please consider removing this from the bug
list.
"pin" should be 1,2,3,4  or AA1, BC1   etc.  There really should never be a
conflict with the
reserved words.

---

From: [email-masked] ( Bob Ross)
Date: Wed, 12 Feb 97 15:27 PST

Kelly:

What you proposed is the realistic situation.  Technically I believe
it is a bug, but one can argue from some language in the specification
that this is not a bug.  

In any case this is on the agenda for Friday's meeting.  I propose this
be documented rather than fixed.

Best Regards,
Bob Ross
Interconnectix

> Date: Fri, 07 Feb 1997 10:40:35 -0800
> To: [email-masked]
> From: Kellee Crisafulli <[email-masked]>
> Subject: Re: IBIS_CHK BUG8