Subject: Pin numbering for BGA packages.

From: "Eitan Medina" <[email-masked]>
Date: Sun, 20 Jul 1997 16:07:04 +0200

Hi,

I have a device packaged in BGA package.
In these packages the pins are not numbered from 1 to 208 (or whatever),
but in Ball# (A1,A2,...C1,C2,C3...).

IBIS ver 2.1 does not say anything on this.

Is it legal to place Ball# instead of pin# ?

Thanks,

Eitan Medina
Email: [email-masked]
Galileo Technology Ltd.
15 Geron st. 
P.O.Box 2786
Yehud 56217
ISRAEL
Tel:   +972-3-6320220
Fax:   +972-3-6320221 
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
* check out our new web site:   http://www.GalileoT.com *
*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*

---

From: [email-masked] (Dan Aleksandrowicz)
Date: Mon, 23 Dec 1996 08:03:34 -0500

Hi Eitan.

It is legal to number pins using BGA numbering like A1, A2, A3 ... AB12.

Good luck.

 		Dan Aleksandrowicz
 		Engineering Solutions
 		KAW/USA
 		39 Simon Street
 		Nashua, NH 03060
 		http://www.kaw.com

---

From: [email-masked] (Syed Huq)
Date: Mon, 21 Jul 97 08:54:35 PDT

Eitan,

The IBIS standard states that the [Pin] field can have 5 characters
Max. So you can either use numbers or letters or combination of both
not to exceed 5 characters.

Regards,
Syed
National Semiconductor Corp.

> From [email-masked] Sun Jul 20 08:37:03 1997
> Comments: Authenticated sender is <eitan@galileo21>
> From: "Eitan Medina" <[email-masked]>
> Organization: Galileo Technology Ltd.
> To: [email-masked]
> Date: Sun, 20 Jul 1997 16:07:04 +0200
> Content-Type> : > text/plain> ; > charset=US-ASCII> 
> Content-Transfer-Encoding: 7BIT
> Subject: Pin numbering for BGA packages.
> X-Mailer: Pegasus Mail for Windows (v2.33)
> 
> Hi,
>

---

From: Luke Chang <[email-masked]>
Date: Mon, 21 Jul 1997 12:16:56 -0400 (EDT)

Hi Syed,

Can a pin name start with any character, such as _, !, @, #, $, 5, 6, *, and &,
or does it have to start with a letter (a-z, A-Z)?

Luke Chang
Fujitsu Nexion, Inc.
Acton, MA

----- Begin Included Message -----

---

From: [email-masked] (Syed Huq)
Date: Mon, 21 Jul 97 08:54:35 PDT

Eitan,

Regards,
Syed

----- End Included Message -----

---

From: [email-masked] (Syed Huq)
Date: Mon, 21 Jul 97 09:25:22 PDT

Luke,

Yes:
I have tested the following on the ibischk2 parser and they will pass. Meaning,
you can have characters like you mentioned as the first char in the pin
field. THere is no restriction.

REgards,
Syed

[Pin]   signal_name       model_name      R_pin   L_pin    C_pin      
|
!1       RINA-            DS90LV032TM_RIN    50.0m   2.07n    0.429p
@2       RINA+            DS90LV032TM_RIN    50.0m   1.49n    0.306p
3A       ROUTA            DS90LV032TM_ROUT   50.0m   0.95n    0.146p
*4       EN               DS90LV032TM_EN     50.0m   0.95n    0.152p
_5       ROUTC            DS90LV032TM_ROUT   50.0m   0.95n    0.152p
6A       RINC+            DS90LV032TM_RIN    50.0m   0.95n    0.146p
7       RINC-            DS90LV032TM_RIN    50.0m   1.49n    0.306p
8       GND              GND                50.0m   2.07n    0.429p
9   

> From [email-masked] Mon Jul 21 09:18:14 1997
> Date: Mon, 21 Jul 1997 12:16:56 -0400 (EDT)
> From: Luke Chang <[email-masked]>
> To: [email-masked]
> Subject: Re: Pin numbering for BGA packages.
> Cc: [email-masked]
> 
> Hi Syed,
> 
> >From [email-masked] Mon Jul 21 12:12:31 1997
> Date: Mon, 21 Jul 97 08:54:35 PDT
> From: [email-masked] (Syed Huq)
> To: [email-masked], [email-masked]
> Subject: Re: Pin numbering for BGA packages.
> Content-Length: 1293
> 
> Eitan,
>

---

From: Kellee Crisafulli <[email-masked]>
Date: Mon, 21 Jul 1997 11:57:16 -0700

Hi Luke,
>or does it have to start with a letter (a-z, A-Z)?

Pin names can start with numbers and A-Z.  Using other characters is
likely to be problematic given the number of IBIS translators out there.
I would recommend against it.

-------------------------------------------------------------------------
Have a great day...
Kellee Crisafulli at HyperLynx
[email-masked]	http://www.hyperlynx.com
-------------------------------------------------------------------------