Subject: Re: examples needed for IBIS V3.1

From: Joe Cahill <[email-masked]>
Date: Fri, 6 Jun 1997 10:50:05 -0400

Either examples or the cookbook are a very fine idea. I have been lurking here
for years, building models (not IBIS) and timing our systems for much longer,
and I am not easily intimidated. But I know that my first IBIS model will be a
very difficult task, and probably quite sloppy if I tackle it just with the
knowledge I can gain from the specification.

I have been awaiting the cookbook before I attempt my first 'trial' or
'experimental' models. Money for tools is very tight here, money for
engineering time is even tighter. Getting over the steep learning curve quickly
would allow us to consider much more intelligently using IBIS models (and
IBIS-based tools) as a base for our system timing tasks.

Joe

---

From: Stephen Peters <[email-masked]>
Date: Fri, 06 Jun 1997 08:59:52 -0700

Hello All:

    I've been reading the mail talking about adding examples to the 
spec and/or the cookbook.  It's a very good idea, especially in
regards to the cookbook.  Do you, the dedicated users of IBIS, have
some specific examples in mind?  Also, are there some specific areas of the
spec that needs explanation or was particularly difficult to understand?
I am in the process of updateing the cookbook for presentation at the
IBIS face to face at DAC next week and your suggestions for
cookbook improvement would be helpfull.

               Thanks,
               Stephen Peters
               Intel Corp.

---

From: Will Hobbs <[email-masked]>
Date: Fri, 06 Jun 97 10:22:00 PDT

Text item: 

Folks,

The cookbook for V2.1 is imminent. Stephen Peters of Intel, who is responsible 
for the majority of the V1.1 cookbook, has made good progress on the new one. 
He is hoping to have it largely done and ready for review prior to the IBIS 
Summit at DAC next week. My preference would be to keep the examples out of the 
spec, but I could be swayed.

Regards,

Will Hobbs
Intel Corp.

Joe

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Date: Fri, 6 Jun 1997 10:50:05 -0400
Subject: Re: examples needed for IBIS V3.1
Cc: <[email-masked]>
To: <[email-masked]>
From: Joe Cahill <[email-masked]>

          id AA08004; Fri, 6 Jun 1997 14:53:21 GMT
Received: from lms02.us1.ibm.com (lms02.ny.us.ibm.com [198.133.29.70]) by server
.vhdl.org (8.8.5/8.8.3) with SMTP id HAA18785 for <[email-masked]>; Fri, 6 Jun 19
97 07:48:36 -0700 (PDT)
Received: from server.vhdl.org (server.vhdl.org [198.31.14.3])
          by mailbag.jf.intel.com (8.8.5/8.8.4) with ESMTP
       id KAA06044; Fri, 6 Jun 1997 10:09:14 -0700 (PDT)
Received: from mailbag.jf.intel.com (mailbag.jf.intel.com [134.134.248.4]) by re
lay.jf.intel.com (8.7.6/8.7.3) with ESMTP id KAA19682; Fri, 6 Jun 1997 10:06:54
-0700 (PDT)
Return-Path: [email-masked]

---

From: [email-masked] (Syed Huq)
Date: Fri, 6 Jun 97 10:39:04 PDT

Hi,

One helpful thing would be to put a model example that has 
data of almost all the model types and with all the optional
parameters that IBIS supports. This may not be a 'true' 
device but would serve as a 'example' only. Model types 
meaning, open_drain, ECL, PECL, CMOS etc etc and there is
a LOT of optional parameters ....

Regards,
Syed
National Semiconductor Corp.

> From [email-masked] Fri Jun  6 10:31:04 1997
> To: [email-masked], [email-masked]
> Date: Fri, 06 Jun 1997 08:59:52 -0700
> From: Stephen Peters <[email-masked]>
> 
> 
> Hello All:
>

---

From: Kellee Crisafulli <[email-masked]>
Date: Fri, 06 Jun 1997 13:50:41 -0700

Hi IBISians,

  It seems we have found considerable common ground on this issue.  The
next question is who will contribute to effort.  Syed mentioned simple models
of many different technologies would be useful.   

e.g.
   Intel -> GTL model
   Xilinx -> basic CMOS model
   Syed -> RS232 model
   TI -> ABT model
    Bob Ross -> switch model

Any takers?
Step up to the plate and commit now while the ball is in motion.
One model from each company will be a lot of models.

-------------------------------------------------------------------------
Have a great day...
Kellee Crisafulli at HyperLynx Inc.
[email-masked]	http://www.hyperlynx.com
-------------------------------------------------------------------------

---

From: [email-masked] (Syed Huq)
Date: Fri, 6 Jun 97 15:32:41 PDT

Hi,

Infact, I am right now working on doing my first RS-232 IBIS
model which will be TYP model based on measurements. You should
add a 'Differential' model to the list and I can pass one of
National's too.

Regards,
Syed.

> From [email-masked] Fri Jun  6 15:18:14 1997
> X-Sender: [email-masked]
> X-Mailer: Windows Eudora Pro Version 3.0 (32)
> Date: Fri, 06 Jun 1997 13:50:41 -0700
> To: [email-masked]
> From: Kellee Crisafulli <[email-masked]>
> Content-Type> : > text/plain> ; > charset="us-ascii"> 
> 
> Hi IBISians,
>

---

From: Andy Ingraham <[email-masked]>
Date: Sat, 7 Jun 97 16:59:53 EDT

D. C. Sessions wrote:

> Just to be contrary, I'd think that it is better to have
> several VERY simple examples rather than one complex one
> where the (terrified) user has a hard time finding what 
> she needs.

I whole-heartedly agree!

We already have example fragments with all the keywords and
many of the optional parameters, right in the IBIS spec
document itself.  What we need are plain and simple examples
with only what's needed to get started.  All the extra
keywords and parameters come with experience and fine-tuning.

There is/was an example file with the version 1.0 spec. 
In fact I think it's still there.  Try this URL:
ftp://ftp.vhdl.org/pub/ibis/ver1.0/n74f244n.ibs

Some of the models in the ibis/models/ directory also might
be worth using.  Unfortunately, that directory seems to have
fallen into disrepair these days....

Regards,
Andy Ingraham

---

From: [email-masked] ( Bob Ross)
Date: Mon, 9 Jun 1997 08:44:46 -0700 (PDT)

Kellee:

I also support doing this.  We can discuss this at the next meeting.
I would like to see a set of samples that we have reviewed stored
under a "samples" subdirectory.

Bob Ross
Interconnectix