Subject: Question on Ramp

From: Unger Bernhard <[email-masked]>
Date: Wed, 18 Jun 1997 19:38:36 +-200

Syed,

you wrote s2ibis2 will add 50Ohms pullup to calculate 
dV/dt_f and 50Ohms pulldown to calculate dV/dt_r values.
Looking in the [RAMP] specification of 2.1 IBIS spec. there 
is only a definition for a R_load sub-parameter but not for a
termination voltage. The subparameter is optional if the preferred
50Ohms load is used.
Is it obvious that the ramp values given in an IBIS model are valid
for the following conditions:

dV/dt_f:  R_load pullup to VCC ?

dV/dt_r:  R_load pulldown to GND ?

Regards,

Bernhard

************************************************************************************
#  Dr. Bernhard Unger                                                                                                   
#  Siemens AG                                                                                                                 
#  Dept. ANL A45 AM                                                                                                     
#  Otto-Hahn-Ring 6                 Tel.        +49-89-636-47404                                       
#  D-81730 Munich                  Fax.       +49-89-636-44595                                       
#  Germany                             E-Mail    [email-masked]                                                                                        
************************************************************************************

----------
Von: 	Syed Huq[SMTP:[email-masked]]
Gesendet: 	Dienstag, 17. Juni 1997 17:36
An: 	[email-masked]; [email-masked]
Betreff: 	Re: Question on Ramp

Milan,

s2ibis2 will add 50Ohms pullup and pulldown to calculate 
dV/dt_f and dV/dt_r values. You can try changing these values
to see if your device will switch or not.

...in your .s2i file:

[Rising waveform] 500 0 NA NA NA NA NA NA NA
[Falling waveform] 500 3.3 NA NA NA NA NA NA NA

Try changing the sim time to a larger number too in your .s2i file

[sim time] 10ns

Regards,
Syed
National Semiconductor Corp.

> From [email-masked] Mon Jun 16 17:27:09 1997
> Date: Mon, 16 Jun 1997 15:51:23 -0700 (PDT)
> From: Milan Gandhi <[email-masked]>
> To: [email-masked]
> Subject: Question on Ramp
> X-Sun-Charset: US-ASCII
> 
> Hi,
> 	This is our first experience with IBIS, so this might
> 	be a trivial issue for you experienced folks !!
> 
> 	We are getting Ramp (dV/dt) as 0 in ibis inspite of
> 	providing required Voltage values.
> 	What should we be looking for in order to get
> 	correct Ramp values in Ibis model.
> 	We are using tools from NC university.
> 
> -Thanks, Milan
>

---

From: [email-masked] (Syed Huq)
Date: Wed, 18 Jun 97 12:13:40 PDT

Bernhard,

It may not be obvious from the spec defination of [Ramp] but
under 'NOTES ON DATA DERIVATION METHOD' at the end of the spec,
section 3 talks more in details about the pullup to Vcc and
pulldown to GND for various I/O structures.

Regards,
Syed

> 
> Syed,
> 
> you wrote s2ibis2 will add 50Ohms pullup to calculate=20
> Looking in the [RAMP] specification of 2.1 IBIS spec. there=20

---

From: Andy Ingraham <[email-masked]>
Date: Wed, 18 Jun 97 15:43:07 EDT

Bernhard,

This is yet another one of those IBIS details where the spec
ASSUMES you know what the "preferred" termination voltage is! 
Actually, the answer is in there, but it forces you to go
scavenging through the IBIS spec to find it.  (This is one of
my big complaints about the IBIS spec.)

If you look near the very back of the 2.1 IBIS spec, under the
section "NOTES ON DATA DERIVATION METHOD", you will find this:

| 3) Ramp Rates:
...
|    b. If: The Model_type is one of the following: Output, I/O, or
|           3-state (not open or ECL types);
|           Then: Attach a 50 ohm resistor to GND to derive the rising edge
|                 ramp.  Attach a 50 ohm resistor to POWER to derive the
|                 falling edge ramp.
|
|       If: The Model_type is Output_ECL or I/O_ECL;
|           Then: Attach a 50 ohm resistor to the termination voltage
|                 (Vterm = VCC - 2 V).  Use this load to derive both the
|                 rising and falling edges.
|
|       If: The Model_type is either an Open_sink type or Open_drain type;
|           Then: Attach either a 50 ohm resistor or the vendor-suggested
|                 termination resistance to either POWER or the vendor-
|                 suggested termination voltage.  Use this load to derive both
|                 the rising and falling edges.
|
|       If: The Model_type is an Open_source type;
|           Then: Attach either a 50 ohm resistor or the vendor-suggested
|                 termination resistance to either GND or the vendor-suggested
|                 termination voltage.  Use this load to derive both the rising
|                 and falling edges.

So your assumptions are correct for a standard CMOS/TTL type
output buffer.

This is one of many areas where the IBIS spec desperately needs
fixing.

Regards,
Andy Ingraham