Subject: s2ibis2

From: [email-masked]
Date: Fri, 28 Mar 97 17:18:30 EST

Hi Everyone:   I encountered some difficulties in using 
the latest release of the s2ibis2 Spice to IBIS 
conversion program from NCSU, s2ibis2 Version2 (The 
latest available downloaded from the IBIS web site. I am 
using a DEC Alpha workstation and I had to recompile to 
get the correct executable).  The program went into 
execution, completed all the required .spi jobs and all 
the .out jobs looked ok.  However, when it tried to 
write the .ibs file, it gave me a '9798 floating 
exception' error and quit.  It did not gerenate the .ibs 
file at all (got an empty file).  The 9798 number in not 
a constant, it changes to a new number everytime I rerun 
the program.  There are no other error 
messages and I don't know where to look for the source 
of the error.  I rerun the identical files using the 
older version of s2ibis2 (v0.91BETA) and it went through 
ok.  I would appreciate any comments or suggestions 
anyone may have to help me resolve the problem.    

Thnak you
Jeff Chu
Digital Equipment corp.
77 Reed road
Hudson, MA
01749
(508)568-4197
(508)568-5195 fax

---

From: [email-masked] (Mike Ventham)
Date: Sat, 29 Mar 97 15:34:35 CST

> anyone may have to help me resolve the problem.    
Jeff,
The number in front of the floating exception is a process
number of the process running the IBIS output. Therefore
it will change everytime. The problem is the floating
exception - this is usually caused by the program dividing
a number by zero. The empty file is caused by the file buffer
not being flushed before  the program crashes.

That's the diagnosis, but it is difficult to pin down the
cause without using a debugger. It's sick, I don't know 
precisely why - hey, I should be a medical doctor!

Regards

Mike
________________________________________________________________
| Mike Ventham - Vice-President Engineering,                   |
| Quantic EMC Inc                   Headquarters               |
| Croft House, Chilcompton,         191 Lombard Ave, Winnipeg, |
| Somerset, UK, BA3 4JA             Manitoba, Canada R3B 0X1   |
| Tel: 44 (0)1761 232191            Tel: (204) 942 4000        |
| Fax: 44(0)1761 233549             Fax: (204) 957 1158        |
| Email: [email-masked]    http://www.quantic-emc.com |