Subject: Re: Proposed Golden IBIS Parser checks

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 04 Nov 1998 11:24:53 -0800

Hi group,

At 11:43 AM 11/4/98 -0700, D. C. Sessions wrote:
>Matthew Flora wrote:
>> Proposed enhancements:
>> 2) Generate at least a warning if the Pullup or Pulldown V/I table
indicates
>>    that current is always flowing in one direction.  In other words, the
V/I
>>    table does not have an entry with zero current or, by interpolation, the
>>    current is never zero in the range of the voltages listed.
>>    I think a warning should be generated even if the current would be zero
>>    when extrapolated to a voltage beyond those listed in the table
because I
>>    believe that V/I tables should be complete and should not force a
simulator
>>    to guess values and, to me, extrapolation beyond the voltages listed
in the
>>    table is a guess.
>If I understand you correctly, you would insist that the tables
>go at least to the zero-current intercept point.  Thus, for an
>1.5v device with a weak pullup to 5.0v you'd have the tables go
>at least to 5v so as to catch the intercept?
Matt asked for a warning.  Not an error.  Just a way to say are you really
sure this is what you wanted.  The warning could even say this condition
may be valid
for some classes of devices.

>> 3) For non-ECL models, shouldn't the zero current voltage for the Typ, Min,
>>    and Max columns in the Pullup or Pulldown V/I tables be the same (say
>>    within a microvolt)?  I suggest that a warning be generated if they are
>>    not.
>Lots of technologies have zero-current intercepts inside of their
>rails.  ECL is only one of them; perhaps you've heard of TTL?
I think Matt is asking that the zero current intercept be the same for
typ,min,max  not that it be 0.

>> 4) Related to a topic recently discussed on the reflector, I suggest
that an
>>    error be generated if a differential pin (a pin referenced in the
>>    [Diff pin] section) is connected to one of the reserved models
(POWER, GND,
>>    or NC).
>This would barf on RS-423
Good point.

---

From: "D. C. Sessions" <[email-masked]>
Date: Wed, 04 Nov 1998 13:00:04 -0700

> typ,min,max  not that it be 0.

Still wouldn't work.  TTL (to pick one) intercepts when the
forward current through the base-collector junction equals
the pulldown current through the collector-emitter path.
This depends on the forward voltage of the base-emitter
junction, the beta of the transistor, and the forward
voltage of the collector-base junction as well as the
predriver current to the transistor base node (also variable).
The first three are dependent on process and temperature, and
the last is also dependent on supply voltage.  IOW, the
open-circuit Vol is going to be all over the place.

-- 
D. C. Sessions
[email-masked]

---

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 04 Nov 1998 14:02:38 -0800

Hi IBIS,

>open-circuit Vol is going to be all over the place.

Excellent point DC!

Any ideas on how to do this that would work better are appreciated.
Did I mention it needs to be reasonably simply so it's not too hard
to write the test.  This is another common problem we see it would be nice
to smash with the golden parser.

---------------------------------------------------------
Have a great day....
Kellee Crisafulli at HyperLynx
SI,EMC,X-talk and IBIS tools for the Windows platform
E-mail: <mailto:[email-masked]>
web:    <http://www.hyperlynx.com>
---------------------------------------------------------