Subject: sweeping range...

From: gerald_truong <[email-masked]>
Date: Tue, 30 Nov 1999 16:46:37 -0700

Hello all,

    I am trying to change the sweeping range for certain curves in
s2ibis2 to avoid non-convergence problems but I am finding myself
unsuccessful at it. Does someone know how to modify the sweeping range
for s2ibis2?

Thank you in advance.

Gerald Truong
Motorola Computer Group
(602)438-3525

---

From: Syed Huq <[email-masked]>
Date: Tue, 30 Nov 1999 16:28:57 -0800 (PST)

Hi,

At the end of your .spi file, you may see some statements like below:

VOUTS2I out 0 DC 0
VCCS2I vdd 0 DC 3
VGNDS2I gnd 0 DC 0
VINS2I in 0 DC 3.3
.TEMP 27
.OPTIONS INGOLD=2
.DC VOUTS2I -3 6 0.1       <---- Edit this line
.PRINT DC I(VOUTS2I)
.END

The above .DC statement is sweeping from -3V to +6V in 0.1V increment.
You should be editing the .spi file that *failed* the DC convergence.

Just to make sure it works with the new sweep range you define, you could
run spice standalone on this spi file. Something like this:

% hspice putout.spi > mynewfile.out

Regards,
Syed
Cisco Systems, Inc