Subject: Re: SPICE-To-IBIS Version 3 (S2IBIS3) Proposal Now Available For Review

From: Kim Helliwell <[email-masked]>
Date: Thu, 02 Dec 1999 16:34:51 -0800

[email-masked] wrote:
> 
> Hello everyone!
> 
> I would like to announce the SPICE-To-IBIS Version 3 (S2IBIS3) Project
> Proposal to everyone who was not present at the last IBIS Open Forum
> Meeting held last Friday, November 26, 1999.  The proposal can be found on
> the IBIS Home Page:
>   http://www.eia.org/eig/ibis/ibis.htm
> or directly at:
>   http://www.eda.org/pub/ibis/s2ibis3/
> 
> Please review the "s2ibis3_PR_1_00.txt" document; if you have any comments,
> please post them on this reflector to help stimulate discussions.
> 
> Again, let me thank everyone who participated on the subcommittee; your
> hard work is much appreciated!  The members of this subcommittee are:
>     Michael Cohen (Chairperson)     IBM Personal Systems Group
>     Syed Huq                        Cisco Systems
>     Christian Klein (Secretary)     Fairchild Semiconductors
>     Mike LaBonte                    Cadence Design Systems
>     Arpad Muranyi                   Intel Corporation
>     Bob Ross                        Mentor Graphics
>     Mohamed Nasef                   Mentor Graphics
>     Jerry Hayes                     IBM
>     Sherif Hammad                   Mentor Graphics
> 
> Regards,
> Michael Cohen
> Chairperson, SPICE To IBIS Subcommittee

Regarding paragraph 3.6.2 concerning incremental changes:

It's not clear whether the iterate feature is the default, or whether
it's even controllable by the user.  At least, my (admittedly small) use
of S2IBIS2 so far suggests that the only way to override the iterate
feature is to rm all the generated files.

I'd like (if it's not already part of the spec, and it doesn't appear to
be) a simple command-line flag or some other simple mechanism to select
iterate or not, as the user chooses.  There really are some times when
incremental changes are *NOT* wanted, and I don't think I should have
to rm the files in order to force a full regeneration of a model.
-- 
Kim Helliwell
Senior CAE Engineer
Acuson Corporation
Phone: 650 694 5030  FAX: 650 943 7260

---

From: Syed Huq <[email-masked]>
Date: Fri, 3 Dec 1999 10:11:02 -0800 (PST)

Kim,

In the present s2ibis2, [Iterate] is optional. If it is not added in
the header file (.s2i), then it is not used. This is what the documentation
says:(/doc/s2ibis2.txt)

 [Iterate]

        Optional.
        Default: none.
        
You could also use the [Cleanup] keyword and let s2ibis2 get rid of all
spi, out , st0, msg files after successful simulation. 
See below:(/doc/s2ibis2.txt)

 [Cleanup]

        Optional.
        Default: none.

        When this command is specified, s2ibis2 will delete all of the
        spice input, output and message files as it proceeds. This is
        good to use when you think the IBIS file is done and you want to
        clean up the working directory.

Regards,
Syed
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Syed B. Huq           [email-masked]  ~
SI Engineer/Technical Leader          ~
Cisco Systems, Inc.  ELB Group        ~
Ph:(408)525-3399   Fax:(408)526-5504  ~
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~