Subject: Re: Using Ibis models in hspice

From: [email-masked] (Bob Ross)
Date: Tue, 19 Jan 99 18:55:25 PST

To Steve Johnson, Kellee, and Steve Monroe and All:

Spice implementations of IBIS is a topic of general interest.  It has been
discussed at meetings and briefly on the IBIS reflectors.  Also, several
comparison studies with Spice simulations have been discussed at
meetings.

Vendor specific issues such as HSPICE offerings should be discussed
on the Signal Integrity reflector (where the message was also sent)
or with the vendor directly.

The question related directly to HSPICE, which is one vendor's
commercial implementation of Spice.  As a general policy, the
IBIS reflectors avoid vendor-specific discussions because of
EIA guidelines.

However, I believe that implementations of IBIS in Spice using
behavioral constructs that are commonly available in several Spices
is an appropriate topic for [email-masked] reflector.  The
formats for tables seem to be unique for different commercial
versions of Spice, so the discussion may have to use one vendor's
Spice for illustration.  However, since the tables can be
translated or made equivalent in other versions of Spice,
I feel the substance of the discussion is sufficiently generic.

I refer to the following documents which are archived for further
reference on this issue of behavioral implementation of IBIS
in Spice.

  http://www.eda.org/pub/ibis/summits/feb98/unger.zip

and the IBIS email reflector archives of October 1997 which
shows a prototype implementation.

  http://www.eda.org/pub/ibis/email/email97/email.oct97

Best Regards,
Bob Ross
Mentor Graphics
Chair., EIA IBIS Open Forum

> Date: Tue, 19 Jan 1999 17:26:11 -0700
> From: "[email-masked]" <[email-masked]>
> To: [email-masked]
> Subject: Re: Using Ibis models in hspice

> Kellee Crisafulli <[email-masked]> wrote:
> >Hi Steve,
> >
> >  This is a question for the simulator company you
> >are using and should not appear on this IBIS reflector.
> >Please redirect you question directly to your simulator
> >company.
> >

>     I disagree completely.  I have been looking forward
>     to someone responding to this question all day.

>     I think that this reflector needs to go beyond what
>     the latest BIRDS are, or whats going on with a trade
>     show.  No invective intended toward BIRDS or trade
>     shows.

>     This group is supposedly a group of IBIS experts, which
>     likely have expertise as it relates to the question 
>     below.
>     
>     I don't understand how the question posed violates the
>     reflector's purpose.

> >
> >
> At 11:21 AM 1/19/99 -0800, steve johnson wrote:
> >To the Ibis experts: I saw a reply in a signal integrity reflector
> >message that suggests contacting you. Here's my original request.
> >An example would also suffice.
> >
> >
> >To all, 
> >  I'm a new subscriber to this reflector, and I am having only limited
> >success with simulating IBIS models using Hspice. I've found alot of
> >information about going from Hspice to IBIS, but very little when
> >going from IBIS to Hspice. Does anyone have an Hspice file which
> >accepts both pullup and pulldown output voltages and currents, the
> >clamps, pin capacitance, resistance, and inductance? Also, I'd like
> >the output to be able to go to high impedance. Last, is functionality
> >controlled using behavioral statements?
> >Thanks in advance.
> >Regards, Steve Johnson

> -- 
> web: http://ee.ecae/pages/SM/docs/sm_home.html   
> vox: 1.303.673.4938
> fax: 1.303.673.2784
> pgr: 1.800.217.9371

---

From: "Mellitz, Richard" <[email-masked]>
Date: Wed, 20 Jan 1999 07:34:07 -0800

I tend to agree with Steve. I realize that the some vendors consider how use
IBIS IP. It would be real nice if some one could present  issues concerning
implementations so the user community at large could make tradeoffs between
simulator companies.
Recently I've worked on doing an IBIS implementation and as neophyte to this
have uncovered a whole bunch of issues that I know simulator companies may
have solved in different ways. Each method will have it's limitations,
assumptions, and applicability. I think the IBIS summit meetings would be a
good place to air this. 

... Rich

		-----Original Message-----
		From:	[email-masked]
[mailto:[email-masked]]
		Sent:	Tuesday, January 19, 1999 7:26 PM
		To:	[email-masked]
		Subject:	Re: Using Ibis models in hspice

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Wed, 20 Jan 1999 08:14:00 -0800

To answer his original question, yes, it is possible to do IBIS modeling in 
HSPICE.  (I have done this for several years now).  You can build such a
thing 
with the already existing controlled sources, or you can wait for the
release of
H98.4 in which I understand there will be IBIS support.

Arpad
============================================================================
===