Subject: ibis VT curves

From: Simon Schaeffer <[email-masked]>
Date: Thu, 16 Nov 2000 14:12:44 +0100

Hi,

I'm working on ibis models and I met the same problem as Betty Luk, it's
to say that in playing around with my IBIS model (changing the ramp data
manually), I didn't see any changes with Sigxplorer (Specctraquest
signal explorer expert). However, in making the same changes in the ibis
model used in pspice I saw differences.
I have done this with an ibis model with and without the VT curves.
I have used "ibis2spice" from Intusoft but this program
doesn't convert the VT curves, it just uses the [Ramp] parameters.
So, I am trying to build a new ibis2spice program using the VT curves.

My questions are:

1) Why doesn't the [Ramp] modifications influence the results (Betty
Luk's question)

2) Why use the VT curves instead of the [Ramp] parameters?  Is it "only"
to get a more accurate curve?

3) I am puzzled by the apparent contradiction that might arise if both
the
VT and VI curves are available.  For example, a VT curve has been
specified with the following load:

out -----/\/\/\/\/-----|
            50         |  
                  + ___|___ 1.25V
                      ---
                       |
                       |
                       |
                      GND

Going from low to high, the VT curve switches from 400mV to 2V.

How can I use this information for other loads?
For example:

-  50 Ohm load only 
(i.e. the dc offset has been removed.  My simulated output will now want
to be something defined by the VI curve.  How do I sensibly use the VT
curve in this case?)

-  100 Ohm load only 

4) Do I have to take into account the Rfixture and Vfixture values used
while specifying the VT curves?

Thanks for your feedback
Simon Schaeffer

---

From: [email-masked]
Date: Fri, 17 Nov 2000 14:45:48 -0600

For what it's worth,

From experience: I now assume that SpecctraQuest always uses the dT data.  I
had a simulation which gave very strange results.  Turns out, the dT data
was bogus (~0.5 pS); everything else was just fine.  And the dT data is easy
to check if you have VT data.

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592

> -----Original Message-----
> From: Katja Koller [mailto:[email-masked]]
> Sent: Friday, November 17, 2000 7:26 AM
> To: ibis
> Subject: Re: ibis VT curves
> 
> 
> Todd Westerhoff wrote:
> > 
> > Simon,
> > 
> > The answer to your original question, as I understand it:
> > 
> > SPECCTRAQuest (a.k.a SQ) doesn't use the dV/dT data when 
> rise/fall curves
> > are present.  As Betty said, the V-I curves and V-T data 
> are used instead.
> > SQ only uses the dV/dT data when the rise/fall curves are 
> NOT present (i.e.
> > the so-called "linear" ramp model).
> > 
> > Some experimentation yesterday revealed that when V-I 
> curves are present
> > (but NOT V-T), SQ uses the dT information, but NOT the dV 
> data.  That makes
> > sense (the high and low operating points are determined by 
> the output's V-I
> > characteristics and the power supplies).  The dT 
> information is used to
> > define the length of time it takes the output to change state.
> > 
> > There are some interesting implications to this, worthy of note:
> > 
> > If you have an output with a 2V swing that takes 1 nS to 
> switch, you have a
> > ramp rate of 2V/nS.  Theoretically, you could specify that 
> as 2V/1nS, or
> > 1V/0.5nS, or 10V/5nS - all of which would give you the same 
> ramp rate.
> >  BUT - only the 2V/1nS value would give you the switch time 
> you expect,
> > because SQ is only using the dT value.
> 
> As far as I know, the ibis spec says, that the ramp rate has 
> to be from
> 20% to 80%.
> In the case of an output with 2V swing within 2 nS, this has to be:
> 
> dV/dt = 1.2V / 0.6 nS
> 
> Unfortuately, I often get ibismodels where this is not the case. This
> can be
> checked by looking at the crossing of the VI-curves with the
> "50Ohm-load-line" 
> (if the load is 50Ohm).
> 
> Perhaps others have similar experiences.
> 
> Katja
> 
> > 
> > Morals of the story:
> > 
> > 1) Ramp data is not used by SQ when V-T data is present.
> > 2) When using Ramp Data, tell SQ the actual dV and dT 
> values for the whole
> > output transition.
> > 
> > That's the story as I understand it.  If anyone has seen 
> different, please
> > let me know!
> > 
> > Todd.
> > 
> > > -----Original Message-----
> > > From: Simon Schaeffer [mailto:[email-masked]]
> > > Sent: Thursday, November 16, 2000 8:13 AM
> > > To: ibis
> > > Subject: ibis VT curves
> > >
> > >
> > > Hi,
> > >
> -- 
> Katja Koller ICN M TC 6 
> Siemens AG Hofmannstr. 51 81359 Muenchen
> [email-masked]
> Tel: 0049 89 722 45719 Fax: 0049 89 722 44692
>

---

From: [email-masked]
Date: Mon, 27 Nov 2000 08:53:29 -0600

Katja,

Regarding non-standard dV/dt, the suspected cause of not following the IBIS
standard plays into how I handle
the situation. My simulation needs, however, are the major determinant of how I
respond.

I suspect two possible causes of non-standard, i.e. non 20%-80% intervals.

1. Carelessness and/or ignorance of what the standard calls for. My guess is
this is 20% of the cases.

2. Deliberately limiting the range to less than 20%-80% of full swing centered
around the 50% point. This
is because this is usually the most linear portion of the curve. There is a
mistaken belief out there that fast
switching speed is invariably good. Inclusion of the full 20%-80% swing usually
picks up soft corners
(non-linearity) resulting in a slower switching speed.

Since I'm a signal integrity engineer I usually am interested in the slowest
part that can switch in the required time.
Speed kills. Especially with today's die-shrunk sub-micron parts. I've yet to
run into a single instance of a part not
fast enough for its application by the time the logic designer has made their
choice an asked me to look into the SI
issues.

We all know our SI problems increase as circuit and topology becomes more
complex and speed, especially edge
rate, increases. Therefore, when I get a model with a dV/dt reduced from 20%-80%
to something less, I suspect it is
worthless for simulation in the faster, more complex cases. Especially, if I
suspect the range was reduced as part of
making the device more marketable in the eyes of a technically ignorant
supplier. The full 20%-80% range has, thus
far, always made the the simulation look better.

This, and the logic designer's need for an accurate, believable simulation and a
recommendation from me that his
circuit is just fine determines my level of motivation to pressure the supplier
for a corrected model.

Best Regards,

Roy