Subject: RE: ibis VT curves

From: Betty Luk <[email-masked]>
Date: Thu, 16 Nov 2000 09:39:09 -0500

Hi,

With regards to:

1) Actually, with the question I had earlier, i found that after restarting
my computer, I did see the ramp data affect my simulation in HyperLynx, as
expected.  Sorry about the confusion.

3) To my understanding, VI curves describe DC behaviour, and VT curves
describe transient behaviour.

Regards,
Betty Luk

> -----Original Message-----
> From: Simon Schaeffer [mailto:[email-masked]]
> Sent: Thursday, November 16, 2000 8:13 AM
> To: ibis
> Subject: ibis VT curves
> 
> 
> Hi,
> 
> I'm working on ibis models and I met the same problem as 
> Betty Luk, it's
> to say that in playing around with my IBIS model (changing 
> the ramp data
> manually), I didn't see any changes with Sigxplorer (Specctraquest
> signal explorer expert). However, in making the same changes 
> in the ibis
> model used in pspice I saw differences.
> I have done this with an ibis model with and without the VT curves.
> I have used "ibis2spice" from Intusoft but this program
> doesn't convert the VT curves, it just uses the [Ramp] parameters.
> So, I am trying to build a new ibis2spice program using the VT curves.
> 
> My questions are:
> 
> 1) Why doesn't the [Ramp] modifications influence the results (Betty
> Luk's question)
> 
> 2) Why use the VT curves instead of the [Ramp] parameters?  
> Is it "only"
> to get a more accurate curve?
> 
> 3) I am puzzled by the apparent contradiction that might arise if both
> the
> VT and VI curves are available.  For example, a VT curve has been
> specified with the following load:
>                         
> 
> out -----/\/\/\/\/-----|
>             50         |  
>                   + ___|___ 1.25V
>                       ---
>                        |
>                        |
>                        |
>                       GND
> 
> Going from low to high, the VT curve switches from 400mV to 2V.
> 
> How can I use this information for other loads?
> For example:
> 
> -  50 Ohm load only 
> (i.e. the dc offset has been removed.  My simulated output 
> will now want
> to be something defined by the VI curve.  How do I sensibly use the VT
> curve in this case?)
> 
> -  100 Ohm load only 
> 
> 4) Do I have to take into account the Rfixture and Vfixture 
> values used
> while specifying the VT curves?
>   
> 
> 
> Thanks for your feedback
> Simon Schaeffer
>

---

From: Ian Dodd <[email-masked]>
Date: Thu, 16 Nov 2000 10:54:49 -0500

Betty,

The IV and VT curves must provide a consistent description of the dynamic
i.e. transient behavior of an IBIS driver. 

The IV curves describe the starting and ending conditions for transitions
under all possible loading conditions. The VT curves describe the switching
behavior under specific loading conditions. For accurate simulation, it
is required that the VT data start before the start of the transition and
end after the transition has completed. At these times, the voltage and current
into the test fixture should be consistent with the IV data. In fact, the IBIS
golden
parser will validate this condition and report if there is a significant
deviation.

Presently it is left to the simulator vendor to create an algorithm that will
use the 
VT data for the device driving a specified loads and predict the behavior into
the load that is actually in the circuit being simulated. 

For simulation purposes most tool vendors will ignore the IBIS edge rate data if
VT data
has been supplied. It is however important that the IBIS edge rate be reasonably 
accurate, even when VT tables are available, because some tool vendors use the
data
to do some quick evaluations e.g. which nets should be simulated for crosstalk.

I hope this helps

Ian Dodd
[email-masked]

---

From: "Todd Westerhoff" <[email-masked]>
Date: Fri, 17 Nov 2000 07:41:36 -0500

Simon,

The answer to your original question, as I understand it:

SPECCTRAQuest (a.k.a SQ) doesn't use the dV/dT data when rise/fall curves
are present.  As Betty said, the V-I curves and V-T data are used instead.
SQ only uses the dV/dT data when the rise/fall curves are NOT present (i.e.
the so-called "linear" ramp model).

Some experimentation yesterday revealed that when V-I curves are present
(but NOT V-T), SQ uses the dT information, but NOT the dV data.  That makes
sense (the high and low operating points are determined by the output's V-I
characteristics and the power supplies).  The dT information is used to
define the length of time it takes the output to change state.

There are some interesting implications to this, worthy of note:

If you have an output with a 2V swing that takes 1 nS to switch, you have a
ramp rate of 2V/nS.  Theoretically, you could specify that as 2V/1nS, or
1V/0.5nS, or 10V/5nS - all of which would give you the same ramp rate.
 BUT - only the 2V/1nS value would give you the switch time you expect,
because SQ is only using the dT value.

Morals of the story:

1) Ramp data is not used by SQ when V-T data is present.
2) When using Ramp Data, tell SQ the actual dV and dT values for the whole
output transition.

That's the story as I understand it.  If anyone has seen different, please
let me know!

Todd.

---

From: Katja Koller <[email-masked]>
Date: Fri, 17 Nov 2000 14:26:00 +0100

> because SQ is only using the dT value.

As far as I know, the ibis spec says, that the ramp rate has to be from
20% to 80%.
In the case of an output with 2V swing within 2 nS, this has to be:

dV/dt = 1.2V / 0.6 nS

Unfortuately, I often get ibismodels where this is not the case. This
can be
checked by looking at the crossing of the VI-curves with the
"50Ohm-load-line" 
(if the load is 50Ohm).

Perhaps others have similar experiences.

Katja

-- 
Katja Koller ICN M TC 6 
Siemens AG Hofmannstr. 51 81359 Muenchen
[email-masked]
Tel: 0049 89 722 45719 Fax: 0049 89 722 44692

---

From: mjs <[email-masked]>
Date: Fri, 17 Nov 2000 07:55:54 -0600 (CST)

unsubscribe

---

From: "Todd Westerhoff" <[email-masked]>
Date: Fri, 17 Nov 2000 10:11:42 -0500

WOW.

Katja, I owe you one.  And, I amend my earlier statement.

Your point is entirely correct - IBIS specifies the 20-80% range.  And, so
does SPECCTRAQuest, as it turns out.  The dT in the model's ramp declaration
is for the 20-80% transition time, NOT the overall transition as I earlier
stated.

The implications are substantial.  A dT of 1nS means the entire output
transition takes 1.66 nS, NOT 1 nS as I thought.  And, the same rationale
would apply for the dV declaration, although SPECCTRAQuest doesn't seem to
use that information when V-I curves are present.

THANK YOU for correcting me.  We have been using SQ "linear models" to
define target buffer requirements, and now understand what the REAL required
edge rates are.

Thanks again!

Todd.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Katja Koller
Sent: Friday, November 17, 2000 8:26 AM
To: ibis
Subject: Re: ibis VT curves

dV/dt = 1.2V / 0.6 nS

Katja