Subject: RE: help with ibischk3 warnings and min data

From: "Ingraham, Andrew" <[email-masked]>
Date: Tue, 21 Nov 2000 13:12:05 -0500

> For your point 2), I'm not sure what I should be comparing my VT data with
> (ie. which part of the VI data). I think I'm still unclear on what the
> warning message means.
 
It means that the steady-state parts of the V-T data were not consistent
with what they should have been, based on the V-I data.

The endpoints are the first and last values in the V-T table.  For rising
edges, the first point should have the driver at steady-state low.  The last
point ought to be far enough out on the rising edge so that most transient
effects have died out.  This approaches a steady-state high.  The
steady-state low and high values can be calculated from the V-I data, in
conjunction with the load resistance and pull-up or pull-down voltage.  It
is complaining that the values are not as close as they should be.

Andy

---

From: Betty Luk <[email-masked]>
Date: Tue, 21 Nov 2000 14:59:45 -0500

Hi,

Thanks for the clarification.  I'm using s2ibis2 to create my IBIS model.
Does anyone have any suggestions on how I can correct these warnings?

Thanks,
Betty

> -----Original Message-----
> From: Tom Dagostino [mailto:[email-masked]]
> Sent: Tuesday, November 21, 2000 1:15 PM
> To: 'Betty Luk'; 'Kim Helliwell'
> Cc: [email-masked]
> Subject: RE: help with ibischk3 warnings and min data
> 
> 
> The IBIS parser tries to check for consistency between the DC 
> and the AC
> parts of the model.  The endpoint message says the steady 
> state part of the
> AC waveforms does not match the predicted DC characteristics. 
>  If you were
> to take the part and put the output in a high state and 
> connect a 50 Ohm
> resistor to ground the voltage on the resistor is predicted 
> from the pull up
> curve.  To calculate this voltage the parser places a load line on the
> curve, 50 Ohms to ground, and calculates the intersection of 
> the pull up
> curve and the load line.  Likewise for the pull down a 50 Ohm 
> to Vcc load
> line is placed on the pull down and the intersection of the two is the
> predicted output low.  If the predicted values do not match 
> the end points
> in the model's AC tables within 2% the error is given.
> 
> Tom Dagostino
> IBIS and Tau Modeling Manager
> SDD
> Mentor Graphics Corp.
> 503-685-1613
> [email-masked]
> 
> 
> -----Original Message-----
> From: Betty Luk [mailto:[email-masked]]
> Sent: Tuesday, November 21, 2000 10:05 AM
> To: 'Kim Helliwell'
> Cc: [email-masked]'
> Subject: RE: help with ibischk3 warnings and min data
> 
> 
> Hi Kim,
> 
> Thanks,
> Betty
> > -----Original Message-----
> > From: Kim Helliwell [mailto:[email-masked]]
> > Sent: Tuesday, November 21, 2000 12:38 PM
> > To: Betty Luk
> > Cc: [email-masked]'
> > Subject: Re: help with ibischk3 warnings and min data
> >
> >
> > > Betty Luk wrote:
> > >
> > > Hi,
> > >
> > > I appreciate all the help I have been getting so far.. thanks!
> > >
> > > I have built my IBIS model using s2ibis2, typ, min and max
> > data.  The data for my min curve seem to be a bit strange
> > > (when I looked at the curves using s2iplt), and the IBIS
> > golden parser is complaining about non-monotonic data.  I am
> > > not sure whether I should try to fix these warnings or not,
> > because they are not just isolated occurences of
> > > non-monotonic data (ie.  I cannot just discard the
> > problematic point).  I have included my IBIS model for
> > > convenience.  These are the warnings that I get:
> > >
> > > WARNING (line   52) - Pulldown Minimum data is non-monotonic
> > > WARNING (line  134) - Pullup Minimum data is non-monotonic
> > > WARNING (line  307) - POWER Clamp Typical data is non-monotonic
> > > WARNING (line  308) - POWER Clamp Minimum data is non-monotonic
> > > I also get another warning.  What does this warning mean?
> > >
> > > WARNING - Model 'tristate_driver': MIN AC Rising Endpoints
> > ( 0.00V,  0.89V) not within
> > >           0.018V (2%) of (-0.02V,  0.84V) on VI curves for
> > 50 Ohms to 0V
> > >
> > > I would really appreciate any feedback!
> > >
> > > Thanks,
> > > Betty Luk
> > >
> > >
> > >
> > >
> > >
> > >
> > >                Name: test.ibs
> > >    test.ibs    Type: unspecified type (application/octet-stream)
> > >            Encoding: quoted-printable
> >
> > 1. I believe that most simulators currently available filter
> > the IBIS table data
> >    so as to remove nonmonotonicity from the data.  That's not
> > to say it's not
> >    better to remove it yourself first.  It might be a good
> > idea to check the
> >    actual curves from the simulator you're using with s2ibis2
> > and see whether
> >    the nonmon behavior is present in the data, or whether
> > it's introduced by
> >    the interpolation routines in s2ibis2.  If it is present
> > in the actual
> >    simulation output, does the nonmonotoncity appear to be
> > severe?  If so, then
> >    perhaps there are problems with the models you are using.
> > If it's minor,
> >    and if it's outside the normal supply range, it probably
> > won't hurt things
> >    too much.
> >
> >    I would say: do your best to eliminate this problem, but
> > if it's not possible,
> >    you may have to rely on the filtering in your customer's
> > simulators.
> >
> > 2. The problem with your AC warning is that the start and end
> > values of the
> >    V-T curves do not match the start and end values of the VI
> > curves.  You need
> >    to understand why this is happening, which will involve
> > looking at the SPICE
> >    netlists and output for the VI and VT curves.  The lower
> > endpoint is probably
> >    close enough to ignore, but the upper one is a bit further
> > off.  There is a
> >    risk that some simulators your customers use will not
> > tolerate this too well
> >    and simply fail or (worse) quietly give the wrong answer.
> >
> > In any case, any warnings you don't fix should be mentioned
> > in comments in the
> > resulting IBIS file, so your users don't panic when they see
> > the warnings.
> >
> >
> > --
> > Kim Helliwell
> > Senior CAE Engineer
> > Acuson Corporation
> > Phone: 650 694 5030  FAX: 650 943 7260
> >
>

---

From: "Ingraham, Andrew" <[email-masked]>
Date: Tue, 21 Nov 2000 16:51:59 -0500

> WARNING - Model 'tristate_driver': MAX AC Falling Endpoints ( 1.34V,
> 3.60V)
> not within 
>           0.045V (2%) of ( 1.34V,  3.79V) on VI curves for 50 Ohms to 3.6V
> 
> For example, in the last warning statement, it states the correct range to
> be ( 1.34V,  3.79V).  If my supply voltage is 3.6V, how can the final
> voltage be 3.79V, higher than 3.6V?
 
Looking at your V-I curves, the [Pullup] curves do not pass through the
origin!  In the I(min) and I(max) columns, the current doesn't equal zero
when Voltage is zero.

That may be why you get that strange behavior.  I don't know what caused the
V-I curves to be like this.

Andy