Subject: Re: DC convergence

From: Syed Huq <[email-masked]>
Date: Tue, 5 Sep 2000 17:40:15 -0700 (PDT)

Linda,

This is a well known issue. Here is the workaround:

1) Make sure the [Iterate] keywork is in your .s2i file. If s2ibis2 generated
   the Input(.spi)and Output(.out)files successfully, the iterate feature helps
   not to re-sim these same model_types again.
   
2) Edit the .spi files that caused the convergence problem by reducing the
   range:
   
   Example:
   
   .DC VOUTS2I 0 -1.5 -0.1 #(GND clamp sweep edited to go from 0V to -1.5V)
   
3) Re-run s2ibis2

Hope this helps.
Syed
Cisco Systems, Inc
   
> X-Sender: [email-masked]
> Date: Tue, 05 Sep 2000 16:42:20 -0700
> To: [email-masked]
> From: Linda Chu x3207 <[email-masked]> (by way of John Angulo 
<[email-masked]>)
> Subject: DC convergence
> Mime-Version: 1.0
> 
> Hi,
> When DC sweep range from -Vcc to Vcc*2 on the PULLUP/PULLDOWN
> simulation, it has convergence problem. I try to use the alternative
> method is to do an AC, but the SPICE-IBIS convertor doesn't recognize
> the spice output format. So when it generated the IBIS model, it puts
> out N/A in the current table. Is there anyone can help me on this?
> thanks
> linda
>

---

From: "Montoya, Silvia" <[email-masked]>
Date: Wed, 6 Sep 2000 11:49:13 -0700

Hi Syed,
	I thought running s2ibis2 re-creates the .spi files every time.
Wouldn't the edits to  .DC VOUTS2I 0 ... be lost ?

Thanks,
Silvia Montoya
Actel Corp.

-----Original Message-----
From: Syed Huq [mailto:[email-masked]]
Sent: Tuesday, September 05, 2000 5:40 PM
To: [email-masked]; [email-masked]
Subject: Re: DC convergence

Linda,

1) Make sure the [Iterate] keywork is in your .s2i file. If s2ibis2
generated
   the Input(.spi)and Output(.out)files successfully, the iterate feature
helps
   not to re-sim these same model_types again.

   Example:

3) Re-run s2ibis2

Hope this helps.
Syed
Cisco Systems, Inc
   
<[email-masked]>)

---

From: Syed Huq <[email-masked]>
Date: Wed, 6 Sep 2000 12:46:13 -0700 (PDT)

Silvia,

It will re-create the spi files every time if the [Iterate] keyword is not used
in the .s2i file. So if you insert the [Iterate] keyword and have a saved .spi
file, the file will not be over-written. Make sure you delete the previously 
generated .out file so your new .spi file will be used to re-sim.

Regards,
Syed

> From: "Montoya, Silvia" <[email-masked]>
> To: "[email-masked]'" <[email-masked]>, [email-masked], 
[email-masked]
> Subject: RE: DC convergence
> Date: Wed, 6 Sep 2000 11:49:13 -0700 
> MIME-Version: 1.0
> 
> Hi Syed,

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Wed, 6 Sep 2000 17:47:55 -0700

Not really.  I have only seen non-convergence in this situation
when the buffer was clamping 1e+23 Amps of current at the end
of the IV curve.  When the resistive properties of the clamps are
correctly described in the SPICE model, the endpoints will usually
not have more than a few amps.  In that case I have never seen any
non-convergence problems, yet the device would probably still go
up in smoke...

Arpad Muranyi
Intel Corporation
================================================================

-----Original Message-----
From: Al Davis [mailto:[email-masked]]
Sent: Wednesday, September 06, 2000 12:03 PM
To: Linda Chu x3207; [email-masked]
Subject: Re: DC convergence

On Tue, 05 Sep 2000, Linda Chu x3207 wrote:
> simulation, it has convergence problem. ...

I think the real problem is that your real chip would probably go up
in smoke if you tried to force -Vcc or Vcc*2 into its signal pin,
without any series resistance to limit the current.  Spice uses
non-convergence as a method of representing the smoke.

The best bet is to not sweep that far if it causes trouble, then fake
it by extending the slope in a straight line.  Ideally, I would say
to stop the curves where you run out of data, but some simulators do
not extend the curve properly.

In any case, be sure test the resulting IBIS model, to make sure it
makes sense, and realize that you may need to tweak it a bit.