Subject: usefullness of V/T curves

From: "Betty Luk" <[email-masked]>
Date: Tue, 19 Sep 2000 17:28:25 -0400

Hello IBIS users,

I just started trying to create an IBIS model for a CMOS 3-State output pad.  I am not an expert on modelling or signal integrity, so I would greatly appreciate any help and feedback.

I have a question regarding the usefullness of an IBIS model:

In the IBIS Cookbook, it recommends that 4 V/T curves be generated for a standard CMOS buffer, using a 50 Ohm load connected to GND or Vcc.  When using the IBIS model in HSPICE, there is an optional parameter that can be specified (ramp_rwf) to indicate that the [Rising waveform] and/or [Falling waveform] data is to be used instead of the [Ramp] ratio.

Specifying the [Rising waveform] and [Falling waveform] should provide better accuracy for the IBIS model because in reality the output switching of the device is not a linear ramp.

My confusion is, how is this data useful for the customer, when the load is not a 50 Ohm resistor, but, say capacitive?  How can the data provided by the [Rising waveform] and [Falling waveform] in the IBIS model give accurate simulation results, when the loading on the device has been changed?

Thank you very much,

Betty Luk

IC Technology
Genesis Microchip Inc.
165 Commerce Valley Dr. W.
Thornhill, Ont. L3T 7V8
(905) 889-5400 x2256

---

From: "Chris Rokusek" <[email-masked]>
Date: Tue, 19 Sep 2000 15:10:50 -0700

Betty,

Can't comment specifically on the HSPICE implementation, but the intended
approach is that the V/T waveforms be used to determine the dynamic thevenin
equivalent(s) of the driver (not just current or voltage which sounds like
what you're thinking).  This dynamic thevenin equivalent (source impedance
and voltage) is assumed not to change significantly even as the actual load
used in practice will.  Four V/T curves are required in order to cover the
all loads that will be seen on the board as well as distribute currents
properly between GND and PWR.

Your IBIS model (assuming standard technology) with the 4 recommended V/T
curves should get the right answer for all practical loads.

Chris Rokusek
Innoveda

> -----Original Message-----
> From: Betty Luk [mailto:[email-masked]]
> Sent: Tuesday, September 19, 2000 2:28 PM
> To: [email-masked]
> Subject: usefullness of V/T curves
>
>
> Hello IBIS users,
>
> I just started trying to create an IBIS model for a CMOS 3-State
> output pad.  I am not an expert on modelling or signal integrity,
> so I would greatly appreciate any help and feedback.
>
> In the IBIS Cookbook, it recommends that 4 V/T curves be
> generated for a standard CMOS buffer, using a 50 Ohm load
> connected to GND or Vcc.  When using the IBIS model in HSPICE,
> there is an optional parameter that can be specified (ramp_rwf)
> to indicate that the [Rising waveform] and/or [Falling waveform]
> data is to be used instead of the [Ramp] ratio.
>
> Specifying the [Rising waveform] and [Falling waveform] should
> provide better accuracy for the IBIS model because in reality the
> output switching of the device is not a linear ramp.
>
> My confusion is, how is this data useful for the customer, when
> the load is not a 50 Ohm resistor, but, say capacitive?  How can
> the data provided by the [Rising waveform] and [Falling waveform]
> in the IBIS model give accurate simulation results, when the
> loading on the device has been changed?
>
> Thank you very much,
>
> Betty Luk
>
> IC Technology
> Genesis Microchip Inc.

---

From: Scott McMorrow <[email-masked]>
Date: Tue, 19 Sep 2000 16:36:44 -0700

Chris Rokusek wrote:

> Betty,
>
> Can't comment specifically on the HSPICE implementation

V/T tables work quite well in HSPICE.  They correlate to the
original spice as well as other behavorial simulators, limited
only by the number of waveform points.

regards,

scott

--
Scott McMorrow
Principal Engineer
SiQual, Signal Quality Engineering
18735 SW Boones Ferry Road
Tualatin, OR  97062-3090
(503) 885-1231
http://www.siqual.com

---

From: Cathy Xu <[email-masked]>
Date: Tue, 19 Sep 2000 18:06:32 -0700

Hi,

I'm modeling differential buffers (diff-in, diff-out).
But I'm not sure how should I set the input and output
terminal.

For the I/V curves: should I let OUTP(or INP) go from 
-VDD/2 to VDD and OUTN (or INN) go from VDD/2 to -VDD? 
Or connect OUTN(or INN) to GND and sweep OUTP(or INP)
from -VDD to 2*VDD. For the first case, how should I
make the table.

For the timing data: should I take the waveform of one
output, or take the differences of OUTP and OUTN? When
we document the Rload, is it the sum of both terminal?

Any document or examples somewhere?

Thanks,
Cathy