Subject: Simulation resolution weirdness

From: [email-masked]
Date: Tue, 19 Sep 2000 12:25:55 +0300

Hi all,

I am fairly new to using IBIS, so I am hoping that the symptoms that I am
getting will strike a chord with someone out there.

I have run the same simulation several times, changing only the time
resolution each time.  When the resolution is set to 20ps, the results look
fine.  However, at 15ps the resultant waveform is just an increasing
oscillation, and at 10ps it look like a range of mountains.

Obviously I am misusing the method somehow - all I need is for someone to
tell me how.

Any ideas?

Mark Browne
Senior Engineer
Nokia UK Ltd.

---

From: "Ingraham, Andrew" <[email-masked]>
Date: Tue, 19 Sep 2000 08:13:13 -0400

There are limitations and imperfections in all circuit simulators.  (You
didn't mention which simulator program you are using, which might help
others to help you.)  Some programs are better than others.  These problems
can be finicky and difficult to avoid.

Yours sounds like a "numerical oscillation" problem, which occasionally
happens in SPICE or SPICE-like simulators.  In your case, it apparently
happens to be made worse by certain time resolution settings.  There are
likely some controls (such as the Method=Gear vs. Trap setting in SPICE)
that may help here.

Regards,
Andy

> ----------
> From: 	[email-masked][SMTP:[email-masked]]
> Sent: 	Tue, 19 September 2000, 05:25
> To: 	[email-masked]
> Subject: 	Simulation resolution weirdness
> 
> Hi all,
>

---

From: [email-masked]
Date: Tue, 19 Sep 2000 16:50:38 +0300

I am using Interconnectix.  Do the tools not generally work in the same way?

Regards,
Mark

> -----Original Message-----
> From: EXT Ingraham, Andrew [mailto:[email-masked]]
> Sent: 19 September 2000 13:13
> To: [email-masked]'
> Cc: 'ibis-users'
> Subject: RE: Simulation resolution weirdness
> 
> 
> > resolution each time.  When the resolution is set to 20ps, 
> the results
> > look

---

From: "Beal, Weston" <[email-masked]>
Date: Tue, 19 Sep 2000 09:11:47 -0700

Mark,

this often happens when the I-V curves don't have enough data points.  If
the slope of the lines connecting the points changes too much, it is hard
for the simulator to follow.  It is a kind of numerical noise similar to
what happens in SPICE.  If you really need a fine time resolution, you might
ask the vendor for a model with finer detail, or you might add a few points
into the tables to smooth out the corners.

Regards,
Weston

 + -----Original Message-----
 + From: [email-masked] [mailto:[email-masked]]
 + Sent: Tuesday, September 19, 2000 2:26 AM
 + To: [email-masked]
 + Subject: Simulation resolution weirdness
 + 
 + 
 + Hi all,
 + 
 + I am fairly new to using IBIS, so I am hoping that the 
 + symptoms that I am
 + getting will strike a chord with someone out there.
 + 
 + I have run the same simulation several times, changing only the time
 + resolution each time.  When the resolution is set to 20ps, 
 + the results look
 + fine.  However, at 15ps the resultant waveform is just an increasing
 + oscillation, and at 10ps it look like a range of mountains.
 + 
 + Obviously I am misusing the method somehow - all I need is 
 + for someone to
 + tell me how.
 + 
 + Any ideas?
 + 
 + Mark Browne
 + Senior Engineer
 + Nokia UK Ltd.
 +

---

From: [email-masked]
Date: Tue, 19 Sep 2000 12:19:55 -0500

Mark,
You should take a close look at the IBIS data you were given.  Check the
ramp data.  I recently had a case of an oscillation like you describe that
went away after I got an updated and corrected IBIS file.  Your supplier can
put numbers in the file that will cause it to pass the ibis checker, but not
the "spice" or human checker.

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592

> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, September 19, 2000 8:51 AM
> To: [email-masked]
> Cc: [email-masked]