Subject: RE: Drive-on-demand

From: "zanella, fabrizio" <[email-masked]>
Date: Thu, 7 Sep 2000 08:21:45 -0400

Bob, DC, are you referring to the double drive devices like AVC logic, which
has fast drive in the 20-80% region and then softens the drive at the
corners?  This is a technology we've wanted to evaluate for some time, but
the IBIS standard does not support it yet.
Regards, 
Fabrizio Zanella
EMC corporation
[email-masked]

-----Original Message-----
From: Bob Ross [mailto:[email-masked]]
Sent: Thursday, August 31, 2000 9:24 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Drive-on-demand

D.C.:

Based on your description, I do not believe Bus_hold will work
directly.  I do not believe simulators will work with 
"negative" currents in the tables - meaning doing the
opposite of what is expected or creating a negative
impedance buffer that acts opposite of a conventional buffer.

Opposite polarity I-V tables will probably be flagged
as an error by the ibischk3 parser.  Therefore it would
not be legal.

I cannot think of any clever alternative with IBIS
Version 3.2.  

However, I believe the new macro language under discussion by
the IBIS Futures Working Group will be able to handle this
situation (this would be a good test case).

Bob Ross
Mentor Graphics

"D.C. Sessions" wrote:
> 
> Need to double-check this.  It seems that there are standard
> logic components which, on output, sense the output voltage
> and adjust drive current in response.
> 
> No, I don't mean bus hold.  These parts drive LOW hard when
> the output voltage is above a certain threshold and cut the
> drive when the output is below that threshold.  Rising-edge
> drive is similar.
> 
> Yes, I know that this is of dubious stability.  Nobody asked
> me if they should do it this way, but the manufacturers want
> to make this a JEDEC standard and I'm trying to help them
> put together an IBIS model.  Which, as far as I can tell, is
> possible using
> 
> Submodel_type   Bus_hold
> 
> and having negative currents in the [Pulldown] and [Pullup]
> tables.
> 
> 1) Have I missed a better way to do this?
> 2) Will this be legal?
> 3) Will this break EDA tools?
> 
> --
> D. C. Sessions
> [email-masked]

---

From: Bob Ross <[email-masked]>
Date: Thu, 07 Sep 2000 11:05:09 -0700

Fabrizio:

Initially I thought that the [Submodel] Bus_hold could be
configured to create the model.  However, what is needed
is a trigger that turns off a submodel driver, rather than
turns it on.

DC suggested creating a "negative" impedance driver to
accomplish the same effect.  The driver would be
switched in, and the negative impedance in parallel
with the existing driver impedance would create the
effect of a higher impedance driver.  I cannot think
of a good way to do this without causing some other
bad interactions.

Bob Ross
Mentor Graphics

---

From: Kellee Crisafulli <[email-masked]>
Date: Thu, 07 Sep 2000 11:27:10 -0700

Hi Bob, Frabrizio,

I don't see what the problem is.
Shouldn't multiple VT tables provide
enough data to modeling this softening effect?

Kellee

> > > 3) Will this break EDA tools?

---------------------------------------------------------
Have a great day....
Kellee Crisafulli
Innovative tools for SI,EMC,X-talk and IBIS tools
E-mail: <mailto:[email-masked]>
web:    <http://www.hyperlynx.com>
---------------------------------------------------------

---

From: Scott McMorrow <[email-masked]>
Date: Thu, 07 Sep 2000 13:05:18 -0700

All,

I would suggest a multistage driver that is tailored for one
specific corner.  It would be tricky to construct, but it should
work.  For each device corner you would have to determine
the transition region where the driver impedance changes
and adjust the staging in the ibis model to account for
this.  I imagine that it would take 3 different models to
cover min/typ/max behavior.

scott

--
Scott McMorrow
Principal Engineer
SiQual, Signal Quality Engineering
18735 SW Boones Ferry Road
Tualatin, OR  97062-3090
(503) 885-1231
http://www.siqual.com