Subject: SPICE-to-IBIS conversion for I/O Buffer

From: "Eric Hui" <[email-masked]>
Date: Mon, 21 Aug 2000 17:13:30 -0400

I am trying to create an IBIS model for an I/O buffer using the following SPICE-to-IBIS conversion program that I downloaded.

SPICE-to-IBIS conversion(IBISv2.1): North Carolina State University

By inspecting all the SPICE files that the conversion program created, I found out that it never supplied any voltage at the input pin and the enable pin, not even for [RAMP] measurement.  Is this a bug in the conversion program, or did I miss something (or parameters)?

Any help will be greatly appreciated.  Thanks in advance.

PS:  I have tried the conversion program for input, output, and 3-state.  They are all fine during the conversion without the problem described above.

Yours truly,
Eric Hui.

---

From: Syed Huq <[email-masked]>
Date: Mon, 21 Aug 2000 17:18:34 -0700 (PDT)

Eric,

I think you are missing something. If your conversion worked for Output and
3-state, you must have defined a input/enable pin in your .s2i file. This
is necessary to put the output in High/Low/Tri-state modes by SPICE.

This same Input pin information will be used for [Ramp] or V/T waveforms.

For example, if this is part of the .s2i file defining the Input and Output
models:

|
|   Node    Signal  Model
[Pin]
1   gg     gnd     GND
2   vv     vdd     POWER
3   a       A    MyDevice_IN
4   b0     B0    MyDevice_OUT
-> 3
|

Your s2ibis2 generated [Ramp] .spi file should look like this:

.
.
RLOADS2I b0 vv 50    # Pin b0 is an Output
VCCS2I vv 0 DC 3.3
VGNDS2I gg 0 DC 0
VINS2I a 0 PULSE(2 0.8 0 1e-10 1e-10 2e-08 4.04e-08) # Pin 'a' is input
.TEMP 27
.OPTIONS INGOLD=2
.TRAN 1e-10 1e-08
.PRINT TRAN V(b0)
.
.

Hope this helps.
Syed
Cisco Systems, Inc

> 
> I am trying to create an IBIS model for an I/O buffer using the following 
SPICE-to-IBIS conversion program that I downloaded.
> By inspecting all the SPICE files that the conversion program created, I found 
out that it never supplied any voltage at the input pin and the enable pin, not 
even for [RAMP] measurement.  Is this a bug in the conversion program, or did I 
miss something (or parameters)?
> PS:  I have tried the conversion program for input, output, and 3-state.  They 
are all fine during the conversion without the problem described above.