Subject: RE: confusion about c_comp

From: Betty Luk <[email-masked]>
Date: Wed, 20 Dec 2000 16:34:31 -0500

> > I am a bit confused about c_comp.  C_comp is the silicon 
> die capacitance,
> > which includes the parasitic capacitance of the buffer, the 
> bond wire and
> > the die pad capacitance.
>  
> I would not have included the bond wire capacitance, because 
> the bond wire
> is part of the package (although the position of the 
> capacitance relative to
> L_pkg may make this debatable).  I think c_comp would apply 
> to just the bare
> die, even though the IBIS spec does not explicitly say so.
>

I think I might have used the wrong terminology.  By "bond wire", I actually
meant the connection between the output of the buffer on the die to the die
pad.  That's why I think that it should be included in the c_comp.
 
> 
> > When the Spice simulations are run to generate the IBIS 
> data, the effects
> > of the c_comp parameter should already be included (since 
> you can't take
> > away the parasitic capacitance of the circuit).  So when 
> the [c_comp]
> > keyword is specified, isn't the effect of c_comp double-counted?
>  
> By specifying the c_comp keyword, you are providing the 
> IBIS-aware simulator
> with the equivalent capacitance that you had in your SPICE 
> simulations.
> That is the only place in the IBIS data where this 
> capacitance exists!  I
> don't see how there is any double-counting.
> 
> 

The effects of c_comp is already in the V/t waveform data.  The on-die
capacitance is what causes the ramp, right?  So if a simulator is not
careful enough, and uses the value of c_comp along with the V/t data in the
IBIS model, then the c_comp would be "double-counted".

> > For example, when I generated my IBIS model, I estimated 
> the value of the
> > bond wire and die pad capacitance, and added that as an explicit
> > capacitance to the buffer output before using Spice to 
> extract data.  Then
> > I estimated the value of parasitic capacitance of the 
> buffer circuit (as
> > described by Arpad Muranyi).  The total [c_comp] value is 
> the sum of bond
> > wire and die pad capacitance, and the parasitic capacitance of the
> > circuit.  Is this approach correct?
>  
> If your SPICE model is complete enough to include die bonding pad
> capacitance (and bond wire capacitance if you determine that 
> it should be
> part of c_comp too), then whatever value of capacitance you 
> extract from
> your SPICE simulations *IS* the value for c_comp.  You would not add a
> correction factor to account for the die pad capacitance.  
> If, on the other
> hand, your SPICE simulation doesn't include the die pad, then 
> you should add
> it to the extracted capacitance to get the c_comp value for 
> the IBIS data.
> 
> However you do it, c_comp should represent the effective 
> on-die capacitance.
> 
> Andy
>

Betty

---

From: "Baikuan Wang" <[email-masked]>
Date: Fri, 22 Dec 2000 12:20:30 -0800

Hi,

Nice to read these discussion mails.

Since V-t curve is extracted from the circuit including C_comp,
the algorithm to handle IBIS inside software definitely considers
C_comp. When users use the black box of buffer linked with other
circuit, C_comp should not be added.

Regards.
Brian

-----Original Message-----
From: Betty Luk [mailto:[email-masked]]
Sent: Wednesday, December 20, 2000 1:35 PM
To: 'Ingraham, Andrew'; [email-masked]'
Subject: RE: confusion about c_comp

Betty