Subject: IBIS model creation

From: Stephen Nolan <[email-masked]>
Date: Wed, 05 Jan 2000 12:31:04 -0600

I've been reading the draft version of the "IBIS FORUM I/O BUFFER MODELING
COOKBOOK - Revision 2.0X (under development)"

In the section entitled "Making Pullup and Power Clamp Sweeps Vcc Relative" it
states that you should make your three sweeps Vcc relative. Example: min=-3.6 to
6.3, typ=-3.3 to 6.6, and max=-3.0 to 6.9.

In this case, there would be table data created for the min column from -3.6 to
-3.3 where no typ data exists. Also, there would be data in the max column from
6.6 to 6.9 where no typ data exists. In those ranges, the typ column would have
to include NAs. Is this legal?

The IBIS spec (Version 3.2) says:
"NA" can be used for currents in the typical column, but numeric values MUST be
specified for the first and last voltage points on any I-V table.

As I read this, the typ table would have NA values for both the first and last
voltage points on the I-V table, by following this method.

And the example given in the IBIS spec ranges ONLY from -5 to 10 V and does not
include the additional data suggested by the "Making Pullup and Power Clamp
Sweeps Vcc Relative" section of the Cookbook.

Thanks.
-- 
Regards,
Stephen M. Nolan

---

From: "Ross Pryor" <[email-masked]>
Date: Wed, 5 Jan 2000 14:33:28 -0500

Stephen,

The data are tabulated after the vcc-relative calculation, vtable=vcc-vout. After the calculation, the data have the same range.
For a pullup curve, the following table may help:

			(vout)		(vtable)
			sweep			vcc-relative
corner	vcc	range			range
------	---	-----			-------------
min		3.0	-3.6 > 6.3		6.6 > -3.3
typ		3.3	-3.3 > 6.6		6.6 > -3.3
max		3.6	-3.0 > 6.9		6.6 > -3.3

Regards,
Ross
--------------
Ross Pryor
Nortel Networks
Billerica, MA
(978) 288-3811
ESN 248-3811
[email-masked]

-----Original Message-----
From: Stephen Nolan [mailto:[email-masked]]
Sent: Wednesday, January 05, 2000 1:31 PM
To: [email-masked]
Subject: IBIS model creation

Thanks.
--
Regards,
Stephen M. Nolan

---

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 05 Jan 2000 11:32:26 -0800

>to include NAs. Is this legal?
Yes; I believe it is legal.

However I suggest you make life simple and sweep them all from -3.6 to 6.9.
I don't see any reason not to and it eliminates the whole issue (KIS
principle).

best wishes..
Kellee

---------------------------------------------------------
Have a great day....
Kellee Crisafulli 
HyperLynx, a division of Pads Software Inc.
SI,EMC,X-talk and IBIS tools for the Windows platform
E-mail: <mailto:[email-masked]>
web:    <http://www.hyperlynx.com>
---------------------------------------------------------

---

From: "Ross Pryor" <[email-masked]>
Date: Wed, 5 Jan 2000 15:13:14 -0500

Yikes, that's not a good idea for pullup and power clamp curves.  What you suggest will make life much more difficult for the curves
which have to be made vcc-relative.

Sorry to be repetitive.  The data are tabulated after the vcc-relative calculation, vtable=vcc-vout. After the calculation, the data
have the same range.

			(vout)		(vtable)
			sweep			vcc-relative
corner	vcc	range			range

Regards,
Ross
-----Original Message-----
From: Kellee Crisafulli [mailto:[email-masked]]
Sent: Wednesday, January 05, 2000 2:32 PM
To: Stephen Nolan; [email-masked]
Subject: Re: IBIS model creation a few comments...

best wishes..
Kellee

---

From: Kellee Crisafulli <[email-masked]>
Date: Wed, 05 Jan 2000 12:25:06 -0800

Hi Stephen, all

Oops.. Ross is correct.
my appologies...

best wishes..
Kellee

At 03:13 PM 1/5/00 -0500, Ross Pryor wrote:
>Yikes, that's not a good idea for pullup and power clamp curves.  What you
suggest will make life much more difficult for the curves
>Sorry to be repetitive.  The data are tabulated after the vcc-relative
calculation, vtable=vcc-vout. After the calculation, the data