Subject: Ver. 3.2 and Ver. 2.1 Models

From: [email-masked]
Date: Thu, 20 Jul 2000 16:21:45 -0500

To Model Users and EDA Vendors:

Philips Semiconductors offers numerous standard logic Ver. 2.1 IBIS models.  We are planning to start generating Ver. 3.2 models but would like your feedback on an issue.  We are trying assess how many people have capability to run Ver 3.2 models and who 
can use only Ver 2.1 models.  Due to the number of logic families and products we have, we want to avoid maintaining 2 sets of libraries per product family for both versions, but we need to see that our customers' needs are met too.  Your comments would 
be greatly appreciated.

Mike Magdaluyo

Logic Products Group
Philips Semiconductors
(408) 991-2642

---

From: Bob Ross <[email-masked]>
Date: Thu, 20 Jul 2000 16:23:58 -0700

Mike:

I would use and supply Version 3.2 models only when Version 3.2 features
are needed to accurately describe the part.  Otherwise, I would still
supply Version 2.1 models.

Bob Ross
Mentor Graphics

---

From: "Matthew Flora" <[email-masked]>
Date: Thu, 20 Jul 2000 16:45:58 -0700

Dear Mike Magdaluyo,

I concur with Bob Ross, except I would suggest still setting the IBIS_ver
keyword to 3.2.  If nothing else, that will cause IBISCHK3 to use it's most
strict syntax/semantic tests.

Best regards,
Matthew Flora

----- Original Message -----
From: "Bob Ross" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 20, 2000 4:23 PM
Subject: Re: Ver. 3.2 and Ver. 2.1 Models

> > Philips Semiconductors offers numerous standard logic Ver. 2.1 IBIS
models.  We are planning to start generating Ver. 3.2 models but would like
your feedback on an issue.  We are trying assess how many people have
capability to run Ver 3.2 models and who
> > can use only Ver 2.1 models.  Due to the number of logic families and
products we have, we want to avoid maintaining 2 sets of libraries per product
family for both versions, but we need to see that our customers' needs are met
too.  Your comments would

---

From: Al Davis <[email-masked]>
Date: Thu, 20 Jul 2000 21:04:41 -0700

> strict syntax/semantic tests.

I suggest setting the IBIS_ver keyword to 2.1 if it is
really a 2.1 model.  If nothing else, it lets the reader
know that it will work on older simulators that only
support 2.1.

In any case, don't forget to test it.
e actually uses the "treat the drain as the
source" equivalent.

question lies the answer to whether
the non-monotonicity matters separately.  If you accept
that only the sum matters, you are accepting that they
cannot be considered separately, or the latter in the above
paragraph.  Then, why does the documentation show them as
separate elements?  Why are the names what they are? 
(which hints toward the two element meaning)

Making this assumption means you lose the distinction
between the where the other ends connect.  Now, what does
it mean when the "power clamp reference" and "pullup
reference" are different?  (another hint toward the two
element meaning)

> OTOH, I doubt it hurts to smooth out (not LEAVE out!) those points, as long
> as they really are "noise" and insignificant compared to the stronger clamp
> current.

Supplying too many points actually reduces accuracy.  For
the V/I curves, the derivative is actually more important
than the data provided.

Consider the following table:
1   2.995
2   2.995
3   2.995
4   2.996
5   2.996
6   2.996
7   2.997
8   2.997
...

you get the idea.  This is common toward the ends of a
table.  What it says is that it acts like a constant
current source from 1-3 volts, from 4-6 volts, etc.  and
has jumps between 3 and 4, and between 6 and 7.

Most likely, the real device is nearly flat, but the whole
region has a finite slope.  It would be better to just give
2 points.

---

From: Mike LaBonte <[email-masked]>
Date: Fri, 21 Jul 2000 11:41:43 -0400

Periodically I hear that IC vendors feel pressured by users to provide IBIS 3.2 models.
I concur with Bob's point, and would like to suggest that it is primarily up the IC vendor
to make this determination on a part-by-part basis. If a part can be modeled with reasonable
accuracy using only IBIS 2.1 features, then there may be no reason to utilize IBIS 3.2
features. So when customers ask for 3.2 models, it would be best to ask why. Hopefully
the reason is not "because it is the latest IBIS".

Mike LaBonte
Cadence Design Systems

---

From: Scott McMorrow <[email-masked]>
Date: Fri, 21 Jul 2000 10:50:27 -0700

We at SiQual provide IBIS version 3.2 models which
include only version 2.1 features quite often.  There are
two reasons for this:

1) This causes ibischk3 to perform it's highest level
of syntax checking.

2) Because it is our only leverage to encouraging
CAD vendors to update their simulators to support
3.2 features.

Recently, however, almost all of the models which we have
developed use IBIS 3.2 features.  Model Spec,
Dynamic Clamps and Model Selector come to mind.

Quite honestly, it is frustrating to us to find that only
one simulator vendor can consistently support these advanced
features in version 3.2.  As a result, I have no problem
in encouraging all vendors to provide version 3.2 models.

Anything we can do on the model creation end to
speed the adoption of 3.2 syntax in simulators is
goodness for the industry.

BTW, SiQual is also providing IBIS models which have
been correlated to the original Spice decks and include
the IBIS Accuracy Trailer as documentation.  I would
strongly encourage all model creators to do the same.

best regards,

scott

--
Scott McMorrow
Principal Engineer
SiQual, Signal Quality Engineering
18735 SW Boones Ferry Road
Tualatin, OR  97062-3090
(503) 885-1231
http://www.siqual.com

---

From: Scott McMorrow <[email-masked]>
Date: Fri, 21 Jul 2000 12:08:00 -0700

Stephen,

Stephen Nolan wrote:
>What is "the IBIS Accuracy Trailer"?

Here is the directory for it on the IBIS website.

http://www.vhdl.org/pub/ibis/accuracy/

The Trailer is a bunch of comment lines at the end of
a model which are intended to document the correlation
of an IBIS model to actual measurements.  It was developed
by a number of IBIS users, along with the accuracy spec and
handbook, because of their frustration with poor model
quality.

We use the correlation metric which is defined by the
specification to compare IBIS simulations with SPICE
simulations and document these in the models we produce
with the Accuracy Trailer.

In our case, the standard test circuit we use is a driver
driving a 50 ohm microstrip transmission line which
is 8 inches long into a 5pF capacitive load.  This gives
us loads of information on the quality of IBIS simulations
into a fairly complex reflected wave environment.  Typically
our correlations are within 98 to 99% of the original
Spice waveform, according to the metric.

We now deliver all models with correlation data to the
orignal source.  Additionally, we provide reports with
pictures of the comparision waveforms to our end customers,
which are usually semiconductor manufacturers.

best regards,

scott

Scott McMorrow
Principal Engineer

---

From: Stephen Nolan <[email-masked]>
Date: Fri, 21 Jul 2000 14:29:34 -0500

Thanks, Scott.

More questions:
It looks like the IBIS Accuracy Handbook simply advises that the user determine
the transmission-line parameters of the standard test board by doing lab-tests
(TDR measurements). I'm curious if anyone has done so and would be willing to
share those numbers. And/or has anyone used a 2D field solver on the board
design file to get the RLGC parameters for the "50 ohm microstrip transmission
line which is 8 inches long".

Thanks.
-- 
Regards,
Stephen M. Nolan

---

From: Scott McMorrow <[email-masked]>
Date: Fri, 21 Jul 2000 13:32:56 -0700

Stephen,

We have done some real system correlation work which we are not
at liberty to share.  However, when we do, we perform TDR measurements
of board parameters and use this to calibrate  both our field solver
results and in-circuit measurements of driver strength and edge-rate.

We then crank these into our modeling efforts.  Our results have been
very good with up to 1.5 Gbit/second data streams.

In most cases, however, we have neither the time, nor the allocated
funds to perform such a rigorous correlation.  Instead we make the
assumption that our customers are supplying validated Spice models,
which we use in further extraction and correlation work.  In many cases
we work with semiconductor vendors who do correlate their Spice
decks to real silicon.  Thus, an IBIS correlation to Spice is quite
valid.

The intent of the accuracy spec is that IBIS models be correlated
to actually measurement.  In reality, this is not always possible.  We
think that correlation to the Spice is the second best alternative
in most cases.

regards,

scott