Subject: RE: IBIS standard inconsistency

From: [email-masked]
Date: Mon, 31 Jul 2000 10:21:15 -0500

I'm sure there was some intent to give examples of allowed variation! :-)

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592

> -----Original Message-----
> From: Matthew Flora [mailto:[email-masked]]
> Sent: Monday, July 31, 2000 9:46 AM
> To: Stephen Nolan; [email-masked]
> Subject: Re: IBIS standard inconsistency
> 
> 
> Dear Stephen M. Nolan,
> 
> Section three of the specification does say:
> 
> | 1)  The content of the files is case sensitive, except for reserved
> |     words and keywords.
> 
> and:
> 
> | 6)  Keywords must be enclosed in square brackets, [], and 
> must start in
> |     column 1 of the line.  No space or tab is allowed 
> immediately after the
> |     opening bracket '[' or immediately before the closing 
> bracket ']'.  If
> |     used, only one space (' ') or underscore ('_') 
> character separates the
> |     parts of a multi-word keyword.
> 
> So both forms you mentioned are legal.  Why the text of the 
> specification
> mixes the two is anyone's guess.
> 
> Best regards,
> Matthew Flora
> 
> 
> ----- Original Message -----
> From: "Stephen Nolan" <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, July 28, 2000 7:51 PM
> Subject: IBIS standard inconsistency
> 
> 
> > In the IBIS standard, the keywords [IBIS Ver] and [File 
> Rev] appear to the
> the
> > only keywords that have capitalized words other than the 
> first word (the
> word
> > IBIS being completely capitalized accepted as an acronym). 
> All other keyword
> > have the first word capitalized followed by the other words 
> lower case. Eg.
> > [Comment char], [File name], [Voltage range]....
> >
> > Why is there an inconsistency in the style of these keywords?
> >
> > Also, some multiple-word keywords use an underscore between 
> words instead of
> a
> > space. Eg. [GND_clamp], [POWER_clamp].
> >
> > Again, why the inconsistency?
> > --
> > Regards,
> > Stephen M. Nolan
> >
>

---

From: "Hobbs, Will" <[email-masked]>
Date: Mon, 31 Jul 2000 08:29:16 -0700

My memory of this is a bit cloudy, but I do remember the 24-straight hour
session we spent hammering out the final version of IBIS 1.1; it's quite
possible that at 3:00 in the morning we missed it, and no one picked it
up in subsequent reviews. Fortunately, it is inconsequential.

Will

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Monday, July 31, 2000 8:21 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: IBIS standard inconsistency

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592