Subject: RE: min typ & max, explained (I hope)

From: "Peters, Stephen" <[email-masked]>
Date: Thu, 23 Mar 2000 12:27:58 -0800

Hello All:

  Which parameters have their min, typ and max values listed
according to absolute value and and those that have their values
listed by operating corner is detailed in the IBIS cookbook, section
4.  The cookbook can be found at:

 http://www.eia.org/eig/ibis/ibis.htm

click on the 'spec' link.

 Regards,
 Stephen Peters
 Intel Corp.

-----Original Message-----
From: Weston Beal [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 11:00 AM
To: [email-masked]
Subject: RE: min typ & max, explained (I hope)

Matt and Kellee,

typ, min, and max refer to the manufacturing tolerance as Kellee stated
except in the case of temperature.  Since temperature has opposite effects
in CMOS and TTL, we can not just specify the min and max temperature.  The
min temperature is the temperature at which the min IV (and VT) curves are
measured.  The same applies to max temperature with max curves. This is
stated in the IBIS specification, I believe.  All the other parameters are
specified by numerical min and max.

Regards,
Weston

-----Original Message-----
From: Kellee Crisafulli [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 9:48 AM
To: Matt Callicoat; [email-masked]
Subject: Re: min typ & max, explained (I hope)

Hi Matt,

At 10:46 AM 3/23/00 -0600, Matt Callicoat wrote:
>I'm a little confused about the definitions of min, typ, and max in the
>ibis specifications.  In some cases, it seems to simply mean the
>smallest, middle, and greatest numerical values, respectively.  But in
>other cases it seems to refer to slow, typical, and fast, respectively.
>For a CMOS circuit, I believe the convention is as follows:

Min typ and max are used consistently in IBIS as refering to the
parameter they describe.  For example: C_comp min,typ,max are the
min,typ,max manufacturing tolerance values that describe C_comp.

For the purposes of choosing a SLOW or FAST process the choice of
which min's and max's to use together is not specified by IBIS.  It is
the responsibility of the user together with the simulator to select
the choice of combinations that would say describe the slowest or fastest
output edge rate.

There have been a few discussions in the past about specifying which
combinations are to be used for some of the corners but we could not
agree about how many corners there should be or what parameters they
should be.  We ultimately decided to leave this to the simulators and
end users.

best wishes..
Kellee

---------------------------------------------------------
Have a great day....
Kellee Crisafulli
HyperLynx, a division of Pads Software Inc.
SI,EMC,X-talk and IBIS tools for the Windows platform
E-mail: <mailto:[email-masked]>
web:    <http://www.hyperlynx.com>
---------------------------------------------------------

---

From: "Weston Beal" <[email-masked]>
Date: Thu, 23 Mar 2000 13:19:29 -0800

All,

Final word. From the IBIS 3.2 specification:

"| The optional [Temperature Range] keyword will contain the temperature
which
| causes or amplifies the slow, weak conditions in the "min" column and the
| temperature which causes or amplifies the fast, strong conditions in the
| "max" column. Therefore, the "min" column for [Temperature Range] will
| contain the lowest value for bipolar models (TTL and ECL) and the highest
| value for CMOS models. Default values described later are assumed if
| temperature is not specified.
|
| The "min" and "max" columns for all remaining keywords and subparameters
| will contain the smallest and largest magnitude values. This applies to
the
| [Model] subparameter C_comp as well even if the correlation to the
voltage,
| temperature, and process variations are known because information about
such
| correlation is not available in all cases."
  - section 9, pg. 76

Regards,
Weston

-----Original Message-----
From: Peters, Stephen [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 12:28 PM
To: [email-masked]'
Subject: RE: min typ & max, explained (I hope)

Hello All:

 Regards,
 Stephen Peters
 Intel Corp.

-----Original Message-----
From: Weston Beal [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 11:00 AM
To: [email-masked]
Subject: RE: min typ & max, explained (I hope)

Matt and Kellee,

Regards,
Weston

-----Original Message-----
From: Kellee Crisafulli [mailto:[email-masked]]
Sent: Thursday, March 23, 2000 9:48 AM
To: Matt Callicoat; [email-masked]
Subject: Re: min typ & max, explained (I hope)

Hi Matt,

best wishes..
Kellee

---

From: Al Davis <[email-masked]>
Date: Thu, 23 Mar 2000 20:51:44 -0800

But the only parameters that the simulator applies
temperature to are the transit times [TTgnd] and [TTpower],
which are diodes so will always act like the TTL devices.