Subject: s2ibis2 conversion tables

From: "Tran, Long" <[email-masked]>
Date: Wed, 29 Mar 2000 14:40:10 -0800

Hi all,

I'm download the s2ibis2 conversion tool from your web site and try to
convert the same file (multipow.s2I file) from s2ibis2/examples/ex4. After
modify the file multipow.s2I to use the Hspice and ran the conversion
command. The conversion completed but the output multipow.ibs file does not
contain all the pullup, pulldown, power clamp, gnd clamp tables as I
compared with your rename file my_mpow.ibs. Am I using the same multipow.s2I
or the file missing something. Please help

Also would you give me some details about using ibis2spice, because I don't
have any successful in using this tool.

Thanks
Long Tran
Email: [email-masked] <mailto:[email-masked]> 
Ph:253-371-6056

---

From: Syed Huq <[email-masked]>
Date: Wed, 29 Mar 2000 17:50:14 -0800 (PST)

Hi,

Just ran it and the example works on Hspice and here are some tips:

1) Make sure you edited the following two fields for hspice:

[Spice type]		hspice
[model file] hspice.mod hspice.mod hspice.mod

2) Never translate the entire component model in one shot. Start out by
only doing the Input model to see if you run into any problems. Then
uncomment the other pins to do the rest:

[Pin]
1   gnd         gnd         GND
2   tri_in      in1         input
3   tri_in      in2         input
4   in          in3         input
5   enable      enable      input
6   clmp_gnd    clmp_gnd    GND
7   clmp_vdd    clmp_vdd    POWER
|8   nc          nc          NC			# All these are 
|9   out         out3        driver		# commented out
|-> 4						# 
|10  tri_out     out2        tristate_driver	#
|-> 3 5						#
|11  tri_out     out1        tristate_driver	#
|-> 2 5						#
12  vdd         vdd         POWER		

3) Hspice will not converge on the IBIS specified range of -Vdd to +2Vdd.
You need to edit the .spi files to change the range.

Once you follow the 3 steps above, just sit back and let the tool do the rest.
It's that easy..

Regards,
Syed
Cisco Systems, Inc

---

From: Syed Huq <[email-masked]>
Date: Thu, 30 Mar 2000 09:17:53 -0800 (PST)

------------- Begin Forwarded Message -------------

Date: Wed, 29 Mar 2000 17:55:59 -0800 (PST)
From: Syed Huq <[email-masked]>
Subject: Re: s2ibis2 conversion tables
To: [email-masked], [email-masked]
MIME-Version: 1.0
Content-MD5: NIYTw/b7jLRwzWD9gJtRWA==

Hi again,

ibis2spice is a shareware from Intusoft. You need to visit their website for
documentation. I have not used it myself.

If you are using Hpice, they support a conversion from IBIS to Hspice behavioral 
model using 'B' element.

Syed

------------- End Forwarded Message -------------