Subject: IBIS Series MOSFET Models - questions

From: Stephen Nolan <[email-masked]>
Date: Thu, 18 May 2000 11:25:02 -0500

Question 1, 

In IBIS Version 3.2, Section 6, "Keyword:  [Series MOSFET]" it states that
"C_comp values are ignored for [Series MOSFET] models." How do you account for
the Cio(off) and Cio(on) characteristics of the FET in the IBIS model?

Question 2,
In IBIS Version 3.2, Section 6, "Keyword:  [Series MOSFET]", and Section 9.5,
"Series MOSFET Table Extractions", it says that the voltage applied to the drain
of the MOSFET is Vds, a fixed voltage difference between the drain and the
source. Quoting from section 9.5:

   Vds is held constant by having a fixed voltage Vds 
   between the drain and source nodes.

However, the drawing shows a fixed voltage source between the drain and GROUND!

|               +----------------------------------------+
|               |                                        |
|               |                   Ids = Table Current  |
|               |                   --->                 |
|               +---<---|     |--->----------+           |
|                   d   |_____| - s          | +         |
|                        --+-- Vgs       +---+---+  +----+----+
|                          | g  +        | Sweep |  |   Vs +  |
|                                        |   Vs  |  |Fixed Vds|
|                                        +---+---+  +----+----+
|                                            | -         |
|                                           GND         GND
|
|                  Example of Series MOSFET Table Extraction

I could see how this would result in a Vds voltage if Vs + was swept, so that it
was always equal to the swept Vs+Vds, but it says "Fixed", not "Sweep".

Shouldn't this drawing be as follows for a true Vds supply?
|                           +---------+
|                         + |   Vs +  | -
|               +-----------+Fixed Vds|------+
|               |           +---------+      |
|               |                            |
|               |   Ids = Table Current      |
|               |         --->               |
|               +---<---|     |--->----------+
|                   d   |_____| - s          | +
|                        --+-- Vgs       +---+---+  
|                          | g  +        | Sweep | 
|                                        |   Vs  | 
|                                        +---+---+
|                                            | -  
|                                           GND   

-- 
Regards,
Stephen M. Nolan

---

From: Mike LaBonte <[email-masked]>
Date: Fri, 19 May 2000 09:14:46 -0400

Stephen,

The figure in the IBIS specification is electrically equivalent to yours,
although your version is easier to understand, in my opinion. The spec
shows two swept sources with a DC offset between them. I prefer your notion
of one fixed source and one swept source, closer to the hardware that would
actually be used.

I would like to see the diagrams also showing the attachment of the gate to Vcc,
since it currently appears that the entire circuit just floats up and down with the
sweep voltage. Then again, maybe the swept source should be attached between
the source and gate, since we are attempting to sweep Vgs.

By the way, has anyone found one of these series switch models available for
public use?

Mike

---

From: Stephen Nolan <[email-masked]>
Date: Fri, 19 May 2000 09:22:21 -0500

Hi Mike,

I discussed this drawing with it's creator (Bob Ross) on the phone yesterday. It
appears that it was the nomenclature in the drawing that I was misunderstanding.
Here is another suggested improvement that I provided:

|                          | g  +        | Sweep |  |  Sweep  |
|                                        |   Vs  |  |  Vs+Vds |

The way that the power-supply on the drain was originally labeled, I had
misunderstood it to be a FIXED supply (like a Vdd). With the labeling I propose
above, I think it is more clear that this is a SWEPT supply that is always Vds
above Vs. 

I agree with you that the gate supply should be illustrated also.

There is an example model (Created by Mentor Graphics) of a TI CBT3383 part
available at: http://www.eda.org/pub/ibis/samples/ver3.1/cbt.ibs

Now another question:

What table voltage do I use for Vgs, when the series switch is a parallel NMOS
and PMOS?

|                      gateP=GND
|                          |
|                          o
|                       =======  Vgs-p
|                       |     |
|               ----<---+     +--->----
|                   d   |_____|   s
|                        --+--   Vgs-n
|                          |
|                      gateN=Vcc

-- 
Regards,
Stephen M. Nolan

---

From: Christian Klein <[email-masked]>
Date: Fri, 19 May 2000 10:41:23 -0400

Mike,

A while ago I created some Bus switch models. They can be found at:
http://www.fairchildsemi.com/models/ibis/#fst

-Christian