Subject: Re: IBIS connector model

From: Kellee Crisafulli <[email-masked]>
Date: Mon, 22 May 2000 06:47:59 -0700

Hi Kanal,

 At this point no company should be offering IBIS connector
models.  We have not released the standard yet and it
is still changing.

We do expect this work to be completed soon however.

best wishes..
Kellee Crisafulli

---

From: Todd Westerhoff <[email-masked]>
Date: Mon, 22 May 2000 10:55:55 -0400

Kanal,

I've seen several responses to your email, some of which were sent to you privately, but I'll overview the answer for the group:

The error message "Connector with Active Pin" points to a problem with the way device CLASS and PINUSE properties are set in your database.

A PCB database, by itself, is a physical database that can be used to manufacture a board.  If you want to accurately model the design for simulation, there is additional information that the simulation tools need:

1- an accurate description of the PCB cross-section (Stackup)
2- definitions of which nets are tied to which power supplies
3- an understanding of each device's electrical purpose (i.e. an IC?  a resistor pack? a connector?)
4- specific simulation models for critical high speed components
5- reasonable "default" simulation models for non-critical components without a specific model

Your issue is with point #3.  Allegro/SPECCTRAQuest use the properties of CLASS and PINUSE to define the device's type (CLASS = IC, DISCRETE or IO) and the function of the pins within the device (PINUSE).  The error message you refer to states that the system has found a connector (CLASS = IO) with a PINUSE other than UNSPEC.    The systems expects the PINUSE for a connector (CLASS = IO) to be UNSPECified because the device is assumed to be passive.

The usual issue is that a company's Allegro device library doesn't set the CLASS and PINUSE properties correctly, because the people who build the parts libraries aren't aware of the electrical requirements.  There are two ways to address the issue:

1. If the people who maintain your device libraries are willing to update their device files, great.
2. The "database setup advisor" introduced in the 13.6 release will guide you through the process of setting up the properties in your database, independent of addressing any fixes to the libraries.  This sets the properties directly in the individual .brd file.

For everyone else, my apologies for getting into so many tool-specific issues in a public forum.  The question was asked publicly, and I figured it would probably benefit a number of people to answer the question (at least to the first level) the same way.

Anyone who needs more detail, let's please take this on off the reflect - feel free to contact me @ [email-masked].

Todd.

At 07:39 AM 5/22/2000 -0400, [email-masked] wrote:
>I am trying to extract a topology using SpectraQuest, but cannot because 
>of the following error. "Errors: Connector With Active pin". The model is 
>attached to this message. Can anyone clarify the proper use of connector
>models in circuit simulation or provide me with a connector model? 
>
>Regards,
>
>Bashu Kanal
>EMC Corporation
>Design Verification Group
>  <<conn149.ibs>> 

    Todd Westerhoff
    Product Marketing Director | High Speed Systems Design | Performance Engineering
    Cadence Design Systems | 270 Billerica Road | Chelmsford, MA  01824
    
    ph: (978) 262-6327
    fx: (978) 446-6798
    email: [email-masked]
    internal information website: http://www-ma.cadence.com/~toddw

---

From: [email-masked]
Date: Mon, 22 May 2000 11:21:11 -0400

Kanal,

From within SPECCTRAQuest or Allegro, ensure that the "CLASS" of the
connector is set to "IO"; by default, it probably is set to "IC".  Also,
ensure that the "PINUSE" is set to "UNSPEC" for each of the pins on the
connector.  Then, from within the SPECCTRAQuest Model Assignment menu,
create or edit an/the IBIS Device, but ensure no IO buffers are assigned to
any pin (including, but not limited to CDSDefault*).

Regards,
Michael Cohen

---

From: "Le, Dat (dle)" <[email-masked]>
Date: Mon, 22 May 2000 08:46:57 -0700

Are you trying to extract the topology from a board2board file? Specctraquest
has a feature called "Design link". In this window, you can specify the pin
to pin interconnection, the length and a pointer to your  "dml" conn model. 
This's another area Specctraquest would spit out error message if your conn
model has a pin count or pin reference mismatch with Allegro boardfile.  Note
your conn.ibs file will need to translated to Specctraquest DML format. I use
ibis2signoise to do this. Yes, Specctraquest v13.5 or newer should be  able
to translate Ibis v 3.1 pkg format. 

As far as obtaining model, I had similar problem obtaining Ibis conn model.
Depend on your simulation accuracy requirement, it's pretty easy to create a
simple lumped single line PCI model in Specctraquest. You can obtain SLM and
MLM data from 
AMP or other conn vendors. More accurate pkg/conn model will need to be
translated directly from vendor Spice format to Cadence K-spice format.
Unfortunately, 6 months ago I  inquired Cadence regarding of an automate
script to do the spice translation without any success. Specctraquest does
have sample of generic pkg models shipped with this tool.

Dat Le
*****************************************
System Engineer
IBM-NumaQ
[email-masked]
(503)578-3412
*****************************************

> -----Original Message-----
> From:	Ross Pryor [SMTP:[email-masked]]
> Sent:	Monday, May 22, 2000 6:42 AM
> To:	[email-masked]; [email-masked]
> Subject:	RE: IBIS connector model
> 
> I believe this error is due to the "pinuse" property of your connector pins
> in the Allegro symbol for the connector.  You need to
> set the property to "unspec" on all connector pins.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, May 22, 2000 7:40 AM
> To: [email-masked]
> Subject: IBIS connector model
> 
>