Subject: "non-monotonic" warning in IBIS checker

From: Shaghayegh Azgomi <[email-masked]>
Date: Mon, 10 Apr 2000 17:17:02 -0700 (PDT)

Hi,
I have a question regarding IBIS models.  When I try
to use IBIS checker to verify the models IBIS models
(Hyperlynx simulator) I get warning messages regading
to 'non-monotonic' nature of some signals.  Some of
the warning are as following such:

Pulldown Maximum data is non-monotonic
Pulldown typical data is non-monotonic
Power clamp Minimum data is non-monotonic
 and so on.

I want to know what is the reason for
this'non-monotonic' warning?  Do we need to be worry
about it?   Would it effect simulation ? How we can
expalin this warning?

Best regards,
Sherri
[email-masked]

__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

---

From: Al Davis <[email-masked]>
Date: Tue, 11 Apr 2000 01:16:26 -0700

On Mon, 10 Apr 2000, Shaghayegh Azgomi wrote:
> to 'non-monotonic' nature of some signals.  

If you think of the pullups, pulldowns, and clamps as being
like nonlinear resistors, a lot clears up.  "Non-monotonic"
means there is a negative resistance region.  In a real
circuit, negative resistance regions usually mean the
circuit has stability problems.  It will oscillate with
some loads.

In a sumulation, it means the same, but most simulators
don't handle this oscillation nicely.  Whether you actually
have a problem depends on how it is used in the circuit. 
If the device is loaded heavy enough, the negative
resistance in one device can be swamped out by another,
leaving a net positive resistance or "passive" circuit, in
which case you would not have a problem.

In Ibis models, this often comes up in the clamp region,
where the pullup current is swamped by the power clamp
current.  (and likewise for pulldown and ground clamp) 
Since both are essentially in parallel, it is impossible to
measure them separately, so the modelers often do an
arbitrary separation.  The result is that one has a
negative resistance region that is swamped by the other,
leaving a net positive resistance.  In this case, it is
usually not a problem, although it is still bad practice. 
It can be a problem with waveform generation, and some
loads.

One point on the v/i tables that is often forgotten .... 
The slope of a v/i characteristic is incremental
resistance.  If the device is a receiver, this is the load
that the driver and its wire sees.  If it is a driver, it
is the driving impedance of the line, and it serves to damp
reflections.  This resistance (derivative of the table) is
actually more important than the values directly stated by
the table.