Subject: What determines Vref & Rref, R_fixture & V_fixture?

From: Greg Haynes <[email-masked]>
Date: Thu, 22 Feb 2001 15:47:30 -0700

I'm starting to use s2ibis2 to create models
for a gate array library.  I don't understand
the significance of the Rref and Vref sub-parameters
under [Model].  We characterize propagation delays
for the I/O buffers in SPICE for a range of
capacitive loads on the output pad. It isn't
clear what values to use for Rref and Vref
(or Cref for that matter).

Similarly, how do I determine the values to 
use for R_fixture and V_fixture with
[Rising Waveform] and [Falling Waveform]?

-Greg Haynes
UTMC

---

From: Mike LaBonte <[email-masked]>
Date: Sat, 24 Feb 2001 15:11:05 -0500

Greg,

If the standard delay test for your part requires only
a capacitive load, then give C_ref but omit R_ref and
V_ref. Use the latter only if the buffer must be tested
with a pullup or pulldown resistor. You will have to
choose just one capacitive load to give as C_ref. But
this should be the load that was used to make measurements
that went into the timing info for the part.

R_fixture and V_fixture have been discussed before on this
list, but I think the best advice (from Stephen Peters)
was to consult the latest IBIS Cookbook linked from:

  http://www.eigroup.org/ibis/tools.htm

You will not find "R_fixture" in there, but Table 1 gives
recommended values for waveform fixtures.

Mike LaBonte