Subject: new ibischk3 V3.2.6

From: Syed Huq <[email-masked]>
Date: Tue, 9 Jan 2001 16:48:32 -0800 (PST)

I ran a model with the NEW ibischk3 ver3.2.6 and get this:

new version:
ERROR - Model XYZ_IO: The [Rising Waveform] 
      with [R_fixture]=50 Ohms and [V_fixture]=2.5V
      has TYP column DC endpoints of  0.41V and  2.50v, but
      an equivalent load applied to the model's I-V tables yields
      different voltages (-0.70V and  2.50V),

In the earlier version(V3.2.5),this would show up as a WARNING. Since now
it shows up as ERROR, the file fails.

old version:
WARNING - Model 'XYZ_IO': TYP AC Rising Endpoints ( 0.41V,  2.50V) not within 
          0.042V (2%) of (-0.70V,  2.50V) on VI curves for 50 Ohms to 2.5V

Why was this changed to ERROR ? 

Syed

---

From: Bob Ross <[email-masked]>
Date: Tue, 09 Jan 2001 17:25:35 -0800

Syed:

The new ibischk3 changed the Warning message to an Error
message when the mismatch exceeded 10%.  In your example,
the mismatch between 0.41 and -0.71 exceeds the 10% value
of the range (.21v).  There may exist a real problem that
needs to be examined.  This change is documented as BUG47:

  http://www.eda.org/pub/ibis/bugs/ibischk/bug47  

However, the -0.71 value is suspicious.  I have seen a
similar problem when some of the end point I-V currents are
extremely large (such as 1e20) and cause ibischk3 to
not properly converge to the correct DC endpoints.  You
might check this and try smaller values if such large
values exist.  Your model might actually be correct.

Bob Ross
Mentor Graphics