Subject: RE: new ibischk3 V3.2.6

From: [email-masked]
Date: Wed, 10 Jan 2001 11:00:56 -0600

Bob,
I'm not sure I agree with your statement that a model with end point I-V
currents that are "extremely large (such as 1e20)" "might actually be
correct" even if those data points are produced from a valid spice deck.
The purpose of a model is to reflect reality where possible and 1e20
amps????

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592

> -----Original Message-----
> From: Bob Ross [mailto:[email-masked]]
> Sent: Tuesday, January 09, 2001 7:26 PM
> To: Syed Huq
> Cc: [email-masked]
> Subject: Re: new ibischk3 V3.2.6
> 
> 
> Syed:
> 
> The new ibischk3 changed the Warning message to an Error
> message when the mismatch exceeded 10%.  In your example,
> the mismatch between 0.41 and -0.71 exceeds the 10% value
> of the range (.21v).  There may exist a real problem that
> needs to be examined.  This change is documented as BUG47:
> 
>   http://www.eda.org/pub/ibis/bugs/ibischk/bug47  
> 
> However, the -0.71 value is suspicious.  I have seen a
> similar problem when some of the end point I-V currents are
> extremely large (such as 1e20) and cause ibischk3 to
> not properly converge to the correct DC endpoints.  You
> might check this and try smaller values if such large
> values exist.  Your model might actually be correct.
> 
> Bob Ross
> Mentor Graphics
> 
> 
> Syed Huq wrote:
> > 
> > I ran a model with the NEW ibischk3 ver3.2.6 and get this:
> > 
> > new version:
> > ERROR - Model XYZ_IO: The [Rising Waveform]
> >       with [R_fixture]=50 Ohms and [V_fixture]=2.5V
> >       has TYP column DC endpoints of  0.41V and  2.50v, but
> >       an equivalent load applied to the model's I-V tables yields
> >       different voltages (-0.70V and  2.50V),
> > 
> > In the earlier version(V3.2.5),this would show up as a 
> WARNING. Since now
> > it shows up as ERROR, the file fails.
> > 
> > old version:
> > WARNING - Model 'XYZ_IO': TYP AC Rising Endpoints ( 0.41V,  
> 2.50V) not within
> >           0.042V (2%) of (-0.70V,  2.50V) on VI curves for 
> 50 Ohms to 2.5V
> > 
> > Why was this changed to ERROR ?
> > 
> > Syed
>

---

From: Bob Ross <[email-masked]>
Date: Wed, 10 Jan 2001 09:55:43 -0800

Aubrey:

I agree that a large current does not reflect reality.  It turns
out that if such a current exists at the ends of certain I-V
tables, the ibischk3 DC algorithm may not converge to the
correct set of DC values for a given Waveform table load - thus
causing an Error or Warning message in cases where the V-T
table amplitudes are correct and consistent with the I-V tables.

It turned out that Syed found a repeated voltage point at -0.71V
in one of the tables that caused the false I-V voltage point.
Removing one line in the table eliminated the Error message.

For the purposes of accurate simulation in the regions of
interest, extreme currents well outside of these regions of
interest theoretically should not be a problem because they
would never be encountered in practice.  However, such currents
might cause unexpected numerical problems.

The general statement is that all Warnings and Errors should
be examined, understood, and fixed, if possible.  Sometimes
they may be issued because of some unrelated serious problem.

Bob
Mentor Graphics