Subject: another new parser question ibischk3 V3.2.6

From: Syed Huq <[email-masked]>
Date: Tue, 9 Jan 2001 21:59:37 -0800 (PST)

Dear Gurus:

I am quite amazed by the amount of information the parser reports. 
Let me explain and I would like to understand the reasons too:

1) For every pin of this 456BGA package, it reports that the R_pin, L_pin
and C_pin are missing. I already know this simply by opening the IBIS file
and looking at the [Pin] list section.

Why do I need to scroll thru all these:
.
<parser output>
.
PIN:signal_name:<DQ[71]>
PIN:model_name:<XYZ_IO>
PIN:R_Pin:NOT SET
PIN:L_Pin:NOT SET
PIN:C_Pin:NOT SET
PIN:Pin:<A3>
PIN:signal_name:<VDDQ>
PIN:model_name:<POWER>
PIN:R_Pin:NOT SET
PIN:L_Pin:NOT SET
PIN:C_Pin:NOT SET
PIN:Pin:<A4>
PIN:signal_name:<DQ[67]>
PIN:model_name:<XYZ_IO>
PIN:R_Pin:NOT SET
PIN:L_Pin:NOT SET
PIN:C_Pin:NOT SET
.
.

2) Why does the parser output print all the V/I and V/T table data ?
.
Pulldown:
Voltage:-2.5, Typ:-0.12, Min:-0.09518, Max:-0.13
Voltage:-2.3, Typ:-0.12, Min:-0.09518, Max:-0.13
Voltage:-2.1, Typ:-0.12, Min:-0.09518, Max:-0.13
.
.

3) Why does the parser not show the value of Cref clearly defined in
the IBIS model ?

Parser:
Model Name:XYZ_TRI
Model_type:3-state
Polarity:Non-Inverting
Enable:Active-High
Vinl:NOT SET
Vinh:NOT SET
Vmeas:1.500000
Cref:0.000000	<------ ??

IBIS:
[Model]          XYZ_TRI
Model_type       3-state
Polarity         Non-Inverting
Enable           Active-High
Vmeas =   1.50V
Cref =  50.00pF	<------ It's there ..

4) Why does the parser not show the dT values for Ramp ?

<parser output>
dV/dt_r:Typ:1.150000/0.000000, Min:0.820000/0.000000, Max:1.280000/0.000000
dV/dt_f:Typ:1.250000/0.000000, Min:1.050000/0.000000, Max:1.360000/0.000000

IBIS model:
dV/dt_r          1.15/0.31n          0.82/0.37n          1.28/0.22n
dV/dt_f          1.25/0.22n          1.05/0.32n          1.36/0.15n

5) Is there a switch a user could use to minimize a lot of these messages ?

Regards,
Syed

---

From: Bob Ross <[email-masked]>
Date: Wed, 10 Jan 2001 13:17:39 -0800

Syed:

The problem is that the uploaded executables were uploaded with
the print flag for debugging turned on.  Replacement executables
with the PRINT switch turned off (at least for Unix) are
now uploaded at:

  http://www.eda.org/pub/ibis/ibischk3/

Bob Ross
Mentor Graphics