Subject: Differential output buffers

From: "Bill Clifford" <[email-masked]>
Date: Fri, 11 May 2001 13:40:21 -0700

Hello.  I'm trying to convert a SPICE model of a differential output buffer to an IBIS model.  I've been using s2ibis2 for other models, but this doesn't work for the differential.  What other tools are available that would be able to do this?  Or do I just have to process the SPICE data myself into the IBIS format?  Any information is greatly appreciated.  Thanks in advance.

Bill Clifford

---

From: Syed Huq <[email-masked]>
Date: Thu, 14 Jun 2001 15:11:15 -0700 (PDT)

Bill,

For a Diff receiver, once s2ibis2 creates a .spi for one leg of
the Rx input(PAD_N), you have to add the E element for the other leg
of the input(PAD_P)..manually..

This works fine for s2ibis2..

Syed

======================================================================
.<extracted from a input spi file generated by s2ibis2>
.
VOUTS2I PAD_N 0 DC 0
E1      PAD_P 0 POLY(2) VDD 0 PAD_N 0 0 1 -1 <--- Manually added this line
VCLMPS2I VDD1 0 DC 1.5
VGCLMPS2I VSS 0 DC 0
.TEMP 55
.OPTIONS INGOLD=2
.DC VOUTS2I -1.5 1.5 0.1
.PRINT DC I(VOUTS2I)
.END
=======================================================================

> From: "Bill Clifford" <[email-masked]>
> To: "Syed Huq" <[email-masked]>, <[email-masked]>
> 
> Syed,
> 
> <<snip snip.....>>
> .......
> But for the receiver I don't
> see how it can work, because s2ibis2 only gives one input pulse.
> 
> Thanks again for any help you can give me on this.  I hope these questions
> aren't too trivial, while I'm familiar with using IBIS models, I'm new to
> actually trying to make my own.  I really appreciate the assistance.
> 
> Regards,
> Bill Clifford
>