Subject: about IO_Buffer model's ac analysis

From: Wenqing Zhang <[email-masked]>
Date: Tue, 27 Mar 2001 21:12:07 +0800

hi, all,

I has a problem.
I think that ibs model was generated  by spice's dc analysis and
transient analysis,
so ibs model don't contain frequency response information.

now I want to realize ac analysis  to ibs model version3.2 in
Star-Hspice , but the simulation results
were very bad.
perhaps ibs model should contain frequency response information which
were generated with spice's
ac analysis.

do you think my idea? pls help me.

I am not a member of ibis-user, so pls email to:
[email-masked]

--
Thanks
Wenqing Zhang
______________End Forwarded Message_________
o:62834978-701
 Avant! Shanghai R&D Center,  16th Floor, SunTong InfoPort Plaza
 No.55, West Huaihai Road, Shanghai, 200030, P.R.China

---

From: "Reid, Chris" <[email-masked]>
Date: Tue, 27 Mar 2001 08:49:41 -0800

Wenqing,
 
You are right.  IBIS contains only static information in the IV curves.  The
dynamic information is only in the VT curves, which should be given for
load conditions similar to the environment the part will be used in.  This
still leaves IBIS with fundamentally a static model.  For most devices this
model seems to be accurate enough.  However, as you may know the
IBIS committee is in the process of defining IBIS-X, which will allow more
general modeling for difficult cases.
 
Chris Reid

-----Original Message-----
From: Wenqing Zhang [mailto:[email-masked]]
Sent: Tuesday, March 27, 2001 5:12 AM
To: [email-masked]
Subject: about IO_Buffer model's ac analysis

hi, all, 

I has a problem. 
I think that ibs model was generated  by spice's dc analysis and transient
analysis, 
so ibs model don't contain frequency response information. 

now I want to realize ac analysis  to ibs model version3.2 in Star-Hspice ,
but the simulation results 
were very bad. 
perhaps ibs model should contain frequency response information which were
generated with spice's 
ac analysis. 

-- 

Thanks

Wenqing Zhang

o:62834978-701

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Tue, 27 Mar 2001 09:03:45 -0800

Chris,
 
Don't forget about the C_comp...
 
Arpad
==================================
-----Original Message-----
From: Reid, Chris [mailto:[email-masked]]
Sent: Tuesday, March 27, 2001 8:50 AM
To: [email-masked]'; [email-masked]
Subject: RE: about IO_Buffer model's ac analysis

Wenqing,

Chris Reid

-----Original Message-----
From: Wenqing Zhang [mailto:[email-masked]]
Sent: Tuesday, March 27, 2001 5:12 AM
To: [email-masked]
Subject: about IO_Buffer model's ac analysis

hi, all, 

I has a problem. 

-- 

Thanks

Wenqing Zhang

o:62834978-701

---

From: "Ingraham, Andrew" <[email-masked]>
Date: Tue, 27 Mar 2001 12:14:02 -0500

> so ibs model don't contain frequency response information. 
Frequency response information IS available in an IBIS model for its package
parasitics, and I think that's what matters here.

When I do an AC analysis, I am interested in the transfer function FROM some
point TO some other point in the circuit.

The first thing you need to think about, is where might the FROM and TO
nodes be when you have IBIS models?

It makes sense to look at transfer functions that might involve the device's
pad node, either FROM (driving out) or TO (as an input).  The IBIS model
ought to have sufficient information about the device's package parasitics
(between the pad and the pin), for the simulator to be able to do an AC
analysis, within the accuracy limits of that package representation.

For a buffer driving out, you would replace the I/V curves with your AC
source.  For a receiver, find the slopes of the I/V curves where they
intercept the DC operating point, and include that resistance, along with
c_comp, as the "load" on the end of the package.

It doesn't make sense to try to analyze THROUGH a buffer that is represented
by an IBIS model.  The IBIS model of a buffer has no input, so there is no
such thing as a transfer function that includes that of the buffer itself.

> ----------
> From: 	Wenqing Zhang[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	Tue, 27 March 2001, 08:12
> To: 	[email-masked]
> now I want to realize ac analysis  to ibs model version3.2 in Star-Hspice
> , but the simulation results 
> were very bad.

---

From: "Ingraham, Andrew" <[email-masked]>
Date: Tue, 27 Mar 2001 12:19:59 -0500

Sorry, this was sent prematurely when a keyboard key got stuck.

 
> Frequency response information IS available in an IBIS model for its
> package parasitics, and I think that's what matters here.
> 
> When I do an AC analysis, I am interested in the transfer function FROM
> some point TO some other point in the circuit.
> 
> It makes sense to look at transfer functions that might involve the
> device's pad node, either FROM (driving out), or TO (as an input).  The
> IBIS model ought to have sufficient information about the device's package
> parasitics (between the pad and the pin), for the simulator to be able to
> do an AC analysis, within the accuracy limits of that package
> representation.
> 
> It doesn't make sense to try to analyze THROUGH a buffer that is
> represented by an IBIS model.  The IBIS model of a buffer has no input, so
> there is no such thing as a transfer function that includes that of the
> buffer itself.  (HSPICE's B-elements do have inputs, but they are just
> there to make the B-elements work.)
> 
Regards,
Andy

---

From: "Raymond, Keith" <[email-masked]>
Date: Tue, 27 Mar 2001 12:52:27 -0500

Why am I receiving this email.... what is it pertaining to?

Keith E. Raymond
Project Manager - Real Estate & Facilities Management
930 Commonwealth Avenue
Boston, MA  02215-1212
617/278-4043
617/593-6396 (Cellular)

> From:	Ingraham, Andrew [SMTP:[email-masked]]
> Sent:	Tuesday, March 27, 2001 12:14 PM
> To:	[email-masked]'
> Cc:	[email-masked]
> transient
> package
> some
> device's
> represented
> transient