Subject: RE: Package Parasitics

From: David Makihara <[email-masked]>
Date: Tue, 24 Apr 2001 16:17:05 -0700

Hello,

It's also possible to have pin specific parasitics which override the Package specific parasitics.

| ----- Cut from the IBIS 2.1 specification -----
[Pin]   signal_name     model_name      R_pin   L_pin   C_pin
|
  1     RAS0#           Buffer1         200.0m  5.0nH   2.0pF
  2     RAS1#           Buffer2         209.0m  NA      2.5pF
| ------------------------------------------------

Regards
Dave

David Makihara
Manager, System Interface Modelling
PMC-Sierra Inc.
105-8555 Baxter Place
Burnaby, BC V5A 4V7
tel:604-415-6000 ext 2422
fax:604-415-6206
e-mail:[email-masked]
website: http://www.pmc-sierra.com

> -----Original Message-----
> From: Kim Helliwell [mailto:[email-masked]]
> Sent: Tuesday, April 24, 2001 2:46 PM
> To: Jay Azurin
> Cc: [email-masked]
> Subject: Re: Package Parasitics
> 
> 
> Jay Azurin wrote:
> > 
> > Hello,
> > 
> > I am new to the IBIS game so pardon my simplistic question. 
> I would like
> > to know the meaning of the values in an IBIS model:
> > 
> > [Package]
> > 
> > |variable       typ     min     max
> > 
> > R_pkg           250m    200m    300m
> > 
> > L_pkg           8nH     5nH     12nH
> > 
> > C_pkg           0.7pF   0.56pF  1.2pF
> > |
> > 
> > I have found other models that have these values set to zero:
> > 
> > 
> > > > > [Package]
> > > > > R_pkg   0   0   0
> > > > > L_pkg   0   0   0
> > > > > C_pkg   0   0   0
> > 
> > Can you explain why these values are used, i.e. why the 
> model would be
> > realistic with no package parasitics?
> > 
> > Thanks for your help.
> > 
> > Best regards,
> > Jay Azurin
> > Motorola NetComm Applications
> 
> The package parasitics might be included in the pullup, 
> pulldown, and clamp
> curves in some way.  While this is permissible (I think), it 
> makes it much
> harder to re-use the pullup/pulldown/clamp curves for any 
> other package.  The
> whole point of separating these effects is to allow re-use of 
> the curves with
> different package models.
> -- 
> Kim Helliwell
> Senior CAE Engineer
> Acuson Corporation
> Phone: 650 694 5030  FAX: 650 943 7260
>

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Wed, 25 Apr 2001 08:02:01 -0700

Kim,

You cannot include the package parasitics in the pullup,
pulldown, and clamp IV curves.  The IV curves are DC
characteristics, and there is no way you can describe
AC effects with them, such as inductance, and capacitance.
The best you can do with these is the resistive losses in
the package.

The AC part may be described in the waveforms (Vt curves),
but that is not the best or most correct way to go about it.

Arpad Muranyi
Intel Corporation
=============================================================

-----Original Message-----
From: Kim Helliwell [mailto:[email-masked]]
Sent: Tuesday, April 24, 2001 2:46 PM
To: Jay Azurin
Cc: [email-masked]
Subject: Re: Package Parasitics

Jay Azurin wrote:
> 
> Hello,
> 
> I am new to the IBIS game so pardon my simplistic question. I would like
> Can you explain why these values are used, i.e. why the model would be

The package parasitics might be included in the pullup, pulldown, and clamp
curves in some way.  While this is permissible (I think), it makes it much
harder to re-use the pullup/pulldown/clamp curves for any other package.
The
whole point of separating these effects is to allow re-use of the curves
with
different package models.
-- 
Kim Helliwell
Senior CAE Engineer
Acuson Corporation
Phone: 650 694 5030  FAX: 650 943 7260

---

From: "Nelson, Kerry" <[email-masked]>
Date: Wed, 25 Apr 2001 09:08:55 -0700

In addition to other reasons...

We have often found this section of the IBIS model to be inadequate in
describing our CPU and chipset packages. For example, there is no way to
include a transmission line element of any sort. We usually use a Package
Model or an Electrical Board Description (EBD) to more accurately describe
the package. (Both are part of the IBIS specification.) In those cases we
will set R_pkg, L_pkg, and C_pkg to zero.

I hope that helps.
Kerry
Intel Corp.

 -----Original Message-----
From: 	Mark Bossard [mailto:[email-masked]] 
Sent:	Wednesday, April 25, 2001 6:10 AM
To:	Syed Huq
Cc:	[email-masked]; [email-masked]
Subject:	Re: Package Parasitics

I agree with Syed... 

The ASIC house I work in does supply ibis models to our customers that
are simply an ibis model for one I/O buffer.  They are many times left
without package RLC so they can be filled in depending on the package
that is used.  

-Mark Bossard
Atmel Chesapeake Design Center

Syed Huq wrote:
> 
> One reason could be is that a ASIC vendor is simply creating "buffer only"
> models without any package parasitics. Once the ASIC is defined(with
package)
> then you create the full IBIS model with all the individual buffers along
> with the package parameters..
> 
> For a commercially available component, it does not make sense to have
> a model without the package parasitics.
> 
> Syed
> Cisco Systems, Inc
> 
> >
> > > |
> > >

-- 

========================================================================
| Mark Bossard                     |                                   |
| Direct Phone: (410) 872-9267     | Atmel Corporation                 |
| Main Phone:   (410) 312-4400     | Chesapeake Design Center          |
| Fax:          (410) 312-4424     | 6740 Alexander Bell Dr, Suite 100 |
| Email:        [email-masked] | Columbia, MD 21046                |
========================================================================