Subject: Re: zero risetime in the IBIS model

From: [email-masked]
Date: Wed, 4 Apr 2001 10:18:26 -0400

Jason,

     I'm not sure what translator you are using but the HSPICE translator
will by default use ramp data for determining switching characteristics in
DC and transient analysis.  You can specify that the translator use the
rising and falling waveform data instead.  See Chapter 18 of the Avanti
HSPICE User's Manual.

Adam Tambone
Fairchild Semiconductor

Hi everyone:
I am trying to verify a IBIS model which consists of a zero rise time
for the driver:
| variable       typ                 min                 max
dV/dt_r            0/0                 0/0                  0/0
dV/dt_f          2.0448/0.4029n      1.8546/0.4176n      2.1792/0.4102n
R_load = 50.0000

My question is :does anyone know how the IBIS translator going to handle
this situation??
thanks alot
Best Regards
Jason Leung

---

From: "Dunbar, Tony" <[email-masked]>
Date: Wed, 4 Apr 2001 08:33:56 -0700

Jason,

One subtle point here is whether, or not, the [Model] that has this dV/dt_r
parameter also has waveform tables. If it does, the [Ramp] parameters should
be ignored by the simulator, anyway.

Neverthless, as has been suggested already, I would also strongly encourage
you to throw the model back at the vendor that supplied it.

This sort of clumsy or outright bad modeling continues in part, I believe,
because we, as consumers, tweak this and change that without letting our
suppliers know they are producing garbage. Sorry to rant on, but this is a
pet subject of mine because it wastes too much of my time and WAY TOO MUCH
of my customers' time. If it was a part for my car brakes that didn't quite
fit, what would I do? Closer to the point, if it was a VHDL model that
wasn't quite right and the ASIC didn't work, what would you and your
management do.

Signed,
Mr. Angry
(Tony Angry, that is!)

-----Original Message-----
From: Jason Leung [mailto:[email-masked]]
Sent: Wednesday, April 04, 2001 8:59 AM
To: [email-masked]
Subject: Re: zero risetime in the IBIS model

Hi everyone:

---

From: [email-masked]
Date: Wed, 4 Apr 2001 12:11:46 -0400

Jason,

     If  V/t data is included in the IBIS datasheet a solution might be to
determine the slope of the line defined by the 20% and 80% points of the
V/t waveform and use this value for the ramp parameter of interest.  As
previously mentioned you should not have to do this 'fix'.

Adam Tambone

---

From: [email-masked]
Date: Wed, 4 Apr 2001 13:44:57 -0500

Jason,
Yes, I have seen a simulator go nuts and produce a very strange meaningless
waveform.  Problem went away when the [Ramp] data was corrected.

ramp data matching the VT data means that they should agree, both come from
time-based data, perhaps even the same load.

From a purist point of view, I'm not an IBIS expert and I don't want to
change the data my supplier gives me.  But if your boss wants results NOW
with your best GUESS, as another suggested, you can build your own Ramp data
from the V/T data.  Use the Rising Waveform for the dV/dt_r (R_fixture to
ground if there are two).  Use the Falling Waveform for the dV/dt_f
(R_fixture to V_fixtuer if there are two).
dV=0.6*(Vmax-Vmin)
dt_x is the difference in time between the 20% and 80% voltage points.

Good Luck!

Aubrey Sparkman
Signal Integrity
[email-masked]
(512) 723-3592

> Sent: Wednesday, April 04, 2001 10:36 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Hi Aubrey Sparkman:
> So even though the translator doesn't complain about the zero 
> rise time in the
> driver model, the translator will go "nuts" ehh? So the 
> waveform come after
> the simulation will have no meaning ehh?
> what do you mean by" ramp data match the VT data"?
> thanks alot
> Jason Leung
> 
> 
> > Jason,
> > Even if your simulator's translator doesn't complain, your 
> simulator may go
> > nuts and give VERY "interesting" results.  Go back to your 
> supplier and
> > insist that the ramp data match the VT data.
> >
> > Aubrey Sparkman
> > Signal Integrity
> > [email-masked]
> > (512) 723-3592
> >
> > > From: [email-masked]
> > > [mailto:[email-masked]]
> > > Sent: Wednesday, April 04, 2001 9:18 AM
> > > To: [email-masked]