Subject: RE: arbitrary length in ebd files?

From: "Dunbar, Tony" <[email-masked]>
Date: Fri, 13 Apr 2001 08:42:13 -0700

Hi Kris,

It's not that intuitive, so don't feel bad for missing this.
The "scaling factor" is in the L and C values for the path.
If you look at the following (fairly well documented) example,
you can see/derive from the scale of the L and C values that
sqrt(LC) gives an answer of delay per unit length in s/m
(i.e. seconds per meter). But I also need the scale of the
L and C values to be correct to obtain the correct Zo=sqrt(L/C).
So I then use a Len value to specify the length of the segment.

In this example, one of segment my lengths needs to be 520mil
but I'm working in meters.

Hope this helps!

Regards,
Tony

[Path Description] XYZ
Pin B18
| 1. Path 1
Len = 0 L = 168.00e-12 C = 0.00 R = 0.006 /
| 2. Via
Len = 0 L = 570.00e-12 C = 0.00 R = 0.0021 /
| 3. Seg. #2 Use slow = 520mil, HighZ 50.3ohm.
Len = 0.013205 L = 3.591440e-07 C = 1.419672e-10 R = 6.931417e01 /
| 4. Seg. #1 Use slow = 80mil, HighZ 42.46ohm.
Len = 0.002032 L = 3.072277e-07 C = 1.704113e-10 R = 5.862795e01 /
| 5. Die bump
Len = 0 L = 20.00e-12 C = 0.0 R = 0.002 /
Node U1.B18

-----Original Message-----
From: Kris Young [mailto:[email-masked]]
Sent: Friday, April 13, 2001 9:43 AM
To: [email-masked]
Subject: arbitrary length in ebd files?

Hello:

I have a question about path descriptions in electronic board description
(ebd) files (IBIS 3.2).  I'm wondering how to get an accurate simulation of
signal reflections when the path length is given in terms of an arbitrary
length.  It seems like running an accurate SI simulation will require an
estimate as to what factor to scale the path lengths by to get them to match
the device specified by the ebd.  Why isn't there a way to specify a scale
factor in the ebd file?  Am I missing something?

Thanks in advance for your assistance.

Regards,

Kris Young
Phase IV Systems, Inc.
Huntsville, AL

---

From: "Reid, Chris" <[email-masked]>
Date: Fri, 13 Apr 2001 08:54:44 -0700

Hello,

There is no specified units for the length of the
transmission lines in EBD because it is not needed.
Given any particular specification of the transmission
line properties it does not matter wether you take the
units to be inches, feet, meeters, or miles.  The
answer will always be the same.

The reason for this is that L and C are given per
unit length.  L is Henrys per unit length.  C is
Farads per unit length.  So, the impedance of the
line is sqrt(L/C) and the length unit cancels in
the ratio.  The delay per unit length is sqrt(LC)
so the total delay is sqrt(LC)*Len, where again the
length units cancel.

Thus the simulator does not need to know the scale
to get a unique answer.  The length unit just needs
to be consistent.

Chris

-----Original Message-----
From: Dunbar, Tony [mailto:tony_dunbar]
Sent: Friday, April 13, 2001 8:42 AM
To: [email-masked]
Subject: RE: arbitrary length in ebd files?

Hi Kris,

Hope this helps!

Regards,
Tony

[Path Description] XYZ
Pin B18
| 1. Path 1

-----Original Message-----
From: Kris Young [mailto:[email-masked]]
Sent: Friday, April 13, 2001 9:43 AM
To: [email-masked]
Subject: arbitrary length in ebd files?

Hello:

Regards,

Kris Young
Phase IV Systems, Inc.
Huntsville, AL