Subject: RE: output impedance of a driver

From: "Dagostino, Tom" <[email-masked]>
Date: Mon, 9 Apr 2001 09:48:04 -0700

If you do both you will find there is usually a difference in pullup and
pulldown impedance.  Makes the design job more interesting.  What trade-off
are you going to make?

Tom Dagostino
IBIS and Tau Modeling Manager
SDD
Mentor Graphics Corp.
503-685-1613
[email-masked]

-----Original Message-----
From: Jason Leung [mailto:[email-masked]]
Sent: Monday, April 09, 2001 9:41 AM
To: Scott McMorrow
Cc: [email-masked]
Subject: Re: output impedance of a driver

Hi Scott McMorrow :
Thanks very much for your advice!
So if we wanted to find the output impedance for the driver ,we just have to

go to 1V row and then read off the corresponding current value eh?
Should I do that on the Pull up curve or the pull down curve?

thanks
Regards
Jason Leung

> Jason,
>
> If the ibis model has been extracted correctly, then the Ramp data
> will tell you what the saturated output impedance is.
>
> The IBIS V/I curves give you the impedance of an output buffer
> at any voltage.  I usually use 1 volts as a good place to measure
> impedance, since it is in the linear portion of the buffer curve.
> For the pullup and pulldown curve, go to the 1V row and read
> off the current.  Since R=V/I, the output channel resistance can
> be calculated.
>
> For example, if at 1 Volt the current is 35mA, then the
> output impedance is 28.57 ohms.
>
> regards,
>
> scott
>
> --
> Scott McMorrow
> Principal Engineer
> SiQual, Signal Quality Engineering
> 18735 SW Boones Ferry Road
> Tualatin, OR  97062-3090
> (503) 885-1231
> http://www.siqual.com
>
> Jason Leung wrote:
>
> > Hi all:
> > Morning!
> > I am trying to obtain the output impedance of a driver, so that I can
> > match the driver with a transmission line and proper termination.
> > The way that I have tried is I used the IBIS model and then translate
> > the model into QUAD model, so that I can used the XNS to observe their
> > rising and falling waveform. Moreover I am trying to find its output
> > impedance in XNS.
> > My question is : Does anyone ever try finding the output impedance of a
> > driver? AND how did you achieve that?
> >
> > Thanks very much for your comment!
> > Jason leung

---

From: "Muranyi, Arpad" <[email-masked]>
Date: Mon, 9 Apr 2001 11:56:16 -0700

You have to add up all of the curves which are ON and then
calculate the impedance. This may consist of a pulldown
plus GND_clamp, plus Vcc_clamp if it is driving low, or
pullup, and the same two clamps when it is driving high.

I hope this helps,

Arpad
========================================================

-----Original Message-----
From: Jason Leung [mailto:[email-masked]]
Sent: Monday, April 09, 2001 11:17 AM
To: Muranyi, Arpad
Cc: [email-masked]
Subject: Re: output impedance of a driver

Hi Muranyi, Arpad:
Thanks for your advice!
one more question I would like to ask you: because I have been asked from
my colleague to use
XTK/XNS to find the output impedance of the driver, I know that in the
spawn -> VI viewer ,
we can import the corresponding .wvi curve to observe the waveform.
Among all those waveform, you can just pick on one waveform, and then do a

delta x and delta y function, then you will be able to find the impedance.

However, there are so many curves I have to choose(shunt and high, shunt
and low and many
many more) , do u know which one I have to choose for an accurate
approximation of the
output impedance of the driver .
The whole point here is , since I know I can find the output impedance of
the driver in the IBIS model
I also wanted to try and find the output impedance of the driver in the
XNS (QUAD) model ,so that
I am able to compare what we have before the simulation and after the
simulation( i.e. how the XTK/XNS
interpret the output impedance of that driver ).

thanks alot
Jason Leung

> Jason,
>
> The DC impedance can be found by dividing V/I on the IV curve of
> the buffer.  You will find that you get a different value at
> practically any of the voltages due to the non linear shape of
> the IV curve.  Plus, the process variation of a chip can give
> you a variation on the order of 2-3x.  So finding the impedance
> and matching the T-line to it is like shooting at a moving target.
>
> The reason I said DC impedance above is because the capacitive
> components of the buffer will also alter the impedance of the
> buffer a higher frequencies.
>
> Arpad Muranyi
> Intel Corporation
> ================================================================
>
> Sent: Monday, April 09, 2001 6:14 AM
> To: [email-masked]

---

From: "Dagostino, Tom" <[email-masked]>
Date: Mon, 9 Apr 2001 09:48:04 -0700

Tom Dagostino

-----Original Message-----
From: Jason Leung [mailto:[email-masked]]
Sent: Monday, April 09, 2001 9:41 AM
To: Scott McMorrow
Cc: [email-masked]
Subject: Re: output impedance of a driver

Hi Scott McMorrow :

thanks
Regards
Jason Leung

---

From: "Jason Leung" <[email-masked]>
Date: Tue, 10 Apr 2001 14:09:42 -0400

Hi Michael:
Thanks for showing me the way to find the output impedance!! It really helps me.

Now, I would like to show you some interesting results:
Right now I am working on LVT162244 from TI and I am trying to measure the
output impedance of the driver .I have used the method you show me to do (i.e.
-motive and I am able to get the output impedance for the high state which is
36.5 ohms and output impedance for the low
state which is 29.81 ohms) .
The schematic  that I have used for testing is :

where I have got a driver ->tline of 0.01 inch 60 ohms , series resistance
->tline of 10 inch 60 ohms-> and receiver.

Since I wanted to compare the real value for the  output impedance of the driver
, I have tried different values for the series termination.
The calculations are like these: I assumed  the output impedance of the driver
is in high state , so RH=36.5 , in order to match that with the tline,
I have to use 23.5 ohms for the series termination, and I do the same thing by
assuming the output impedance of the driver is in low state, then
the series termination is 30.19 ohms . The third case is (RH+RL)/2 =33.2 so the
series termination 60-33.2 =26.8 ohms.the last case is when the series
termination is 60 ohms

and you can see from the output waveform :

here we see that the red curve is with series termination of 23.5 ohms , and the
one below the red curve is when series termination of 26.8 ohms
and the third one is when  series termination of 30.15 ohms and finally series
termination of 60 ohms.
This is interesting to us because at the red curve where series termination is
23.5 ohms the rising edge is ok , but the falling edge is not ok .
When the series termination is 26.845 ohms , the  rising edge is not ok , but
the falling edge is  ok. Also when the series termination is 30.19 ohms , the
rising edge is not ok , but the falling edge is  ok.Finally for the series
termination is 60 ohms , the  rising edge is not ok , but the falling edge is
not ok.
My question is how do we determine the output impedance for the driver in this
case, whether we should use RH , RL or (RH+RL)/2 . ???
Please feel free to comment.
Thanks
Jason Leung

Michael Mayer wrote:

> You can use ibis2xtk. One of the options generates a BLAST (formerly MOTIVE)
> model. This is a simple linear model that includes the high and low
> impedance. Try ibis2xtk -motive
>
> It will generate a .src file. At the bottom of the file will be a DEFDRIVER
> statement for each buffer. RL and RH are the low and high impedances.
>
> =======================================================================
> Mike Mayer                                          [email-masked]
> Applications Engineer                             Office: (608)523-1960
> Innoveda, Inc                                     Mobile: (608)575-2732
>
> Sent: Monday, April 09, 2001 8:14 AM
> To: [email-masked]