Subject: Monotonicity

From: FITZPATRICK John <[email-masked]>
Date: Thu, 05 Sep 1996 10:35:03 +0200

Hello all,

I believe there were many discussions on monotonicity before
I joined the IBIS mailing lists. Perhaps someone would be kind
enough to help me with this issue.

We are currently trying to encourage a semiconductor supplier 
to provide us with IBIS data for a set of components. Their response
is lukewarm. An argument used is that because the buffers have
non-monotonic curves, IBIS models cannot be created.

On reading IBIS 2.1, this appears to be true. An example of an
output curve is a follows:

                 |        *
            Vdd  + 
                 |        *                   Pulldown
                 | 
                 |        *
   Vout          |         
                 |        *
                 |                *                 
          0.5Vdd +                                *      
                 |                                     *
                 |                                   *
                 |                           *
                 |                    * 
                 |             *
                 |       *
                 | *
                --------------------------------------------------
                                 Iout

Has anybody else had to deal with this issue?

Why is their a restriction put on monotonicity? Is it because
some simulators cannot handle this case?

In 2.1 it states that most simulators filter non-monotonic data.
Does this mean that it's OK to feed non-monotonic IBIS models to
most simulators i.e. it will generate results based on filtered
data?

I've looked at the FAQ, but this seems to say that the only reason for
non-monotonic behaviour is due to the way clamping and active
curves are generated!

Any feedback appreciated,

Regards,
John

-- 
John Fitzpatrick   <[email-masked]>    
Alcatel CIT, 4 rue de Broglie, 22304 Lannion, France
Tel: (+33)96.04.79.33  Fax: (+33)96.04.85.09

---

From: John Brennan <[email-masked]>
Date: Thu, 05 Sep 1996 08:43:15 -0400

John,

The curve you draw looks like OCDs I have dealt with.

This type of non-monoticity was due to slew rate control schemes
(not clamping). Although a clamp would add another monotonic point to
this curve since the current would take off exponentailly as the output
got above Vdd + diode drop for simple diode clamp.

The feedback I got from the IBIS group was that this does not preclude
the driver data from being formatted in IBIS, but it is up to the
simulator tool to handle the data correctly. Some vendors claimed to be
able to handle these types of drivers. 

Understand what is meant by "filtering", some tools just changed the
values of the curve to make them monotonic, which gave poor correlation
reuslts to SPICE on certain loads(this was in IBIS 1.1 time frame).

John Brennan

------------------ Referenced E-Mail ----------------------------

Date:    Thu, 05 Sep 1996 10:35:03 +0200
To:      [email-masked]
From:    FITZPATRICK John <[email-masked]>
Subject: Monotonicity 
Sender:  [email-masked]
Message-Id: <[email-masked]>
Organization: Alcatel Telecom, 22304 Lannion, France
X-Mailer: Mozilla 3.0 (X11; I; SunOS 4.1.3_U1 sun4c)
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Hello all,

                 |        *
            Vdd  + 
                 |        *                   Pulldown
                 | 
                 |        *
   Vout          |         
                 |        *
                 |                *                 
          0.5Vdd +                                *      
                 |                                     *
                 |                                   *
                 |                           *
                 |                    * 
                 |             *
                 |       *
                 | *

Regards,
John