Subject: s2ibis and spice netlist file

From: [email-masked] (Syed Huq)
Date: Thu, 5 Sep 96 17:29:06 PDT

----------
X-Sun-Data-Type: text
X-Sun-Data-Description: text
X-Sun-Data-Name: text
X-Sun-Content-Lines: 20

Hi,

I am trying to model an input called BTI(See plot.ps attached).
In my spice netlist file, I have sub-ckt calls like below:

XI1 BTI 0 N0 0 G3 SUB5 
XI0 BTI OUT 0 G3 SUB6 

It seems that since these sub-ckt calls mention output 
node(N0 & OUT), I run into various errors saying certain
pmos nmos not present. G3 is Power.

I do have all pmos nmos models in my process files

Is this a wrong way of modeling an input ? Do I need to remove
ALL reference to output nodes when modeling an Input ?

Regards,
Syed.
National Semiconductor Corp.
----------
X-Sun-Data-Type: postscript-file
X-Sun-Data-Description: postscript-file
X-Sun-Data-Name: plot.ps
X-Sun-Content-Lines: 2251

%!PS-Adobe-3.0
%%DocumentFonts: Helvetica Times-Roman Courier
%%Creator: Cadence Design Systems
%%EndComments
%%BeginProlog
%
% Start of Cadence ps.prologue -- Version 5.0.0
% Adobe Postscript Level 2 Color Version.  
%******************************************************************************
% Graphics initialization routine.
%
/gis  { 
  save
  mark
  newpath

%
% Scale postscripts 72 dpi divided by the plotter resolution set in pap.
%
  72 resolution div
  dup
  scale

%
% Move the origin of the plot up and to the right so the plotters margin
% is observed.
%
  offsetX offsetY translate

  /stippleArray 10 array def
    stippleArray
     dup    0  <FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF
                FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF> put
     dup    1  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    2  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    3  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    4  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    5  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    6  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    7  <00000000000000000000000000000000
                00000000000000000000000000000000> put
     dup    8  <08080404020201018080404020201010
		08080404020201018080404020201010> put
            9  <08081414222241418080414122221414
                08081414222241418080414122221414> put

  /newFont 10 dict def 
  newFont begin

    /FontType 3 def
    /FontMatrix [1 0 0 1 0 0] def
    /FontBBox [0 0 1 1] def

    /Encoding 256 array def
    0 1 255 {Encoding exch /.notdef put} for
    Encoding
      dup 48 0  put
      dup 49 1  put
      dup 50 2  put
      dup 51 3  put
      dup 52 4  put
      dup 53 5  put
      dup 54 6  put
      dup 55 7  put
      dup 56 8  put
          57 9  put

    /BuildChar {
        /char exch def
        /fontdict exch def
        /charname fontdict /Encoding get char get def

         1 0 setcharwidth

          16 16 true
          [16 0 0 -16 -.5 15.50]
           stippleArray charname 1 getinterval cvx
          imagemask
    } def

  end
  /StippleFont newFont definefont 66 scalefont setfont
  /fillChar 0 def

  /ellipsedict 8 dict def
  ellipsedict /mtrx matrix put

  /xformdict 6 dict def
  xformdict /xformmtrx matrix put

  /color     0 def

  /lineRed   0 def
  /lineGreen 0 def
  /lineBlue  0 def

  /fillRed   0 def
  /fillGreen 0 def
  /fillBlue  0 def

  /hatchSet  0 def

} bind def
%******************************************************************************
% Paper call.  Sets resolution page height and page width.
%
/pap {
    /resolution exch def
    /pageHeight exch def
    /pageWidth exch def
    /offsetY exch def
    /offsetX exch def
    /papx pageWidth offsetX offsetX add add 72 mul resolution idiv def
    /papy pageHeight offsetY offsetY add add 72 mul resolution idiv def
%    <</PageSize [papx papy] /ImagingBBox null>> setpagedevice

  } bind def

%******************************************************************************
% Plot is done.
%
/gfs  {
    showpage 
    cleartomark
    restore
  } bind def

%******************************************************************************
% Next Page sequence.
%
/nxp  {

    showpage
    newpath

%
% Scale postscripts 72 dpi divided by the plotter resolution set in pap.
%
    72 resolution div
    dup
    scale
%
% Move the origin of the plot up and to the right so the plotters margin
% is observed.
%
    offsetX offsetY translate

  } bind def

%******************************************************************************
% Rotate Plot Sequence.
%
/rotp  {
  pageWidth 0  translate  %% This moves lower left of plot to 
                          %% lower right of page.

  90 rotate    %% rotate plot 90 degs. 
} bind def
%******************************************************************************
% Clipping Window
%
/clwin  {
    initclip
    /y2 exch def
    /x2 exch def
    /y1 exch def
    /x1 exch def
    newpath 
    x1 y1 moveto
    x2 y1 lineto 
    x2 y2 lineto 
    x1 y2 lineto 
    closepath
    clip
} bind def
%******************************************************************************
% These to routines keep track of the bounding box of the shape.
% This information is used when filling the drawn shape.
%
/bblineto {
  dup dup
  /cury exch def
  miny lt {/miny exch def}
    {dup maxy gt { /maxy exch def }
           {pop } ifelse } ifelse
  dup dup
  minx lt {/minx exch def}
    {dup maxx gt { /maxx exch def }
           { pop } ifelse } ifelse
  cury lineto
} bind def

/bbmoveto {
  dup dup
  /miny exch def /maxy exch def /cury exch def
  dup dup
  /minx exch def /maxx exch def
  cury moveto
} bind def
%******************************************************************************
% Internal ellipical arc routine.
%    x y xradius yradius startangle endangle ellipse
%
/ellipse 
  {
    /endangle exch def
    /startangle exch def
    /yrad exch def
    /xrad exch def
    /y exch def
    /x exch def

    startangle endangle gt {
      save
      /tmpangle startangle def
      /startangle endangle def
      /endangle tmpangle def
      restore
    } if

    ellipsedict begin
      /savematrix mtrx currentmatrix def
      x y translate
      xrad yrad scale
      0 0 1 startangle endangle arc
      savematrix setmatrix
    end
  } bind def
%******************************************************************************
% Resident Font Scale Sequence
%    x y rfss
%
/rfss  {
    4 2 roll
    dup
    3 div
    add
    scalefont 
    setfont
    0 color ne {setLineColor}
               { 0 setgray } ifelse
  } bind def
%******************************************************************************
% Resident Font End
%    
%
/rfe
{
/width exch def
5 1 roll
moveto
    
xformdict begin
/savematrix xformmtrx currentmatrix def

exch 				% rotate mirror to mirror rotate
matrix rotate concat		% add rotation to current transform matrix
dup 1 eq
	{pop 1 -1}		% X mirror

	{2 eq
		{-1 1}		% Y mirror
		{1 1}		% No mirror
	ifelse}
ifelse matrix scale concat	% add mirror to current transform matrix

dup				% duplicate (string)
length				% replace one of the strings with its length
dup 0 ne
{
	3 -1 roll		% move fixed width flag to top of stack
	0 eq
	{			% if flag is false (0) do old string handling
		/numChr exch def
		dup stringwidth	%stack  wy,wx,(string)
		pop
		width
		exch sub	%stack  xdiff,ydiff,(string)

		cvi
		numChr idiv	%stack  xspace,ydiff,(string)

		/xoff exch def

		{		% this is the positioning  function for kshow
			pop pop
			xoff
			0
			rmoveto
		}

		exch
		kshow
	}

	{			% if flag is true (not 0) just show string
		pop show
	}
	ifelse
}

{
	pop pop pop pop
}
ifelse
      savematrix setmatrix
    end
  } bind def
%******************************************************************************
% Draw line sequence.
%
/dls  {
  newpath
  moveto
  rlineto
  gsave
  0 color ne { setLineColor }
             { 0 setgray } ifelse
  stroke
  grestore
} bind def
%******************************************************************************
% Draw line to.
%
/dlt  {
  newpath
  gsave
  0 color ne { setLineColor }
             { 0 setgray } ifelse
  moveto 
} bind def
%******************************************************************************
%
/dslt  { 
  newpath
  gsave
  0 color ne { setLineColor }
             { 0 setgray } ifelse
  moveto 
} bind def
%******************************************************************************
%
/dlv  { 
  rlineto 
} bind def
%******************************************************************************
%
/dle  { 
  stroke
  grestore
} bind def
%******************************************************************************
% Move to.
/mps {
  newpath
  moveto 
} bind def
%******************************************************************************
%
% Draw Box Unfilled
%    x1 y1 x2 y2 dbu
%
/dbu  { 
    0 color ne { setLineColor } if
    newpath
    moveto
    dup 0 rlineto
    0 3 -1 roll
    rlineto
    neg 0 rlineto
    closepath
    stroke
  } bind def
%******************************************************************************
%
% Draw Box Filled
%    x1 y1 x2 y2 dbf
%
/dbf  { 
    /y2 exch def
    /x2 exch def
    /y1 exch def
    /x1 exch def
    newpath
    x1 y1 bbmoveto
    x2 y1 bblineto
    x2 y2 bblineto
    x1 y2 bblineto
    closepath
    gsave 
    0 color ne { setFillColor } if
    clip fillpath grestore
  } bind def
%******************************************************************************
% Draw Box Solid
%    x1 y1 x2 y2 dsb
%
/dbs  {
    /y2 exch def
    /x2 exch def
    /y1 exch def
    /x1 exch def
    newpath 
    x1 y1 moveto
    x2 y1 lineto 
    x2 y2 lineto 
    x1 y2 lineto 
    closepath
    gsave
    0 color ne { setFillColor }
               { 0 setgray } ifelse
    fill 
    stroke 
    grestore
  } bind def

%******************************************************************************
% Draw Polygon Begin
%    x y dpb
%
/dpb  { 
    newpath bbmoveto
  } bind def

%******************************************************************************
% Draw Polygon Unfilled
%    x y dpu
%
/dpu  { 
      closepath
      gsave
      0 color ne { setLineColor } if
      stroke
      grestore
   } bind def

%******************************************************************************
% Draw Polygon Filled
%    x y dpf
%
/dpf  { 
    closepath
    gsave
    0 color ne { setFillColor } if
    clip fillpath grestore
  } bind def

%******************************************************************************
% Draw Polygon Solid
%    x y dps
%
/dps  { 
    closepath
    gsave 
    0 color ne { setFillColor }
               { 0 setgray } ifelse
    fill stroke
    grestore
  } bind def

%******************************************************************************
% Draw Polygon Vertex
%    x y dpv
%
/dpv  { 
    bblineto
  } bind def

%******************************************************************************
% Draw Circle Unfilled
%    x y radius dcu
%
/dcu  { 
    /radius exch def
    /y exch def
    /x exch def

    newpath 
    x y radius radius 0 360 ellipse
    gsave
    0 color ne { setLineColor } if
    stroke
    grestore
  } bind def
%******************************************************************************
% Draw Circle Filled
%    x y radius dcs
%
/dcf  { 
    /radius exch def
    /y exch def
    /x exch def
    /minx x radius sub def
    /miny y radius sub def
    /maxx x radius add def
    /maxy y radius add def

    newpath 
    x y radius radius 0 360 ellipse
    gsave
    0 color ne { setFillColor } if
    clip fillpath
    grestore
  } bind def

%******************************************************************************
% Draw Circle Solid
%    x y radius dcs
%
/dcs  { 
    /radius exch def
    /y exch def
    /x exch def

          newpath 
    x y radius radius 0 360 ellipse
    gsave
    0 color ne { setFillColor }
               { 0 setgray } ifelse
    fill stroke
    grestore
  } bind def
%******************************************************************************
% Draw Ellipse Unfilled
%    x y xradius yradius deu
%
/delu  { 
    /yradius exch def
    /xradius exch def
    /y exch def
    /x exch def
    
    newpath
    x y xradius yradius 0 360 ellipse 
    gsave
    0 color ne { setLineColor } if
    stroke
    grestore
  } bind def
%******************************************************************************
% Draw Ellipse Filled
%    x y xradius yradius def
%
/delf  { 
    /yradius exch def
    /xradius exch def
    /y exch def
    /x exch def
    /minx x xradius sub def
    /miny y yradius sub def
    /maxx x xradius add def
    /maxy y yradius add def
    
    newpath
    x y xradius yradius 0 360 ellipse 
    gsave
    0 color ne { setFillColor } if
    clip fillpath
    grestore
  } bind def

%******************************************************************************
% Draw Ellipse Solid
%    x y xradius yradius des
%
/dels  { 
    /yradius exch def
    /xradius exch def
    /y exch def
    /x exch def

    newpath
    x y xradius yradius 0 360 ellipse 
    gsave
    0 color ne { setFillColor }
               { 0 setgray } ifelse

    fill
    stroke 
    grestore 
  } bind def
%******************************************************************************
% Draw Arc Unfilled
%    x y xradius yradius startangle endangle das
%
/dau  { newpath ellipse 
        gsave
        0 color ne { setLineColor } if
        stroke 
        grestore
      } bind def
%******************************************************************************
% Line Define Code.
%
/setlinedash {
    1 index length 11 gt
    {exch dup length 11 sub 11 getinterval exch } if
    setdash
  } bind def

/lpb    { 
    pop
    [
    /offset 0 def
    /offcount 0 def
    /oncount 0 def
  } bind def

/lpon  { 
    /oncount exch def
    pop
    oncount
  } bind def

/lpoff  { 
    /offcount exch def
    pop
    oncount 0 eq
    {/offset offcount def }
    { offcount } ifelse
  } bind def

/lpe  { 
    /linewidth exch def
    pop
    offset 0 ne
    { offset } if ] 0 setlinedash
    linewidth dup 1 eq {pop 0} if setlinewidth
  } bind def

/sls    { pop } bind def

/ssls  { [] 0 setdash 
          1 setlinewidth
        } bind def

%******************************************************************************
% Fill pattern define code.
%
/fillpath  {    
    0 color ne { setFillColor } if
    /str 1 string def
    /minx minx 66 div
    truncate 66 mul def
    /miny miny 66 div
    truncate 66 mul def

          /fillLine maxx minx sub cvi 66 idiv 1 add string def

          0 1 fillLine length 1 sub {
            fillLine exch fillChar str cvs cvi 48 add put
          } for

          minx
          miny 66 maxy
            { exch dup 3 -1 roll moveto fillLine show
          } for pop

    hatchSet 1 eq {stroke} if
} bind def

/fds  { pop /currchar 30 def} bind def
/fdf   {
    exch
    /char exch def
    /stipple stippleArray char get def
    stipple exch currchar
    exch putinterval
    stippleArray char stipple put
    /currchar currchar 2 sub def
  } bind def
/fde  { 
    pop
  } bind def
/sfp  {
    /fillChar exch def
    /hatchSet 0 def
    fillChar 8 ge {/hatchSet 1 def} if
    /StippleFont findfont 66 scalefont setfont
  } bind def
/setLineColor {
  lineRed    1000 div
  lineGreen  1000 div
  lineBlue   1000 div
  setrgbcolor
} bind def

/setFillColor {
  fillRed    1000 div
  fillGreen  1000 div
  fillBlue   1000 div
  setrgbcolor
} bind def

/slc {
  /lineBlue  exch def
  /lineGreen exch def
  /lineRed   exch def
  /color 1 def
  lineBlue 1000 eq {lineGreen 1000 eq {lineRed 1000 eq {
    /lineBlue  0 def
    /lineGreen 0 def
    /lineRed   0 def
  } if} if} if
} bind def

/sfc {
  /fillBlue  exch def
  /fillGreen exch def
  /fillRed   exch def
  /color 1 def
  fillBlue 1000 eq {fillGreen 1000 eq {fillRed 1000 eq {
    /fillBlue  0 def
    /fillGreen 0 def
    /fillRed   0 def
  } if} if} if
} bind def
%******************************************************************************
%
% End of Cadence ps.prologue 
%
%******************************************************************************
%%EndProlog
/#copies 1 def
86 66 2405 3165 300 pap
gis
rotp
0 0 3157 1707 clwin
0 0 3159 1707 clwin
0 0 3165 1707 clwin
0 0 3164 1707 clwin
ssls
1021 1559 dlt
0 143 dlv
61 0 dlv
20 -7 dlv
7 -7 dlv
7 -13 dlv
0 -20 dlv
-7 -14 dlv
-7 -7 dlv
-20 -7 dlv
-61 0 dlv
dle
0 -96 1238 1655 dls
1238 1634 dlt
-14 14 dlv
-13 7 dlv
-21 0 dlv
-13 -7 dlv
-14 -14 dlv
-7 -20 dlv
0 -14 dlv
7 -20 dlv
14 -14 dlv
13 -7 dlv
21 0 dlv
13 7 dlv
14 14 dlv
dle
0 -143 1367 1702 dls
1367 1634 dlt
-14 14 dlv
-13 7 dlv
-21 0 dlv
-13 -7 dlv
-14 -14 dlv
-7 -20 dlv
0 -14 dlv
7 -20 dlv
14 -14 dlv
13 -7 dlv
21 0 dlv
13 7 dlv
14 14 dlv
dle
1530 1634 dlt
61 0 dlv
20 -7 dlv
7 -6 dlv
7 -14 dlv
0 -20 dlv
-7 -14 dlv
-7 -7 dlv
-20 -7 dlv
-61 0 dlv
0 143 dlv
61 0 dlv
20 -7 dlv
7 -7 dlv
7 -13 dlv
0 -14 dlv
-7 -13 dlv
-7 -7 dlv
-20 -7 dlv
dle
0 -143 1700 1702 dls
95 0 1652 1702 dls
27 0 1768 1702 dls
0 -143 1781 1702 dls
27 0 1768 1559 dls
476 267 31 dcu
-89 0 909 356 dls
641 267 133 134 90 270 dau
641 401 dlt
179 0 dlv
0 -268 dlv
-179 0 dlv
dle
418 267 dlt
27 0 dlv
dle
-89 0 909 178 dls
134 0 1310 1069 dls
-89 0 1399 1247 dls
1399 1247 dlt
0 -44 dlv
-45 0 dlv
45 -45 dlv
-45 0 dlv
45 -44 dlv
-45 0 dlv
45 -45 dlv
dle
44 0 1310 1069 dls
134 0 1666 1069 dls
1444 1247 dpb
1444 891 dpv
1666 1069 dpv
dpu
133 0 909 1069 dls
268 268 1042 935 dbu
267 0 909 178 dls
0 178 1176 0 dls
579 0 597 0 dls
0 178 597 0 dls
18 0 579 178 dls
18 0 597 178 dls
36 0 1292 891 dls
36 0 1292 1247 dls
36 0 579 356 dls
222 0 196 267 dls
1248 0 1800 1069 dls
713 0 196 1069 dls
0 713 909 356 dls
1286 891 dlt
1 -1 dlv
1 1 dlv
-1 1 dlv
-1 0 dlv
-2 -1 dlv
-2 -1 dlv
2 -2 dlv
0 -2 dlv
-2 -2 dlv
dle
1278 892 dlt
2 0 dlv
2 -1 dlv
2 -1 dlv
1 -2 dlv
0 -2 dlv
-1 -2 dlv
-2 -1 dlv
-2 -1 dlv
-2 0 dlv
-2 1 dlv
-1 1 dlv
-1 2 dlv
0 2 dlv
1 2 dlv
1 1 dlv
2 1 dlv
-1 -1 dlv
-1 -2 dlv
0 -4 dlv
1 -2 dlv
1 -1 dlv
dle
1276 890 dlt
-1 -2 dlv
0 -2 dlv
1 -2 dlv
dle
1280 882 dlt
1 1 dlv
1 2 dlv
0 4 dlv
-1 2 dlv
-1 1 dlv
dle
1275 884 dlt
-1 -1 dlv
-1 -2 dlv
0 -1 dlv
1 -2 dlv
1 -2 dlv
3 -1 dlv
4 0 dlv
4 -1 dlv
1 -1 dlv
dle
1275 878 dlt
3 -2 dlv
4 0 dlv
4 -1 dlv
dle
1273 880 dlt
1 -1 dlv
3 -1 dlv
5 0 dlv
4 -2 dlv
1 -2 dlv
0 -1 dlv
-1 -2 dlv
-4 -1 dlv
-6 0 dlv
-3 1 dlv
-1 2 dlv
0 1 dlv
1 2 dlv
3 2 dlv
-2 -2 dlv
-1 -2 dlv
0 -1 dlv
1 -2 dlv
2 -1 dlv
dle
0 -14 1295 892 dls
0 -12 1296 891 dls
1292 892 dlt
5 0 dlv
0 -14 dlv
dle
1297 888 dlt
1 2 dlv
1 1 dlv
3 1 dlv
3 0 dlv
2 -1 dlv
1 -1 dlv
1 -3 dlv
0 -9 dlv
dle
1307 890 dlt
1 -3 dlv
0 -8 dlv
dle
1305 892 dlt
1 -1 dlv
1 -3 dlv
0 -10 dlv
dle
8 0 1292 878 dls
8 0 1304 878 dls
2 -1 1293 892 dls
1 -2 1294 892 dls
-2 -1 1295 879 dls
-1 -2 1295 880 dls
1 -2 1297 880 dls
2 -1 1297 879 dls
-2 -1 1307 879 dls
-1 -2 1307 880 dls
1 -2 1309 880 dls
2 -1 1309 879 dls
1329 900 dlt
0 -22 dlv
5 0 dlv
dle
0 -20 1330 899 dls
1326 900 dlt
5 0 dlv
0 -22 dlv
dle
1329 889 dlt
-1 2 dlv
-2 1 dlv
-2 0 dlv
-3 -1 dlv
-2 -2 dlv
-2 -3 dlv
0 -2 dlv
2 -3 dlv
2 -2 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 2 dlv
dle
1320 889 dlt
-1 -2 dlv
0 -4 dlv
1 -2 dlv
dle
1324 892 dlt
-2 -1 dlv
-1 -1 dlv
-1 -3 dlv
0 -4 dlv
1 -3 dlv
1 -1 dlv
2 -1 dlv
dle
2 -1 1327 900 dls
1 -2 1328 900 dls
1 -2 1331 880 dls
2 -1 1331 879 dls
1342 888 dlt
-1 9 dlv
0 2 dlv
1 1 dlv
0 -15 dlv
1 0 dlv
0 15 dlv
-1 0 dlv
dle
1343 900 dlt
1 -1 dlv
0 -2 dlv
-1 -9 dlv
dle
1342 881 dlt
-1 -1 dlv
0 -1 dlv
1 -1 dlv
1 0 dlv
1 1 dlv
0 1 dlv
-1 1 dlv
-1 0 dlv
dle
1342 880 dlt
0 -1 dlv
1 0 dlv
0 1 dlv
-1 0 dlv
dle
573 178 dlt
1 -1 dlv
1 1 dlv
-1 1 dlv
-1 0 dlv
-3 -1 dlv
-1 -1 dlv
1 -2 dlv
0 -2 dlv
-1 -2 dlv
dle
565 179 dlt
2 0 dlv
2 -1 dlv
1 -1 dlv
1 -2 dlv
0 -2 dlv
-1 -2 dlv
-1 -1 dlv
-2 -1 dlv
-2 0 dlv
-2 1 dlv
-1 1 dlv
-1 2 dlv
0 2 dlv
1 2 dlv
1 1 dlv
2 1 dlv
-1 -1 dlv
-1 -2 dlv
0 -4 dlv
1 -2 dlv
1 -1 dlv
dle
563 177 dlt
-1 -2 dlv
0 -2 dlv
1 -2 dlv
dle
567 169 dlt
1 1 dlv
1 2 dlv
0 4 dlv
-1 2 dlv
-1 1 dlv
dle
562 171 dlt
-1 -1 dlv
-1 -2 dlv
0 -1 dlv
1 -3 dlv
1 -1 dlv
3 -1 dlv
4 0 dlv
4 -1 dlv
1 -1 dlv
dle
562 164 dlt
3 -1 dlv
4 0 dlv
4 -1 dlv
dle
560 167 dlt
1 -2 dlv
3 -1 dlv
5 0 dlv
4 -1 dlv
1 -2 dlv
0 -1 dlv
-1 -2 dlv
-4 -1 dlv
-6 0 dlv
-3 1 dlv
-1 2 dlv
0 1 dlv
1 2 dlv
3 1 dlv
-2 -1 dlv
-1 -2 dlv
0 -1 dlv
1 -2 dlv
2 -1 dlv
dle
0 -15 582 179 dls
0 -13 583 178 dls
579 179 dlt
5 0 dlv
0 -15 dlv
dle
584 175 dlt
1 2 dlv
1 1 dlv
2 1 dlv
4 0 dlv
2 -1 dlv
1 -1 dlv
1 -3 dlv
0 -10 dlv
dle
594 177 dlt
1 -3 dlv
0 -9 dlv
dle
592 179 dlt
1 -1 dlv
1 -3 dlv
0 -11 dlv
dle
8 0 579 164 dls
8 0 591 164 dls
2 -1 580 179 dls
1 -2 581 179 dls
-2 -1 582 165 dls
-1 -3 582 167 dls
1 -3 584 167 dls
2 -1 584 165 dls
-2 -1 594 165 dls
-1 -3 594 167 dls
1 -3 596 167 dls
2 -1 596 165 dls
616 187 dlt
0 -23 dlv
5 0 dlv
dle
0 -21 617 186 dls
613 187 dlt
5 0 dlv
0 -23 dlv
dle
616 176 dlt
-1 2 dlv
-2 1 dlv
-2 0 dlv
-3 -1 dlv
-3 -2 dlv
-1 -3 dlv
0 -2 dlv
1 -3 dlv
3 -3 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 3 dlv
dle
606 176 dlt
-1 -2 dlv
0 -4 dlv
1 -2 dlv
dle
611 179 dlt
-2 -1 dlv
-1 -1 dlv
-2 -3 dlv
0 -4 dlv
2 -3 dlv
1 -2 dlv
2 -1 dlv
dle
2 -1 614 187 dls
1 -2 615 187 dls
1 -3 618 167 dls
2 -1 618 165 dls
629 175 dlt
-1 9 dlv
0 2 dlv
1 1 dlv
0 -15 dlv
1 0 dlv
0 15 dlv
-1 0 dlv
dle
630 187 dlt
1 -1 dlv
0 -2 dlv
-1 -9 dlv
dle
629 168 dlt
-1 -1 dlv
0 -2 dlv
1 -1 dlv
1 0 dlv
1 1 dlv
0 2 dlv
-1 1 dlv
-1 0 dlv
dle
629 167 dlt
0 -2 dlv
1 0 dlv
0 2 dlv
-1 0 dlv
dle
1277 1249 dlt
7 -15 dlv
1 2 dlv
5 12 dlv
-2 1 dlv
dle
6 -13 1278 1249 dls
6 -13 1279 1249 dls
8 0 1275 1249 dls
6 0 1286 1249 dls
3 -2 1276 1249 dls
-3 -1 1282 1249 dls
-1 -1 1291 1249 dls
1308 1256 dlt
0 -22 dlv
5 0 dlv
dle
0 -20 1309 1255 dls
1305 1256 dlt
5 0 dlv
0 -22 dlv
dle
1308 1246 dlt
-1 2 dlv
-2 1 dlv
-2 0 dlv
-3 -1 dlv
-2 -2 dlv
-2 -3 dlv
0 -3 dlv
2 -3 dlv
2 -2 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 2 dlv
dle
1299 1246 dlt
-1 -2 dlv
0 -5 dlv
1 -2 dlv
dle
1303 1249 dlt
-2 -1 dlv
-1 -1 dlv
-1 -3 dlv
0 -5 dlv
1 -3 dlv
1 -1 dlv
2 -1 dlv
dle
2 -1 1306 1256 dls
1 -2 1307 1256 dls
1 -2 1310 1236 dls
2 -1 1310 1235 dls
1330 1256 dlt
0 -22 dlv
6 0 dlv
dle
0 -20 1331 1255 dls
1327 1256 dlt
6 0 dlv
0 -22 dlv
dle
1330 1246 dlt
-1 2 dlv
-2 1 dlv
-2 0 dlv
-3 -1 dlv
-2 -2 dlv
-1 -3 dlv
0 -3 dlv
1 -3 dlv
2 -2 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 2 dlv
dle
1321 1246 dlt
-1 -2 dlv
0 -5 dlv
1 -2 dlv
dle
1325 1249 dlt
-2 -1 dlv
-1 -1 dlv
-1 -3 dlv
0 -5 dlv
1 -3 dlv
1 -1 dlv
2 -1 dlv
dle
2 -1 1328 1256 dls
1 -2 1329 1256 dls
1 -2 1333 1236 dls
2 -1 1333 1235 dls
1343 1245 dlt
-1 8 dlv
0 2 dlv
1 1 dlv
0 -15 dlv
1 0 dlv
0 15 dlv
-1 0 dlv
dle
1344 1256 dlt
1 -1 dlv
0 -2 dlv
-1 -8 dlv
dle
1343 1237 dlt
-1 -1 dlv
0 -1 dlv
1 -1 dlv
1 0 dlv
1 1 dlv
0 1 dlv
-1 1 dlv
-1 0 dlv
dle
1343 1236 dlt
0 -1 dlv
1 0 dlv
0 1 dlv
-1 0 dlv
dle
564 358 dlt
7 -15 dlv
1 2 dlv
5 11 dlv
-2 2 dlv
dle
6 -13 565 358 dls
6 -13 566 358 dls
8 0 562 358 dls
6 0 573 358 dls
3 -3 563 358 dls
-3 -2 569 358 dls
-1 -2 578 358 dls
595 365 dlt
0 -22 dlv
5 0 dlv
dle
0 -20 596 364 dls
592 365 dlt
5 0 dlv
0 -22 dlv
dle
595 354 dlt
-1 2 dlv
-2 2 dlv
-2 0 dlv
-3 -2 dlv
-3 -2 dlv
-1 -3 dlv
0 -2 dlv
1 -3 dlv
3 -2 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 2 dlv
dle
585 354 dlt
-1 -2 dlv
0 -4 dlv
1 -2 dlv
dle
590 358 dlt
-2 -2 dlv
-1 -1 dlv
-2 -3 dlv
0 -4 dlv
2 -3 dlv
1 -1 dlv
2 -1 dlv
dle
2 -1 593 365 dls
1 -2 594 365 dls
1 -2 597 345 dls
2 -1 597 344 dls
617 365 dlt
0 -22 dlv
6 0 dlv
dle
0 -20 618 364 dls
614 365 dlt
5 0 dlv
0 -22 dlv
dle
617 354 dlt
-1 2 dlv
-2 2 dlv
-2 0 dlv
-3 -2 dlv
-2 -2 dlv
-1 -3 dlv
0 -2 dlv
1 -3 dlv
2 -2 dlv
3 -1 dlv
2 0 dlv
2 1 dlv
1 2 dlv
dle
608 354 dlt
-1 -2 dlv
0 -4 dlv
1 -2 dlv
dle
612 358 dlt
-2 -2 dlv
-1 -1 dlv
-1 -3 dlv
0 -4 dlv
1 -3 dlv
1 -1 dlv
2 -1 dlv
dle
2 -1 615 365 dls
1 -2 616 365 dls
1 -2 619 345 dls
3 -1 619 344 dls
630 353 dlt
-1 9 dlv
0 2 dlv
1 1 dlv
0 -15 dlv
1 0 dlv
0 15 dlv
-1 0 dlv
dle
631 365 dlt
1 -1 dlv
0 -2 dlv
-1 -9 dlv
dle
630 346 dlt
-1 -1 dlv
0 -1 dlv
1 -1 dlv
1 0 dlv
1 1 dlv
0 1 dlv
-1 1 dlv
-1 0 dlv
dle
630 345 dlt
0 -1 dlv
1 0 dlv
0 1 dlv
-1 0 dlv
dle
0 -33 602 273 dls
602 264 dlt
7 7 dlv
4 2 dlv
7 0 dlv
5 -2 dlv
2 -7 dlv
0 -24 dlv
dle
0 -33 672 273 dls
672 266 dlt
-5 5 dlv
-5 2 dlv
-7 0 dlv
-4 -2 dlv
-5 -5 dlv
-2 -7 dlv
0 -5 dlv
2 -7 dlv
5 -4 dlv
4 -3 dlv
7 0 dlv
5 3 dlv
5 4 dlv
dle
0 -33 690 273 dls
690 264 dlt
7 7 dlv
5 2 dlv
7 0 dlv
5 -2 dlv
2 -7 dlv
0 -24 dlv
dle
0 -49 760 289 dls
760 266 dlt
-4 5 dlv
-5 2 dlv
-7 0 dlv
-5 -2 dlv
-4 -5 dlv
-3 -7 dlv
0 -5 dlv
3 -7 dlv
4 -4 dlv
5 -3 dlv
7 0 dlv
5 3 dlv
4 4 dlv
dle
779 278 dlt
0 2 dlv
2 5 dlv
3 2 dlv
4 2 dlv
10 0 dlv
4 -2 dlv
3 -2 dlv
2 -5 dlv
0 -5 dlv
-2 -4 dlv
-5 -7 dlv
-23 -24 dlv
32 0 dlv
dle
750 352 dlt
14 35 dlv
13 -35 dlv
dle
17 0 755 363 dls
791 380 dlt
3 2 dlv
5 5 dlv
0 -35 dlv
dle
0 47 98 334 dls
98 367 dlt
3 10 dlv
5 4 dlv
16 0 dlv
6 -4 dlv
2 -10 dlv
0 -33 dlv
dle
149 372 dlt
3 6 dlv
5 3 dlv
14 0 dlv
6 -3 dlv
4 -6 dlv
0 -38 dlv
dle
181 354 dlt
-4 4 dlv
-4 3 dlv
-18 0 dlv
-3 -3 dlv
-3 -4 dlv
0 -14 dlv
3 -5 dlv
3 -1 dlv
18 0 dlv
4 1 dlv
4 5 dlv
dle
0 47 200 334 dls
200 367 dlt
3 10 dlv
4 4 dlv
16 0 dlv
7 -4 dlv
1 -10 dlv
0 -33 dlv
dle
284 367 dlt
-2 10 dlv
-6 4 dlv
-18 0 dlv
-5 -4 dlv
-3 -12 dlv
0 -15 dlv
3 -11 dlv
5 -5 dlv
18 0 dlv
6 5 dlv
2 7 dlv
dle
0 -66 284 400 dls
310 334 dlt
-4 5 dlv
-3 11 dlv
0 17 dlv
3 10 dlv
4 4 dlv
18 0 dlv
6 -4 dlv
2 -12 dlv
0 -15 dlv
-2 -11 dlv
-6 -5 dlv
-18 0 dlv
dle
355 381 dlt
0 -33 dlv
3 -9 dlv
5 -5 dlv
14 0 dlv
6 5 dlv
4 7 dlv
dle
0 -47 387 381 dls
30 0 406 381 dls
413 394 dlt
0 -51 dlv
4 -8 dlv
6 -1 dlv
5 0 dlv
6 1 dlv
3 8 dlv
0 8 dlv
dle
3021 1136 dlt
-5 5 dlv
-3 11 dlv
0 17 dlv
3 10 dlv
5 5 dlv
17 0 dlv
7 -5 dlv
1 -11 dlv
0 -16 dlv
-1 -11 dlv
-7 -5 dlv
-17 0 dlv
dle
3065 1184 dlt
0 -34 dlv
3 -9 dlv
5 -5 dlv
14 0 dlv
7 5 dlv
3 8 dlv
dle
0 -48 3097 1184 dls
30 0 3116 1184 dls
3124 1196 dlt
0 -50 dlv
3 -8 dlv
6 -2 dlv
5 0 dlv
7 2 dlv
3 8 dlv
0 7 dlv
dle
0 67 116 1136 dls
116 1169 dlt
3 10 dlv
5 5 dlv
17 0 dlv
7 -5 dlv
1 -11 dlv
0 -16 dlv
-1 -11 dlv
-7 -5 dlv
-17 0 dlv
-5 5 dlv
-3 8 dlv
dle
30 0 168 1184 dls
176 1196 dlt
0 -50 dlv
3 -8 dlv
7 -2 dlv
4 0 dlv
7 2 dlv
3 8 dlv
0 7 dlv
dle
0 48 219 1136 dls
0 7 219 1196 dls
0 -44 650 185 dls
650 179 dlt
4 4 dlv
4 2 dlv
7 0 dlv
4 -2 dlv
4 -4 dlv
2 -7 dlv
0 -4 dlv
-2 -6 dlv
-4 -4 dlv
-4 -3 dlv
-7 0 dlv
-4 3 dlv
-4 4 dlv
dle
688 185 dlt
8 -30 dlv
9 30 dlv
8 -30 dlv
9 30 dlv
dle
0 -30 737 185 dls
737 172 dlt
2 7 dlv
4 4 dlv
4 2 dlv
7 0 dlv
dle
0 -30 764 185 dls
764 177 dlt
7 6 dlv
4 2 dlv
6 0 dlv
5 -2 dlv
2 -6 dlv
0 -22 dlv
dle
0 -44 650 363 dls
650 357 dlt
4 4 dlv
4 2 dlv
7 0 dlv
4 -2 dlv
4 -4 dlv
2 -6 dlv
0 -4 dlv
-2 -7 dlv
-4 -4 dlv
-4 -2 dlv
-7 0 dlv
-4 2 dlv
-4 4 dlv
dle
688 363 dlt
8 -29 dlv
9 29 dlv
8 -29 dlv
9 29 dlv
dle
0 -29 737 363 dls
737 351 dlt
2 6 dlv
4 4 dlv
4 2 dlv
7 0 dlv
dle
0 -44 764 363 dls
764 357 dlt
5 4 dlv
4 2 dlv
6 0 dlv
4 -2 dlv
5 -4 dlv
2 -6 dlv
0 -4 dlv
-2 -7 dlv
-5 -4 dlv
-4 -2 dlv
-6 0 dlv
-4 2 dlv
-5 4 dlv
dle
1683 1121 dlt
-4 -2 dlv
-4 -4 dlv
-2 -7 dlv
0 -4 dlv
2 -6 dlv
4 -4 dlv
4 -3 dlv
7 0 dlv
4 3 dlv
4 4 dlv
2 6 dlv
0 4 dlv
-2 7 dlv
-4 4 dlv
-4 2 dlv
-7 0 dlv
dle
1715 1121 dlt
0 -21 dlv
2 -6 dlv
5 -3 dlv
6 0 dlv
4 3 dlv
7 6 dlv
dle
0 -30 1739 1121 dls
1758 1136 dlt
0 -36 dlv
2 -6 dlv
4 -3 dlv
4 0 dlv
dle
15 0 1751 1121 dls
964 1136 dlt
2 -2 dlv
2 2 dlv
-2 2 dlv
-2 -2 dlv
dle
0 -30 966 1121 dls
0 -30 983 1121 dls
983 1113 dlt
7 6 dlv
4 2 dlv
6 0 dlv
4 -2 dlv
3 -6 dlv
0 -22 dlv
dle
0 -44 1127 956 dls
1127 950 dlt
4 4 dlv
4 2 dlv
7 0 dlv
4 -2 dlv
4 -4 dlv
2 -6 dlv
0 -5 dlv
-2 -6 dlv
-4 -4 dlv
-4 -2 dlv
-7 0 dlv
-4 2 dlv
-4 4 dlv
dle
1165 956 dlt
8 -29 dlv
9 29 dlv
8 -29 dlv
9 29 dlv
dle
0 -29 1214 956 dls
1214 944 dlt
2 6 dlv
4 4 dlv
4 2 dlv
7 0 dlv
dle
0 -29 1241 956 dls
1241 948 dlt
7 6 dlv
4 2 dlv
6 0 dlv
5 -2 dlv
2 -6 dlv
0 -21 dlv
dle
0 -45 1127 1313 dls
1127 1306 dlt
4 5 dlv
4 2 dlv
7 0 dlv
4 -2 dlv
4 -5 dlv
2 -6 dlv
0 -4 dlv
-2 -7 dlv
-4 -4 dlv
-4 -2 dlv
-7 0 dlv
-4 2 dlv
-4 4 dlv
dle
1165 1313 dlt
8 -30 dlv
9 30 dlv
8 -30 dlv
9 30 dlv
dle
0 -30 1214 1313 dls
1214 1300 dlt
2 6 dlv
4 5 dlv
4 2 dlv
7 0 dlv
dle
0 -45 1241 1313 dls
1241 1306 dlt
5 5 dlv
4 2 dlv
6 0 dlv
4 -2 dlv
5 -5 dlv
2 -6 dlv
0 -4 dlv
-2 -7 dlv
-5 -4 dlv
-4 -2 dlv
-6 0 dlv
-4 2 dlv
-5 4 dlv
dle
1 lpb
1 1 lpon
1 31 lpoff
1 1 lpe
1 sls
240 227 dpb
240 307 dpv
191 307 dpv
151 267 dpv
191 227 dpv
dpu
3003 1029 dpb
3003 1109 dpv
3052 1109 dpv
3093 1069 dpv
3052 1029 dpv
dpu
151 1029 dpb
151 1109 dpv
200 1109 dpv
240 1069 dpv
200 1029 dpv
dpu
36 35 401 249 dbu
36 36 891 160 dbu
36 36 579 338 dbu
36 36 891 338 dbu
36 36 579 160 dbu
36 36 1782 1051 dbu
36 36 891 1051 dbu
36 36 1292 873 dbu
35 36 1292 1230 dbu
240 227 dpb
240 307 dpv
191 307 dpv
151 267 dpv
191 227 dpv
dps
3003 1029 dpb
3003 1109 dpv
3052 1109 dpv
3093 1069 dpv
3052 1029 dpv
dps
151 1029 dpb
151 1109 dpv
200 1109 dpv
240 1069 dpv
200 1029 dpv
dps
ssls
1087 1020 dlt
0 71 dlv
31 0 dlv
10 -3 dlv
3 -3 dlv
4 -7 dlv
0 -10 dlv
-4 -7 dlv
-3 -4 dlv
-10 -3 dlv
-31 0 dlv
dle
1148 1020 dlt
27 71 dlv
28 -71 dlv
dle
33 0 1159 1044 dls
1223 1020 dlt
0 71 dlv
24 0 dlv
10 -3 dlv
7 -7 dlv
3 -7 dlv
4 -10 dlv
0 -17 dlv
-4 -10 dlv
-3 -7 dlv
-7 -6 dlv
-10 -4 dlv
-24 0 dlv
dle
1465 1105 dlt
0 -29 dlv
2 -5 dlv
3 -2 dlv
4 0 dlv
dle
12 0 1460 1093 dls
1486 1105 dlt
0 -29 dlv
1 -5 dlv
4 -2 dlv
3 0 dlv
dle
12 0 1481 1093 dls
0 -36 1504 1105 dls
1516 1105 dlt
2 -2 dlv
2 2 dlv
-2 2 dlv
-2 -2 dlv
dle
0 -24 1518 1093 dls
0 -24 1532 1093 dls
1532 1086 dlt
5 5 dlv
3 2 dlv
5 0 dlv
4 -2 dlv
1 -5 dlv
0 -17 dlv
dle
1588 1081 dlt
-26 0 dlv
17 24 dlv
0 -36 dlv
dle
19 -24 1596 1093 dls
-19 -24 1615 1093 dls
9 0 477 401 dls
0 -49 481 401 dls
9 0 477 352 dls
505 391 dlt
4 3 dlv
7 7 dlv
0 -49 dlv
dle
7 0 1246 851 dls
0 -36 1250 851 dls
7 0 1246 815 dls
1272 851 dlt
-5 -2 dlv
-4 -5 dlv
-1 -9 dlv
0 -5 dlv
1 -8 dlv
4 -5 dlv
5 -2 dlv
3 0 dlv
5 2 dlv
4 5 dlv
1 8 dlv
0 5 dlv
-1 9 dlv
-4 5 dlv
-5 2 dlv
-3 0 dlv
dle
-23 -36 1285 851 dls
0 -32 129 317 dls
129 308 dlt
7 7 dlv
5 2 dlv
7 0 dlv
5 -2 dlv
2 -7 dlv
0 -23 dlv
dle
0 -32 199 317 dls
199 310 dlt
-4 5 dlv
-5 2 dlv
-7 0 dlv
-5 -2 dlv
-4 -5 dlv
-3 -7 dlv
0 -4 dlv
3 -7 dlv
4 -5 dlv
5 -2 dlv
7 0 dlv
5 2 dlv
4 5 dlv
dle
0 -32 218 317 dls
218 308 dlt
7 7 dlv
5 2 dlv
7 0 dlv
4 -2 dlv
3 -7 dlv
0 -23 dlv
dle
0 -49 288 334 dls
288 310 dlt
-5 5 dlv
-4 2 dlv
-7 0 dlv
-5 -2 dlv
-5 -5 dlv
-2 -7 dlv
0 -4 dlv
2 -7 dlv
5 -5 dlv
5 -2 dlv
7 0 dlv
4 2 dlv
5 5 dlv
dle
316 317 dlt
-5 -2 dlv
-4 -5 dlv
-3 -7 dlv
0 -4 dlv
3 -7 dlv
4 -5 dlv
5 -2 dlv
7 0 dlv
5 2 dlv
4 5 dlv
3 7 dlv
0 4 dlv
-3 7 dlv
-4 5 dlv
-5 2 dlv
-7 0 dlv
dle
351 317 dlt
0 -23 dlv
2 -7 dlv
5 -2 dlv
7 0 dlv
5 2 dlv
7 7 dlv
dle
0 -32 377 317 dls
398 334 dlt
0 -40 dlv
2 -7 dlv
5 -2 dlv
4 0 dlv
dle
16 0 391 317 dls
948 228 dlt
0 -37 dlv
-2 -7 dlv
-2 -2 dlv
-5 -3 dlv
-7 0 dlv
-5 3 dlv
dle
948 221 dlt
-4 5 dlv
-5 2 dlv
-7 0 dlv
-5 -2 dlv
-4 -5 dlv
-3 -7 dlv
0 -4 dlv
3 -7 dlv
4 -5 dlv
5 -2 dlv
7 0 dlv
5 2 dlv
4 5 dlv
dle
0 -32 967 228 dls
967 219 dlt
7 7 dlv
5 2 dlv
7 0 dlv
4 -2 dlv
3 -7 dlv
0 -23 dlv
dle
0 -49 1037 245 dls
1037 221 dlt
-5 5 dlv
-4 2 dlv
-7 0 dlv
-5 -2 dlv
-5 -5 dlv
-2 -7 dlv
0 -4 dlv
2 -7 dlv
5 -5 dlv
5 -2 dlv
7 0 dlv
4 2 dlv
5 5 dlv
dle
0 -33 1058 245 dls
1058 200 dlt
-2 -2 dlv
2 -2 dlv
2 2 dlv
-2 2 dlv
dle
0 -49 927 423 dls
927 400 dlt
5 4 dlv
4 3 dlv
7 0 dlv
5 -3 dlv
5 -4 dlv
2 -7 dlv
0 -5 dlv
-2 -7 dlv
-5 -5 dlv
-5 -2 dlv
-7 0 dlv
-4 2 dlv
-5 5 dlv
dle
974 423 dlt
0 -40 dlv
2 -7 dlv
5 -2 dlv
4 0 dlv
dle
16 0 967 407 dls
997 423 dlt
2 -2 dlv
3 2 dlv
-3 2 dlv
-2 -2 dlv
dle
0 -33 999 407 dls
0 0 3165 1707 clwin
0 0 3164 1707 clwin
0 0 3165 1707 clwin
gfs

---

From: [email-masked] (Syed Huq)
Date: Fri, 6 Sep 96 14:24:17 PDT

IBISfans,

I think I have solved my problem. I noticed that the s2ibis generated
.spi files did not attach the .INCLUDE process_file_names I had
specified in my header files. As such, the process parameters were not
seen by hspice.

The solution would be to go into each and every .spi file and manually
add the .INCLUDE statement with the process_file_name, run hspice, 
extract out the V/I data and manually create the .ibs file from all these.

Anyone seen this same problem with s2ibis ?

Regards,
Syed.

> From huq Thu Sep  5 17:29:37 1996
> Date: Thu, 5 Sep 96 17:29:06 PDT
> From: huq (Syed Huq)
> To: [email-masked]
> Subject: s2ibis and spice netlist file
> Cc: huq
> Content-Type> : > X-sun-attachment> 
> Content-Length: 31643
> 
> Hi,
>