Subject: Re: Monotonicity

From: "C. Kumar" <[email-masked]>
Date: Thu, 5 Sep 1996 07:03:45 -0400

In most cases the non monotonic data is an artifact of separating out the clamp curves. It is incorrect to filter this data as the combined effect of the clamp and the active pullup/down curves will yield at the worst mild non monotonicity.
- kumar

> From [email-masked] Thu Sep  5 04:43 EDT 1996
> Received-Date: Thu, 5 Sep 1996 04:43:22 -0400
> Sender: [email-masked]
> From: FITZPATRICK John <[email-masked]>
> Organization: Alcatel Telecom, 22304 Lannion, France
> X-Mailer: Mozilla 3.0 (X11; I; SunOS 4.1.3_U1 sun4c)
> Mime-Version: 1.0
> To: [email-masked]
> Subject: Monotonicity 
> Content-Transfer-Encoding: 7bit
> X-Lines: 66
> 
> Hello all,
> 
> I believe there were many discussions on monotonicity before
> I joined the IBIS mailing lists. Perhaps someone would be kind
> enough to help me with this issue.
> 
> We are currently trying to encourage a semiconductor supplier 
> to provide us with IBIS data for a set of components. Their response
> is lukewarm. An argument used is that because the buffers have
> non-monotonic curves, IBIS models cannot be created.
> 
> On reading IBIS 2.1, this appears to be true. An example of an
> output curve is a follows:
> 
>    
>                  |        *
>             Vdd  + 
>                  |        *                   Pulldown
>                  | 
>                  |        *
>    Vout          |         
>                  |        *
>                  |                *                 
>           0.5Vdd +                                *      
>                  |                                     *
>                  |                                   *
>                  |                           *
>                  |                    * 
>                  |             *
>                  |       *
>                  | *
>                 --------------------------------------------------
>                                  Iout
> 
> 
> Has anybody else had to deal with this issue?
> 
> Why is their a restriction put on monotonicity? Is it because
> some simulators cannot handle this case?
> 
> In 2.1 it states that most simulators filter non-monotonic data.
> Does this mean that it's OK to feed non-monotonic IBIS models to
> most simulators i.e. it will generate results based on filtered
> data?
> 
> I've looked at the FAQ, but this seems to say that the only reason for
> non-monotonic behaviour is due to the way clamping and active
> curves are generated!
> 
> Any feedback appreciated,
> 
> Regards,
> John
> 
> 
> 
> 
> 
> 
> 
> 
> 
> -- 
> John Fitzpatrick   <[email-masked]>    
> Alcatel CIT, 4 rue de Broglie, 22304 Lannion, France
> Tel: (+33)96.04.79.33  Fax: (+33)96.04.85.09
>

---

From: FITZPATRICK John <[email-masked]>
Date: Thu, 05 Sep 1996 13:47:22 +0200

To clarify a point:

The I/V curves I've seen for the chipset are for the *combined*
effect of clamp and active curves. Some are mildly non-monotonic,
others are extremely non-monotonic.

Does this mean that they cannot be modelled with IBIS?

Regards, John