Subject: Re: Help: Programmable Outputs

From: [email-masked] (MR RONALD J CHRISTOPHER)
Date: Sat, 7 Dec 1996 08:24:50, -0500

-- [ From: Ron Christopher * EMC.Ver #2.5.1 ] --

It seems like the proposed BIRD will have the user manually edit the
IBIS model for each different condition.  The IBIS model is in the
category of rules data when processing at the higher level package. 
Would you require each user to have their own copy of the IBIS model in
an MCM or board design shop?  Can this proposal support a user who needs
the IBIS model set  one way for one net and a different way for a
different net in the same higher level package being processed?

Would a standardized filter identifier associated with the pin in the
design data base improve the proposal?  The filter identifier would
identify to the programs which subset of the IBIS model to use for each
instance of a pin.  The standardized identifier can then be used by
other functions such as system level delay or tristate rules checking
etc. One could perhaps write a checker that checked that the
standardized identifier was correct for the conditions which might
require tracing a couple of levels of logic through the network.

Ron Christopher 

==================

Text item: 

Scott,

BIRD30.2 addresses the problem you have.  Hopefully it will be
implemented in  IBIS3.0 soon.  Untill then, in our models we use
comments.  Spceifically, I put  everything that is legal in BIRD30.2
into the IBIS file with comment characters  in front of each line.  This
and an explanation gives enough information to the  user to know how to
edit the IBIS file for the various conditions.  When IBIS3.0 arrives,
all they need to do is to rmove the comment characters.

Arpad
========================================================================
=======

Ibis folks,

I guess this question is mainly aimed at the simulation vendor folks,
but feedback is welcome from everyone:
(Our products are programmable logic devices, for those who are not
familiar with Actel)

For a component that has a programable behavior for the I/O pins, what
might be the preferred way of presenting the data for the different
possible configurations?  Specifically, let's say that a pin can be
programmed to be either:
     1) Tristateable I/O with a fast slew rate
     2)  "           "    "  " slow slew rate
     3) Open Drain output (data input to the output buffer is
             programmed to be tied to the enable of the buffer)

Would it be better to actually make a main IBIS file that contains all
of the I/Os in condition (1),  with 2 extra IBIS files that contain only
one pin in them each for conditions (2) and (3)?  Or, perhaps only make
one IBIS file with all of the pins configured in condition (1) and
commented out sections for conditions (2) and (3).  Or, even another
possibility of dividing the I/Os into 3 equal sections, one for each
configuration?  All comments/suggestions welcome, and please forgive me
if this has been discussed already.  Thanks,
-Scott Schlachter
 [email-masked]
 Actel Corporation
 Sunnyvale, CA.

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: Help: Programable outputs
To: [email-masked], [email-masked]
From: [email-masked] (Scott Schlachter)
Date: Wed, 4 Dec 96 13:30:44 PST
vhdl.org (8 .7.3/8.7.3) with SMTP id NAA17598; Wed, 4 Dec 1996 13:40:39
-0800 (PST) Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3])
by ormail.intel.com ( 8.8.3/8.7.3) with ESMTP id NAA19804; Wed, 4 Dec
1996 13:36:55 -0800 (PST) Received: from ormail.intel.com (ormail.intel.
com [134.134.248.3]) by relay.jf.i ntel.com (8.8.2/8.7.3) with ESMTP id
NAA10202; Wed, 4 Dec 1996 13:37:03 -0800 (P ST)
Return-Path: [email-masked]

---

From: Arpad Muranyi <[email-masked]>
Date: Tue, 10 Dec 96 08:12:00 PST

Text item: 

Ron,

First, the proposed bird (30.2) does not require any manual edits by the user.  
The whole point was to provide a mechanizm that the simulation software would be
able to use in a user friendly interface or dialog box, etc.  Through this the 
user would not have to edit the IBIS model, the user will have to make 
selections in the simulation software.  If no selections are made, the default 
will be in effect, but the software will still be able to simulate.

Second, you are using some kind of a software jargon in your suggestion that I 
don't understand ("standardized filter identifier").  Since I don't understand, 
I cant comment on it.  Would you care to elaborate a little more?

Arpad
===============================================================================

Ron Christopher

==================

Text item: 

Scott,

Arpad

Ibis folks,

Subject: Re: Help: Programmable Outputs
To: [email-masked], [email-masked]
Date: 07 Dec 96
cc: [email-masked], [email-masked]
To: [email-masked], [email-masked]
Date: Sat,  7 Dec 1996 08:24:50, -0500
From: [email-masked] (MR RONALD J CHRISTOPHER)
w.prodigy.com (8.6.10/8.6.9) with ESMTP id IAA33562; Sat, 7 Dec 1996 08:30:52 -0
500
Received: from pimaia4w.prodigy.com (pimaia4w.prodigy.com [198.83.18.139]) by vh
dl.vhdl.org (8.7.3/8.7.3) with SMTP id FAA05263; Sat, 7 Dec 1996 05:55:06 -0800
(PST)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by mailbag.jf.intel.c
om (8.8.4/8.7.3) with ESMTP id FAA03566; Sat, 7 Dec 1996 05:52:35 -0800 (PST)
Received: from mailbag.jf.intel.com ([email-masked] [134.134.248.4])
by relay.jf.intel.com (8.8.2/8.7.3) with ESMTP id FAA01760; Sat, 7 Dec 1996 05:5
0:02 -0800 (PST)
Return-Path: [email-masked]