Subject: s2ibis translator

From: [email-masked] (Hoang Nguyen)
Date: Wed, 12 Jun 96 14:30:10 EDT

Hello IBIS gurus:

I have a couple questions concerning s2ibis program usage.  If you have
similar experience, please inform me.

   1.   I can't find a way to make use of multiple voltage sources
	in the netlist.  So I modified each spice input files after they are 
	created by s2ibis, then re-run s2ibis. Please advise.

   2.	Also, I cannot combine input ckt and output/I/O ckt in one s2ibis spice
	file, so not all buffer models in a component can be generated in one pass
	thru s2ibis program, but rather in several passes for each buffer type.  
	Then I manually combine them into ibis model, and run the parser thru.
	Do you have any comment on this?  Could we make the suggestion to enhance
	s2ibis program?

Thank you for any inputs on these.  And thanks Syed for your answers on my other
questions.

Regards,

Hoang Nguyen
[email-masked]
919-479-3479

Mitsubishi Semiconductor America, Inc.
Durham, North Carolina

---

From: [email-masked] (Syed Huq)
Date: Thu, 13 Jun 96 17:44:05 PDT

Hoang,

Do you mind if I post this on the reflector. I do not have an answer for this.
Pls advice.

Regards,
Syed.
> From [email-masked] Wed Jun 12 11:51:59 1996
> Date: Wed, 12 Jun 96 14:30:10 EDT
> From: [email-masked] (Hoang Nguyen)
> To: [email-masked]
> Subject: s2ibis translator
> Cc: [email-masked]
> Content-Length: 931
> 
> 
> Hello IBIS gurus:
>

---

From: [email-masked] ( Bob Ross)
Date: Fri, 14 Jun 96 11:33 PDT

Hoang:

Regarding your questions, I will try to give a response without
knowing the specific details.

(1)  Your approach is OK.  However, if they are expected to
change for min and max conditions, I sometimes augment the 
Spice code by creating the second supply dependent on the
first.  It could be a direct offset, or could be through a 
porportional divider.  Other supplies might be set by options
in the min and max models, although I have not done this.

(2)  I have had success with I/O structures.  Sometimes, I
just use 3-state and then change the Model_type afterwards
since exactly the same data is produced.  Generally I 
prefer partitiioning the problem and doing mulitple passes.
Then any problem is more easily to isolate.  However, for
storing a reference script for documentation and later
usage by someone else, putting all the models in one
script makes sense.  I have been successful by putting
in subcircuit calls X... for each model.  The problem
may be that the pin number notation may be conflicting.
By using the subcircuit call, you can define the pin
number notation that the script references the Spice code
to assure different numbers.

Best Regards,
Bob Ross
Inerconnectix, Inc.

> Message-Id: <[email-masked]>
> To: [email-masked]
> Status: RO