Subject: Re: Use of [Ramp] keyword

From: Arpad Muranyi <[email-masked]>
Date: Wed, 15 May 96 08:10:19 PST

Text item: 

John,

This is an excerpt from the IBIS specification.  It is from the section called 
"data derivation methods".

|           Then: Attach a 50 ohm resistor to GND to derive the rising edge
|                 ramp.  Attach a 50 ohm resistor to POWER to derive the
|                 falling edge ramp.
|
|    c. Due to the resistor, output swings will not make a full transition as
|       expected.  However the pertinent data can still be collected as
|       follows:
|           1)  determine the 20% to 80% voltages of the 50 ohm swing
|           2)  measure this voltage change as "dV"
|           3)  measure the amount of time required to make this swing "dt"
|
|    d. Post the value as a ratio "dV/dt".  The simulation tool vendor
|       extrapolates this value to span the required voltage swing range in
|       the final model.

According to this, your a) example might not be 100% correct, since it shows the
same number for dt in the typical and minimum places.  Usually the worst case 
buffer (represented in the minimum columns) will not be able to drive the load 
resistor as fast as a typical (or best case) buffer.  So I would not expect to 
see two identical dt numbers in any of these entries.  (However, I suspect you 
might have just forgotten to edit those numbers to make it look correct).

Anyway, the b) example is definitely incorrect, since the numbers are 
"normalized" over 1 ns and do not follow the measurement rules quoted above.  
The simulator tool needs to know both numbers as would be measured according to 
the rules quoted above.  If someone doesn't provide the numbers that way, there 
is actually loss of information.  We had long discussions on this topic in the 
early days of the Open Forums.

Arpad Muranyi
Intel Corporation
================================================================================

Hello all,

A short question regarding interpretation of a model:

In the IBIS 2.1 spec, the ramp rate is defined as

  dV         20% to 80% voltage swing
  --  = --------------------------------------
  dt    Time to take to swing the above voltage

When I scan through a random set of IBIS models, I see the
following entries after the [Ramp] keyword of the following
types:

a)     dV/dt_r      1.84/0.65n 1.77/0.65n 1.87/0.53n

b)     dV/dt_r         4.1/1n          1.6/1n          8.2/1n

From my point of view, a) is correct, but b) is not good.

I would like to be able to extract dV and dt individually.
As [Ramp] is an obligatory keyword, I hoped it would be
safe to do so .... until I saw b).

Thanks for your help,
John

--
John Fitzpatrick   <[email-masked]>
Alcatel CIT, 4 rue de Broglie, 22304 Lannion, France
Tel: (+33)96.04.79.33  Fax: (+33)96.04.85.09

Text item: External Message Header

The following mail header is for administrative use
and may be ignored unless there are problems.

***IF THERE ARE PROBLEMS SAVE THESE HEADERS***.

Subject: Use of [Ramp] keyword
To: [email-masked]
Organization: Alcatel CIT, 22304 Lannion, France
From: FITZPATRICK John <[email-masked]>
Date: Wed, 15 May 1996 12:07:55 +0200
Sender: [email-masked]
; Wed, 15 May 1996 12:04:50 +0200 (METDST)
Received: from alcatel.fr (gatekeeper-ssn.alcatel.fr [155.132.180.244]) by mailg
ate.alcatel.fr (8.7.3/8.7.3) with ESMTP id LAA09302 for <[email-masked]>; W
ed, 15 May 1996 11:06:59 +0200
Received: from alcatel.fr (ns.alcatel.fr [194.133.58.131]) by vhdl.vhdl.org (8.7
.3/8.7.3) with ESMTP id DAA01389 for <[email-masked]>; Wed, 15 May 1996 03:
14:06 -0700 (PDT)
Received: from vhdl.vhdl.org (vhdl.vhdl.org [198.31.14.3]) by ormail.intel.com (
8.7.4/8.7.3) with ESMTP id DAA19342; Wed, 15 May 1996 03:08:51 -0700 (PDT)
Received: from ormail.intel.com (ormail.intel.com [134.134.192.3]) by relay.jf.i
ntel.com (8.7.4/8.7.3) with ESMTP id DAA11538; Wed, 15 May 1996 03:08:52 -0700 (
PDT)
Return-Path: [email-masked]

---

From: FITZPATRICK John <[email-masked]>
Date: Wed, 15 May 1996 18:55:24 +0200

Hello all,

Thanks to everyone who replied to my question.

It looks like I'm slowly getting to understand the spec! 
The general view is that b) is indeed wrong.

Example b) is an LVT18504 model that Sri Jandhyala (TI) sent me a few 
months ago when I was interested in seeing how bus-hold can
be modelled.

Example a) is from the CMOS_I/O buffer of Pentium(R)_Pro_Processor,
pentpro.ibs, revision 2.1.

I was interested by Arpad's remark that the "a) example might not 
be 100% correct, since it shows the same number for dt 
in the typical and minimum places."  As the pentpro has
rising and falling waveforms, I guess I should really use them
instead of relying on [Ramp].

Thanks again for your help.
John

ps
Is it possible to search the mail archive? I may have other
such questions that were surely answered long before I got
to know about IBIS

---------------------------------------------------------
Hello all,

Thanks for your help,
John