Subject: IBIS at >400MHz

From: Paul Gregory <[email-masked]>
Date: Fri, 3 Oct 97 12:34:01 MDT

In future designs, we plan to use interfaces that 
reach beyond 400 MHz.  As I think about the tools 
that we need to help us successfully design at that 
speed, simulation is going to be a big part of it.  
But I am concerned that IBIS descriptions and 
simulation techniques may not be adequate to accurately 
simulate at that speed.  Perhaps SPICE simulation 
will be required.

Should IBIS based simulators be capable of accurate 
simulation at speed of 400MHz to 1000MHz?  

When device parasitics play a larger part of the 
equation, is IBIS sufficiently robust to accurately 
describe these parasitics?

What are the key factors to consider when simulating
at these higher frequencies?

What are your thoughts?

 -- Paul Gregory

   phone: (208) 396-5086               USmail: Hewlett-Packard
     fax: (208) 396-4122                       M/S 143
   email: [email-masked]                  11311 Chinden Blvd.
                                               Boise, ID  83714

---

From: [email-masked] ( Bob Ross)
Date: Thu, 9 Oct 1997 12:14:06 -0700 (PDT)

Paul:

You raise some very good points and questions.  I don't
have definitive answers.  I support using Spice simulation
and measurement as part of the design methodology along 
with IBIS based behavioral simulation.  I would expect
that as specific IBIS format limitations are identified
with respect to higher frequency simulation accuracy,
proposals to ammend the IBIS format will be made.

Eric Blomberg in "IBIS "models" come of age" in the October 1997
issue of Printed Circuit Design. p. 20 provides a very concise
paragraph that addresses your points and provides some thoughts.
Eric's paragraph follows:

  "Can I use IBIS models for my 600 MHz bus?" The simplest
  answer is yes - if the IBIS provider has validated the
  model at 600 MHz.  It is true that the device effects which
  are simplified out of the IBIS model format start to become
  visible about 300 MHz.  It is also true that other effects,
  such as dielectric loss, and the modeling engine's way of
  handling this become significant as well.  Device package
  models play a larger role.  The expectation answer is that
  above 300 MHz, validation becomes a part-by-part issue for
  the entire modeling system.

Bob Ross
Interconnectix

> From: Paul Gregory <[email-masked]>
> Message-Id: <[email-masked]>
> Subject: IBIS at >400MHz
> To: [email-masked]
> Date: Fri, 3 Oct 97 12:34:01 MDT

---

From: "Mellitz, Richard" <[email-masked]>
Date: Mon, 13 Oct 1997 09:31:52 -0400

Hi folks,

Can IBIS help at > 400 MHz. Maybe. 

Here's my opinion (mostly babbling):

At < 100 MHz we can talk about register to register 
transactions. We can talk about a simple algebraic 
equation. Clock to out, flight time, setup etc. 
Simple, eh? Maybe we even through in fudge 
factors for clock uncertainty and SSO.

At > 100 MHz there are more players; statistical 
com theory, feedback, and crazy types of dispersion 
to name few.  You need to understand these to 
develop design guidelines. For these you need just 
about every tool and trick you can muscle up. No tool 
alone is sufficient. You need to do some "real hard 
to make measurements" too. I guess this validation 
stuff is your basic a multi-dimensional task ;-)
Who knows? You may get lucky and find a case 
where simple IBIS alone will work for you.  

After all that, the IBIS tools can be relegated the
mammoth work horse task at the system level to 
being the "bell ringer" for problems you may want 
to look at closer.  The real trick is to figure out
what bells to ring and how loud to ring them.
Anyone got any bells?

Richard Mellitz, NCR

>----------
>From: 	[email-masked][SMTP:[email-masked]]
>Sent: 	Thursday, October 09, 1997 3:14 PM
>To: 	[email-masked]; [email-masked]
>Cc: 	[email-masked]
>Subject: 	Re:  IBIS at >400MHz
>
>Paul:
>