Subject: Re: examples needed for IBIS V3.1

From: Stephen Peters <[email-masked]>
Date: Fri, 06 Jun 1997 08:59:52 -0700

Hello All:

    I've been reading the mail talking about adding examples to the 
spec and/or the cookbook.  It's a very good idea, especially in
regards to the cookbook.  Do you, the dedicated users of IBIS, have
some specific examples in mind?  Also, are there some specific areas of the
spec that needs explanation or was particularly difficult to understand?
I am in the process of updateing the cookbook for presentation at the
IBIS face to face at DAC next week and your suggestions for
cookbook improvement would be helpfull.

               Thanks,
               Stephen Peters
               Intel Corp.

---

From: Andy Ingraham <[email-masked]>
Date: Sat, 7 Jun 97 16:58:32 EDT

D. C. Sessions wrote:

> Just to be contrary, I'd think that it is better to have
> several VERY simple examples rather than one complex one
> where the (terrified) user has a hard time finding what 
> she needs.

I whole-heartedly agree!

We already have example fragments with all the keywords and
many of the optional parameters, right in the IBIS spec
document itself.  What we need are plain and simple examples
with only what's needed to get started.  All the extra
keywords and parameters come with experience and fine-tuning.

There is/was an example file with the version 1.0 spec. 
In fact I think it's still there.  Try this URL:
ftp://ftp.vhdl.org/pub/ibis/ver1.0/n74f244n.ibs

Some of the models in the ibis/models/ directory also might
be worth using.  Unfortunately, that directory seems to have
fallen into disrepair these days....

Regards,
Andy Ingraham