Subject: Re: about offseting the pu and pc

From: [email-masked] (Syed Huq)
Date: Tue, 4 Mar 97 13:24:11 PST

Aurtur,

If each voltage table gets offset by it's respective Vcc, how
do you still end up with one voltage col that is applicable 
to all three current columns ?

For example, If I sweep from Vcc to 2Vcc, I get the following

For TYP, sweep range is : 3.3V to 6.6V
    MIN, sweep range is : 3.0V to 6.0V
    MAX, sweep range is : 3.6V to 7.2V

After Vcc offset for each table,

    TYP range is : 0.0 to -3.3V (offset by 3.3V)
    MIN range is : 0.0 to -3.0V (offset by 3.0V)
    MAX range is : 0.0 to -3.6V (offest by 3.6V)

How do you end up with one voltage col that is applicable to
all there current columns ?? The datapoints are different for
each voltage table.

Regards,
Syed.

> From [email-masked] Tue Mar  4 12:46:09 1997
> From: Arthur Wong <[email-masked]>
> Date: Tue, 4 Mar 1997 12:34:58 -0800
> To: [email-masked], [email-masked]
> Subject: Re: about offseting the pu and pc
> 
> 
> Hi Syed,
> 
> s2ibis2 uses the supply voltage corresponding to the current column.
> For example, Vcc=3.0v for the min current column; Vcc=3.6v for the max column.
> 
> This would make all three curves go through the origin.
> 
> Regards,
> Arthur Wong
> IDT
> 
> 
> > From [email-masked] Tue Mar  4 11:51:05 1997
> > Date: Tue, 4 Mar 97 11:20:32 PST
> > From: [email-masked] (Syed Huq)
> > To: [email-masked]
> > Subject: about offseting the pu and pc
> > Content-Length: 570
> > 
> > Hi,
> > 
> > I have a ques on the Vcc offseting of the pu(Pullup) and 
> > pc(Power Clamp) V/I data.
> > 
> > I am creating a CMOS model with 3.3V supply. This means
> > TYP=3.3V, MIN=3.0V and MAX=3.6V
> > 
> > There is 'one' voltage table for the three current table.
> > When I use the Vtable = Vcc - Vmeas to offset the voltage
> > table, 'Which' Vcc should be used ??
> > 
> > If I use 3.3V, only the TYP curve goes thru the 0,0 point
> > and the MIN and MAX will not ! The 0,0 point is when 
> > Vcc=Voh (pu curve)
> > 
> > I am not sure how s2ibis2 handles this issue.
> > 
> > Pls comment.
> > 
> > Regards,
> > Syed.
> > National Semiconductor Corp.
> > 
>

---

From: [email-masked]
Date: Tue, 4 Mar 1997 17:15:24 -0500 (EST)

Syed,

This is handled by fixing the sweep range for all three curves to be
equal to the TYP curve sweep range, and then

    - if it's a ground clamp or pulldown curve, setting the sweep
      starting voltage to be the same for all three columns. Thus you get:

            TYP: -3.3V to 6.6V
            MIN: -3.3V to 6.6V
            MAX: -3.3V to 6.6V

    - if it's a power clamp or pullup curve, offsetting the sweep
      starting voltage for the MIN and MAX columns by (Vcc_min -
      Vcc_typ) and (Vcc_max - Vcc_typ), respectively. Thus you get:

            TYP: 6.6V to -3.3V  (Vcc = Vcc_typ = 3.3V)
            MIN: 6.3V to -3.6V  (Vcc = Vcc_min = 3.0V)
            MAX: 6.9V to -3.0V  (Vcc = Vcc_max = 3.6V)

Thus for all three columns Vtable is the same.

Regards,

Alan

-- 
Alan Glaser                         "It's not a competition,
ECE Dept.                            it's just a mint..." - K
North Carolina State University